VCSC Presence works with MOVI 4.2, but not 4.3. But it works with the VCSE

Unanswered Question
Apr 12th, 2012
User Badges:

Good evening,

I have run into an issue with a VCSC. For some reason, Presence information doesnt seem to reach any MOVI client registered to the VCSC. The odd part of it is it is just specific to Jabber client 4.3 and greater. When I register the same client to the VCSE, it registers fine.

Has anyone else ran into this? I just blew away the majority of the config and rebuilt it, but the issue still remains.

Aside from just the presence information, all other calling works on the VCSC.

Any help to narrow this one down would be greatly appreciated.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Alok Jaiswal Thu, 04/12/2012 - 21:32
User Badges:
  • Silver, 250 points or more


Does the jabber report any error when it doesn't get the presence information like error code 403 or any thing else.

Its odd if its not working only with jabber.?

Check the provisioning directory. while defining the server URI'sI did you explicitly mentioned any movi/jabber version.

Also a diagnostic logs on VCS will help to get more information about the presence issue.



Darren Lapierre Fri, 04/13/2012 - 04:10
User Badges:

So there is no error from the client itself.

The uri for presence has not changed. I did load the specific template for 4.3 and 4.4 to TMS and defined specific presence uri's in hopes that would correct this, but it did not.

I will load the diag log to this post shortly.

Sent from Cisco Technical Support iPad App

Alok Jaiswal Fri, 04/13/2012 - 11:24
User Badges:
  • Silver, 250 points or more

Hi Darren,

I would have prefered if you can open a TAC case on this for further troubleshooting.

However just to give a hint i see the 200OK for presence event so it should have worked.

Apr 13 07:07:08 prd-vcsc-01 tvcs: UTCTime="2012-04-13 13:07:08,697" Module="network.sip" Level="INFO":  Dst-ip=""  Dst-port="56599"   Detail="Sending Response Code=200, Method=PUBLISH, To=sip:[email protected], [email protected]"

Apr 13 07:07:08 prd-vcsc-01 tvcs: UTCTime="2012-04-13 13:07:08,697" Module="network.sip" Level="DEBUG":  Dst-ip=""  Dst-port="56599"


|SIP/2.0 200 OK



Darren Lapierre Fri, 04/13/2012 - 11:40
User Badges:

That s what I see too. There is no sound reason why it is not working.

And it only effects 4.3 clients and newer.

I will open a ticket shortly.

Sent from my Android phone using TouchDown (

t.svatek Fri, 04/13/2012 - 13:30
User Badges:

Hi Darren,

Same here. Could you keep us informed about the TAC Case?



Sent from Cisco Technical Support iPhone App

Darren Lapierre Fri, 04/13/2012 - 18:34
User Badges:


I definitely will keep you updated on the ticket.


Sent from Cisco Technical Support iPad App

rasimyigit Sat, 04/14/2012 - 01:53
User Badges:


Could you try to remove the templates and try as a default. I got the same problem and I solved with no template using;-)

Sent from Cisco Technical Support iPad App

Darren Lapierre Sat, 04/14/2012 - 06:15
User Badges:
Good thought! I pulled all the templates off of TMS provisioning directory. Unfortunately, the issue still occurs.
t.svatek Mon, 05/07/2012 - 04:33
User Badges:

Hi Darren,

have you been able to solve this issue with TAC?



Darren Lapierre Mon, 05/07/2012 - 05:10
User Badges:

No, I was not.

There is some account thing that is not allowing me to work with Cisco TAC to resolve the issue (Equipment was purchased through OnX, while my company, igniteCSG (we are a Cisco partner, as well) provides services and support).

So, I am taking it up with Cisco services to figure out how this can be done.

And the issue is still occurring.


Jason Neurohr Mon, 05/21/2012 - 18:11
User Badges:

I'm seeing the same behaviour with Movi 4.2 working but Movi 4.3/4.4 not working. Attempting to get a TAC case open as well for the issue.

aldepar_tel Tue, 07/17/2012 - 00:52
User Badges:


Any news from the TAC? The same problem here. If someone know the solution, please, post it here.

Thank you in advance.

Fabian Tscherner Mon, 01/13/2014 - 05:56
User Badges:

We've had quite similar issue with VCS-C and VCS-E (X7.1) scenario.

VCS-C is the registering clients against the AD, but all clients has to be proxied from the VCS-E to the VCS-C.

VCS-E has no DNS Zone with any matching SearchRule (therefore there is another VCS-E in this scenario).

Presence was also only working if we used JabberVideo client 4.2 and/or clients were directly registered to VCS-C (which is not allowed in our scenario).

After diagnostic log analyzes, we've noticed the difference between working and not working cases:


Contact: IP_ADDRESS_CLIENT:2524;transport=tls>


Contact: DOMAIN;gr=urn:uuid:xyz>

After that we've recognized, SIP GRUU function makes the difference.

It seems that the 4.2 client ignores or breaks the GRUU function offer from VCS and the new clients are ready to deal with it.

In consequence we've deactivated SIP GRUU Mode on VCS-C by entering:

xConfiguration SIP GRUU Mode: Off

Result: we've got also running PresenceStatus for JabberVideo clients >4.2  (mainly tested with Version 4.7).


This Discussion