Voice gateway sends no busy tone to external calls

Answered Question
May 17th, 2012

Hi,

we have Cisco phones with callmanager behind cisco ISDN to H.323 gateway. Calls placed

from outside dont hear busy tone. Inbound calls between phones works fine. Problem should

be on voice gateway. Do you have any ideas?

Close to our problem is described in

http://www.cisco.com/en/US/tech/tk652/tk653/technologies_tech_note09186a0080111b58.shtml

But it was no help. Any help appreciated.

In the included file is debug from debug isdn 921 and debug isdn 931.

call

from 667

to  221466370

is inbound call

call

from 605221474

to 667

is call from outside which doesnt hear busy tone

Attachment: 
I have this problem too.
0 votes
Correct Answer by acampbell about 1 year 11 months ago

Jan,

I think your issue is being caused by the
voice application "name" which is running on your
dial peer voice 1 pots.

I am using the show run  fron your post further up


To prove this can you add another dial peer

!
!
dial-peer voice 1111 pots
description *** FOR INCOMING DIAL PEER MATCHING ***
incoming called-number 70
direct-inward-dial
port 0/0/0:15
!

incoming called-number 70
Please correct this match the phone and gateway you are testing.

Try and restest

Regards,
Alex.
Please rate useful posts.

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 4.6 (7 ratings)
acampbell Thu, 05/17/2012 - 06:22

Jan,

Can you post the H323 router config.

Can you also look at the settings for the phone 667.

Look at the LINE and see what the value of the BUSY trigger is.

Regards,
Alex.
Please rate useful posts.

acampbell Thu, 05/17/2012 - 15:58

Jan,

Sorry for the delay.

The Trace file shows calls on s0/0/0:15 channels 30 and then 20

The config file shows that the valid channels only 1-12

!

controller E1 0/0/0

clock source line primary

pri-group timeslots 1-12,16

!

I cannot see how these files can be from the same router.

Regards,
Alex.
Please rate useful posts.

JohnPeca18 Fri, 05/18/2012 - 02:42

Thanks, you are right, because actually we have same problem on 2 gateways with similar configuration. Now I am posting debug session which happened on the gateway I posted configuration. First call is normal connected. Second call is not connected and should hear a busy tone but it doesnt work. I also post show voice call summary where first call is in state CONNECTED and second in PROCEEDING.

Ayodeji oladipo... Fri, 05/18/2012 - 02:58

Jan,

If the busy trigger is set to 1, then you may need an annunciator to provide busy tone. Here is the detail from SRND..

I have removed some parts..

Annunciator

Cisco IOS gateways and intercluster trunks

These devices require support for call progress tone (ringback tone).

System messages

During the following call failure conditions, the system plays a streaming message to the end user:

A dialed number that the system cannot recognize

A call that is not routed due to a service disruption

A number that is busy and not configured for preemption or call waiting

Do you have MRGL on the PSTN gateway? In your MRG, are there ANN in it?

Here is the SRND link..

http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/srnd/8x/media.html#wp1046552

Ayodeji oladipo... Fri, 05/18/2012 - 03:22

Jan,

You could also send debug voip ccapi inout. Thats where we will the PI(progress indicators)

JohnPeca18 Fri, 05/18/2012 - 03:50

We havent MRGL on gateway, so I set it and added annunciator to the list. But it didnt help. I note that ringback tone works fine. I am posting debug you mentioned. There are interesting lines

Progress Indication=NULL(0), Signal Indication=SIGNAL RINGBACK(1), Cause Value=0

   Voice Call Send Alert=FALSE, Call Entry(Alert Sent=FALSE)

Ayodeji oladipo... Fri, 05/18/2012 - 04:00

Jan,

Ok.. so Did you also assign the MRGL to the phones?

May 18 10:28:58.803: //146/16E684618027/CCAPI/ccCallDisconnect:

   Cause Value=17, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=17) May 18 10:28:58.803: //146/16E684618027/CCAPI/ccCallDisconnect:
   Cause Value=17, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=17)

Cause of 17 is because its "user busy" SO we are getting the right disconnect cause from the gateway.

Can you assign the MRGL to the phone and can you please send Detailed CUCM trace for the call if you can..

The thing is CUCM needs to send a busy tone to the PSTN. SO CUCM needs to inform the phone to send the busy tone, just as cucm informs the phone to ring by changing the call state on the phone. So we need to look at what CUCM is telling the phone to do when the call is busy

Correct Answer
acampbell Fri, 05/18/2012 - 04:18

Jan,

I think your issue is being caused by the
voice application "name" which is running on your
dial peer voice 1 pots.

I am using the show run  fron your post further up


To prove this can you add another dial peer

!
!
dial-peer voice 1111 pots
description *** FOR INCOMING DIAL PEER MATCHING ***
incoming called-number 70
direct-inward-dial
port 0/0/0:15
!

incoming called-number 70
Please correct this match the phone and gateway you are testing.

Try and restest

Regards,
Alex.
Please rate useful posts.

JohnPeca18 Fri, 05/18/2012 - 05:12

Yeah you are right! after configuring another dial peer it works. But I really dont understand it, what is the problem?

acampbell Fri, 05/18/2012 - 05:49

Jan,

Sounds like the script is causing some kind of contious hunting

I am not script man

However I would like you to try this

!

voice service voip

h323

no h225 alt-ep hunt user-busy

!

And put your dial peer back to normal

like no dial-peer voice 1111 pots

If you have left in in

Test with retry.

If this does not work then I suggest you raise a new post with a question something like

TCL script does not allow busy tone to PSTN callers

May be one of our TCL gurus can help.

Regards,
Alex.
Please rate useful posts.

JohnPeca18 Fri, 05/18/2012 - 06:11

Thanks much for your help, commands you wrote didnt work so I started new post as you suggested.

Actions

Login or Register to take actions

This Discussion

Posted May 17, 2012 at 2:38 AM
Stats:
Replies:12 Avg. Rating:4.57143
Views:1866 Votes:0
Shares:0

Related Content

Discussions Leaderboard

Rank Username Points
1 21,026
2 15,047
3 10,314
4 7,999
5 4,856
Rank Username Points
154
95
72
66
55