Ping between a real windows7 /XP PC and virtual router in GNS3

Unanswered Question
May 18th, 2012

Dear All,

In spite of giving much effort in making successful ping  between a real windows7 pc and virtual router in GNS3 Topology,I became  unsuccessful to do it.

steps followed:-

1.windows firewall disabled.NO antivirus running.

2.microsoft loopback adapter added (ip-192.168.1.10/24,gw-192.168.1.1)

3.router added in gns3 and configured (ip in interface fa0/0-192.168.1.1/24,no shut given)

4.cloud added and its loopback added to router fa0/0 interface

It is tried for window7 and xp machine.

Kindly help me resolve the problem.

Thanking you.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
johnlloyd_13 Fri, 05/18/2012 - 21:39

Hi,

Kindly post your running config and ipconfig/all from your PC. Make sure you've disabled your wireless adapter coz most of the time it uses the same private IP subnet messes the connectivity.

Sent from Cisco Technical Support iPhone App

nishith_samanta2000 Mon, 05/21/2012 - 03:43

Dear Friend,

Thank u for ur response.

Please find below ipconfig/all output from my PC.

C:\Users\NOC1>ipconfig/all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : NOC-HP

   Primary Dns Suffix  . . . . . . . :

   Node Type . . . . . . . . . . . . : Hybrid

   IP Routing Enabled. . . . . . . . : No

   WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection 2:

   Connection-specific DNS Suffix  . :

   Description . . . . . . . . . . . : Microsoft Loopback Adapter

   Physical Address. . . . . . . . . : 02-00-4C-4F-4F-50

   DHCP Enabled. . . . . . . . . . . : No

   Autoconfiguration Enabled . . . . : Yes

   Link-local IPv6 Address . . . . . : fe80::6d16:38a9:a528:1224%32(Preferred)

   IPv4 Address. . . . . . . . . . . : 9.0.0.9(Preferred)

   Subnet Mask . . . . . . . . . . . : 255.255.255.0

   Default Gateway . . . . . . . . . :

   DHCPv6 IAID . . . . . . . . . . . : 671219788

   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-14-C7-C8-88-6C-62-6D-8F-2A-2C

   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1

                                       fec0:0:0:ffff::2%1

                                       fec0:0:0:ffff::3%1

   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :

   Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller

   Physical Address. . . . . . . . . : 6C-62-6D-8F-2A-2C

   DHCP Enabled. . . . . . . . . . . : No

   Autoconfiguration Enabled . . . . : Yes

   Link-local IPv6 Address . . . . . : fe80::4466:7e11:d9c3:f6bc%12(Preferred)

   IPv4 Address. . . . . . . . . . . : 10.129.7.235(Preferred)

   Subnet Mask . . . . . . . . . . . : 255.255.255.0

   Default Gateway . . . . . . . . . : 10.129.7.1

   DHCPv6 IAID . . . . . . . . . . . : 275538541

   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-14-C7-C8-88-6C-62-6D-8F-2A-2C

   DNS Servers . . . . . . . . . . . : 218.248.240.208

                                       218.248.255.177

                                       10.129.20.211

                                       10.129.20.212

                                       4.4.4.4

                                       8.8.8.8

   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{2C322AA8-6ABF-4168-80DD-1EBC5E7B7864}:

   Media State . . . . . . . . . . . : Media disconnected

   Connection-specific DNS Suffix  . :

   Description . . . . . . . . . . . : Microsoft ISATAP Adapter

   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

   DHCP Enabled. . . . . . . . . . . : No

   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter 6TO4 Adapter:

   Media State . . . . . . . . . . . : Media disconnected

   Connection-specific DNS Suffix  . :

   Description . . . . . . . . . . . : Microsoft 6to4 Adapter

   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

   DHCP Enabled. . . . . . . . . . . : No

   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Teredo Tunneling Pseudo-Interface:

   Connection-specific DNS Suffix  . :

   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface

   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

   DHCP Enabled. . . . . . . . . . . : No

   Autoconfiguration Enabled . . . . : Yes

   IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e76:14e4:39b2:f57e:f814(Preferred)

   Link-local IPv6 Address . . . . . : fe80::14e4:39b2:f57e:f814%30(Preferred)

   Default Gateway . . . . . . . . . :

   NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter isatap.{2A0064A7-9C27-4616-A566-8EAE63601C71}:

   Media State . . . . . . . . . . . : Media disconnected

   Connection-specific DNS Suffix  . :

   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3

   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

   DHCP Enabled. . . . . . . . . . . : No

   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Reusable Microsoft 6To4 Adapter:

   Connection-specific DNS Suffix  . :

   Description . . . . . . . . . . . : Microsoft 6to4 Adapter #2

   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

   DHCP Enabled. . . . . . . . . . . : No

   Autoconfiguration Enabled . . . . : Yes

   IPv6 Address. . . . . . . . . . . : 2002:900:9::900:9(Preferred)

   Default Gateway . . . . . . . . . : 2002:c058:6301::c058:6301

   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1

                                       fec0:0:0:ffff::2%1

                                       fec0:0:0:ffff::3%1

   NetBIOS over Tcpip. . . . . . . . : Disabled

C:\Users\NOC1>

And also find below sh run output from virtual router--

R1#sh run

R1#sh run

Building configuration...

Current configuration : 804 bytes

!

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R1

!

logging queue-limit 100

!

ip subnet-zero

!

!

no ip domain lookup

!

!

!

!

!

!

!

!

!

!

!

!

!

no voice hpi capture buffer

no voice hpi capture destination

!

!

mta receive maximum-recipients 0

!

!

!

!

interface FastEthernet0/0

ip address 9.0.0.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

no ip http server

no ip http secure-server

ip classless

!

!

!

!

!

call rsvp-sync

!

!

mgcp profile default

!

!

!

dial-peer cor custom

!

!

!

!

!

line con 0

exec-timeout 0 0

logging synchronous

line aux 0

line vty 0 4

!

end

R1#

Thanking u all.

johnlloyd_13 Mon, 05/21/2012 - 04:04

You forgot to manually add the default gateway: 9.0.0.1 on your PC.

Sent from Cisco Technical Support iPhone App

nishith_samanta2000 Mon, 05/21/2012 - 04:27

Hello,

I added default gateway 9.0.0.1 but still not working.

C:\Users\NOC1>ipconfig/all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : NOC-HP

   Primary Dns Suffix  . . . . . . . :

   Node Type . . . . . . . . . . . . : Hybrid

   IP Routing Enabled. . . . . . . . : No

   WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection 2:

   Connection-specific DNS Suffix  . :

   Description . . . . . . . . . . . : Microsoft Loopback Adapter

   Physical Address. . . . . . . . . : 02-00-4C-4F-4F-50

   DHCP Enabled. . . . . . . . . . . : No

   Autoconfiguration Enabled . . . . : Yes

   Link-local IPv6 Address . . . . . : fe80::6d16:38a9:a528:1224%32(Preferred)

   IPv4 Address. . . . . . . . . . . : 9.0.0.9(Preferred)

   Subnet Mask . . . . . . . . . . . : 255.255.255.0

   Default Gateway . . . . . . . . . : 9.0.0.1

   DHCPv6 IAID . . . . . . . . . . . : 671219788

   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-14-C7-C8-88-6C-62-6D-8F-2A-2C

   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1

                                       fec0:0:0:ffff::2%1

                                       fec0:0:0:ffff::3%1

   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :

   Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller

   Physical Address. . . . . . . . . : 6C-62-6D-8F-2A-2C

   DHCP Enabled. . . . . . . . . . . : No

   Autoconfiguration Enabled . . . . : Yes

   Link-local IPv6 Address . . . . . : fe80::4466:7e11:d9c3:f6bc%12(Preferred)

   IPv4 Address. . . . . . . . . . . : 10.129.7.235(Preferred)

   Subnet Mask . . . . . . . . . . . : 255.255.255.0

   Default Gateway . . . . . . . . . :

   DHCPv6 IAID . . . . . . . . . . . : 275538541

   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-14-C7-C8-88-6C-62-6D-8F-2A-2C

   DNS Servers . . . . . . . . . . . : 218.248.240.208

                                       218.248.255.177

                                       10.129.20.211

                                       10.129.20.212

                                       4.4.4.4

                                       8.8.8.8

   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{2C322AA8-6ABF-4168-80DD-1EBC5E7B7864}:

   Media State . . . . . . . . . . . : Media disconnected

   Connection-specific DNS Suffix  . :

   Description . . . . . . . . . . . : Microsoft ISATAP Adapter

   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

   DHCP Enabled. . . . . . . . . . . : No

   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter 6TO4 Adapter:

   Media State . . . . . . . . . . . : Media disconnected

   Connection-specific DNS Suffix  . :

   Description . . . . . . . . . . . : Microsoft 6to4 Adapter

   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

   DHCP Enabled. . . . . . . . . . . : No

   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Teredo Tunneling Pseudo-Interface:

   Media State . . . . . . . . . . . : Media disconnected

   Connection-specific DNS Suffix  . :

   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface

   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

   DHCP Enabled. . . . . . . . . . . : No

   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{2A0064A7-9C27-4616-A566-8EAE63601C71}:

   Media State . . . . . . . . . . . : Media disconnected

   Connection-specific DNS Suffix  . :

   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3

   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

   DHCP Enabled. . . . . . . . . . . : No

   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Reusable Microsoft 6To4 Adapter:

   Connection-specific DNS Suffix  . :

   Description . . . . . . . . . . . : Microsoft 6to4 Adapter #2

   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

   DHCP Enabled. . . . . . . . . . . : No

   Autoconfiguration Enabled . . . . : Yes

   IPv6 Address. . . . . . . . . . . : 2002:900:9::900:9(Preferred)

   Default Gateway . . . . . . . . . : 2002:c058:6301::c058:6301

   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1

                                       fec0:0:0:ffff::2%1

                                       fec0:0:0:ffff::3%1

   NetBIOS over Tcpip. . . . . . . . : Disabled

C:\Users\NOC1>

Thanking You.

Cadet Alain Mon, 05/21/2012 - 05:27

Hi,

I don't see any loopback adapter in your ipconfig output.

Regards.

Alain

nishith_samanta2000 Mon, 05/21/2012 - 05:53

Hello,

Here is the loopback adapter:-

Ethernet adapter Local Area Connection 2:

   Connection-specific DNS Suffix  . :

   Description . . . . . . . . . . . : Microsoft Loopback Adapter

   Physical Address. . . . . . . . . : 02-00-4C-4F-4F-50

   DHCP Enabled. . . . . . . . . . . : No

   Autoconfiguration Enabled . . . . : Yes

   Link-local IPv6 Address . . . . . : fe80::6d16:38a9:a528:1224%32(Preferred)

   IPv4 Address. . . . . . . . . . . : 9.0.0.9(Preferred)

   Subnet Mask . . . . . . . . . . . : 255.255.255.0

   Default Gateway . . . . . . . . . : 9.0.0.1

   DHCPv6 IAID . . . . . . . . . . . : 671219788

   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-14-C7-C8-88-6C-62-6D-8F-2A-2C

   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1

                                       fec0:0:0:ffff::2%1

                                       fec0:0:0:ffff::3%1

   NetBIOS over Tcpip. . . . . . . . : Enabled

Cadet Alain Mon, 05/21/2012 - 06:16

Hi,

ok I missed it but then how come the addressing is different from this ? :

2.microsoft loopback adapter added (ip-192.168.1.10/24,gw-192.168.1.1)

Regards.

Alain

johnlloyd_13 Mon, 05/21/2012 - 06:36

Further adding to Alain's comment, could you post your router's show ip interface brief and show ip arp.

Make sure you've selected the MS loopback adapter in GNS3 cloud.

Sent from Cisco Technical Support iPhone App

Nandan Mathure Mon, 05/21/2012 - 06:57

Hi Nishith,

As John asked, also paste the screeshot of Cloud Configuration like NIO Ethernet.

Thanks,

Nandan

nishith_samanta2000 Mon, 05/21/2012 - 08:12

R1#sh ip int br

R1#sh ip int brief

Interface                  IP-Address      OK? Method Status                Protocol

FastEthernet0/0            9.0.0.1         YES NVRAM  up                    up 

FastEthernet0/1            unassigned      YES NVRAM  administratively down down

Virtual-Access1            unassigned      YES unset  up                    up

R1#sh arp

Protocol  Address          Age (min)  Hardware Addr   Type   Interface

Internet  9.0.0.9                21   0200.4c4f.4f50  ARPA   FastEthernet0/0

Internet  9.0.0.1                 -   c400.25c8.0000  ARPA   FastEthernet0/0

R1#sh run

Building configuration...

Current configuration : 811 bytes

!

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R1

!

logging queue-limit 100

!

ip subnet-zero

!

!

no ip domain lookup

!

!

!

!

!

!

!

!

!

!

!

!

!

no voice hpi capture buffer

no voice hpi capture destination

!

!

mta receive maximum-recipients 0

!

!

!

!

interface FastEthernet0/0

ip address 9.0.0.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

no ip http server

no ip http secure-server

ip classless

!

!

!

!

!

call rsvp-sync

!

!

mgcp profile default

!

!

!

dial-peer cor custom

!

!

line con 0

exec-timeout 0 0

logging synchronous

line aux 0

line vty 0 4

login

!

end

R1#

notice MS loopback adapter has been selected in GNS3 cloud.

Nandan Mathure Mon, 05/21/2012 - 09:20

I recreated this on my PC works without any issues:

1] I added MS-Loopback , assigned IP statically IP :10.10.10.10 MASK : 255.255.255.0 GW:10.10.10.1

2] Restarted the PC

3] In GN3 i assigned the MS-Loopback to cloud.

4] Connected the Router to the Cloud with Fa0/0

5] Router Fa0/0 IP: 10.10.10.1 Mask 255.255.255.0

6] Ping from Router to PC = Success

7] Ping from PC to Router = Success

I tested this on XP machine. If its still not working, then delete the loopback, recreate step by step and let us know if it works.

Regards,

Nandan

Cadet Alain Mon, 05/21/2012 - 23:02

Hi,

if you shutdown/ no shutdown the f0/0 on R1 is the ping working now ?

Regards.

Alain

Nandan Mathure Mon, 05/21/2012 - 23:40

Hi Nishith,

Could you post the output for "debug ip icmp" and "debug ip packet detail" when you start pinging from PC to ROUTER and ROUTER to PC ?

Thanks,

Nandan Mathure

nishith_samanta2000 Tue, 05/22/2012 - 00:16

Hi Nandan,

R1#debug ip icmp

ICMP packet debugging is on

R1#ping 10.10.10.10

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.10.10.10, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

R1#

R1#debug ip packet detail

IP packet debugging is on (detailed)

R1#ping 10.10.10.10

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.10.10.10, timeout is 2 seconds:

*Mar  1 01:07:33.551: IP: s=10.10.10.1 (local), d=10.10.10.10 (FastEthernet0/1), len 100, sending

*Mar  1 01:07:33.555:     ICMP type=8, code=0.

*Mar  1 01:07:35.551: IP: s=10.10.10.1 (local), d=10.10.10.10 (FastEthernet0/1), len 100, sending

*Mar  1 01:07:35.551:     ICMP type=8, code=0.

*Mar  1 01:07:37.551: IP: s=10.10.10.1 (local), d=10.10.10.10 (FastEthernet0/1), len 100, sending

*Mar  1 01:07:37.551:     ICMP type=8, code=0.

*Mar  1 01:07:39.551: IP: s=10.10.10.1 (local), d=10.10.10.10 (FastEthernet0/1), len 100, sending

*Mar  1 01:07:39.551:     ICMP type=8, code=0.

*Mar  1 01:07:41.551: IP: s=10.10.10.1 (local), d=10.10.10.10 (FastEthernet0/1), len 100, sending

*Mar  1 01:07:41.551:     ICMP type=8, code=0.

Success rate is 0 percent (0/5)

R1#

Regards,

Nishith

Cadet Alain Tue, 05/22/2012 - 01:04

Hi,

isn't your loopback 9.0.0.9 ? so why not pinging this first ?

Can you do this with the windows firewall turned off and also do the debug again as well as sniff your loopback on Windows

and the f0/0 interface on GNS3 with wireshark.

Regards.

Alain

nishith_samanta2000 Tue, 05/22/2012 - 02:22

hello alain,my current loopback ip-10.10.10.10/24,gw-10.10.10.1

router ip-10.10.10.1/24

PLS find below packet capture on loopback interface:-

notice in we see reply from pc but not from router.

but actually I cant see any reply in both direction

Cadet Alain Tue, 05/22/2012 - 02:48

When you ping from loopback to router what is telling the debug ip icmp on the router ?

Regards.

Alain

johnlloyd_13 Tue, 05/22/2012 - 05:12

hi,

can you post a screenshot of your network info and setup? go to control panel > network and internet > network and sharing center. as suggested previously, make sure you've temporarily disabled other NICs (especially wifi) and select the proper network (i use mine as home network/group) for the MS loopback NIC/network.

http://windows.microsoft.com/en-us/windows7/Choosing-a-network-location

nishith_samanta2000 Mon, 05/28/2012 - 20:35

Dear All,

It is now pinging.the problem was with the rouge image.After i changed the it just worked fine.

Regards

Actions

Login or Register to take actions

This Discussion

Posted May 18, 2012 at 7:20 PM
Stats:
Replies:24 Avg. Rating:
Views:3658 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard