×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

etherchannel does not go up/up from 3750 stack to 6k5 vss

Unanswered Question
May 20th, 2012
User Badges:

We have two 6k5 configured as vss and it is working fine. For each floor we have a 3750 stack. In each 3750 stack we have 4 switches. From the first 3750 we have a fiber link to the first 6k5 and from the fourth switch we have another fiber link to the other 6k5 switch, for each floor/3750 stack, both configured as etherchannel. We installled each 3750 stack/floor in different maintenance windows; in all these installations we have problems configuring the etherchannel. After we configure the etherchannel on 3750 stack and in the vss, the etherchannel does not go up/up. We see the etherchannel up/down; after a lot off work, try and error, configuring shut/ no shut, adding and excluding links from the etherchannel; in any aleatory moment the etherchannel goes up/up and works fine. Is there any bug related with these IOS versions, or is there any right procedure to configure etherchannel from vss to 3750 stack?

3750 stack config (IOS

Cisco IOS Software, C3750 Software (C3750-IPBASEK9-M), Version 12.2(50)SE1, RELEASE SOFTWARE (fc2)

)

interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100,101,371,372
switchport mode trunk
channel-group 1 mode on
!
interface GigabitEthernet4/0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100,101,371,372
switchport mode trunk
channel-group 1 mode on
!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100,101,371,372
switchport mode trunk

6k5 vss config (IOS

Cisco IOS Software, s72033_rp Software (s72033_rp-IPSERVICESK9_WAN-VM), Version 12.2(33)SXI4a, RELEASE SOFTWARE (fc2)

)

interface Port-channel170
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100,101,371,372

switchport mode trunk
!
interface GigabitEthernet1/1/8
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100,101,371,372
switchport mode trunk
channel-group 170 mode on
!
interface GigabitEthernet2/1/8
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100,101,371,372
switchport mode trunk
channel-group 170 mode on
                   

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Leo Laohoo Sun, 05/20/2012 - 17:07
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Config looks fine.  Can I ask if you can post the "sh log" of both 3750 and the 6500 chassis?


Another thing, when dealing with 6500 chassis, it doesn't like when you "add" and "remove" VLANs from the port channels.  Usually, I would have to REMOVE the port channel interface and also remove the physical interface's port-channel assignment and then re-add the port-channel assignment (which will re-create the port-channel interface).

claudiols Sun, 05/20/2012 - 18:13
User Badges:

Thanks leolahoo; I am not adding/removing vlans on channels; the customer complain that to make the channel up/up they had to make many actions shutting/no shutting, adding/removing the links from the channel. We made this king off configuration on other customers and it worked fine. I really beliave that it is some bug; but would like some some other suggestion from the community

Leo Laohoo Sun, 05/20/2012 - 18:31
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Please post the "sh logs".  I would like to see what the logs says when the etherchannel and/or the physical interface(s) go up and down.

claudiols Sun, 05/20/2012 - 18:41
User Badges:

sorry, but we does not have the show logs for the moments with problem

claudiols Mon, 05/21/2012 - 18:20
User Badges:

In the link http://www.cciezone.com/?p=167 is reported the same problem that I having in customer, and the workaround is dificult to realize in a troubleshooting activity. Does anyone have any comments or had the same problem?

glen.grant Mon, 05/21/2012 - 18:47
User Badges:
  • Purple, 4500 points or more

  The only thing to verify is to make sure the 3750 stack is actually wired and operating correctly and you don't have something like a split stack somehow.  Config looks ok .   You could try setting it up using lacp instead of trying to force the port channel on .

claudiols Mon, 05/21/2012 - 20:48
User Badges:

thanks glen.grant, with your comment I realize that my stack have problem, I will fix this and try again the config

------------------ show switch stack-ring speed ------------------


Stack Ring Speed        : 16G
Stack Ring Configuration: Half
Stack Ring Protocol     : StackWise

------------------ show switch detail ------------------


Switch/Stack Mac Address :
May 20 04:54:37.425 GMT-3: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet2/0/48, changed state to up 04c5.a438.7f00
                                           H/W   Current
Switch#  Role   Mac Address     Priority Version  State
----------------------------------------------------------
*1       Master 04c5.a438.7f00     15     0       Ready              
2       Member 04c5.a438.8180     13     0       Ready              
3       Member 04c5.a430.1280     11     0       Ready              
4       Member 04c5.a438.4b00     9      0       Ready              


         Stack Port Status             Neighbors    
Switch#  Port 1     Port 2           Port 1   Port 2
--------------------------------------------------------
  1        Ok         Ok                2        4
  2        Ok         Ok                3        1
  3       Down        Ok              None       2
  4        Ok        Down               1      None


Actions

This Discussion