×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Cisco 878 - Transparent Bridging

Unanswered Question
May 23rd, 2012
User Badges:

                   Hello everybody,

I have got two 878 integrated services routers and I need to configure them as transparent bridges in order to connect 2 remote sites over ATM.

As I'm testing the topology, I configured two switches (representing the sites) at each end with a VTP domain. VTP works while the switches are connected directly with eachother, but it won't work with the bridges in the middle.

Has anyone had a similar issue before?

Test.jpg

The configuration is identical on both routers, as follows:


Current configuration : 1228 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname XXXXXX

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

!

no aaa new-model

!

!

dot11 syslog

ip source-route

no ip routing

!

!        

!

!

no ip cef

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

vtp domain IE

vtp mode transparent

!

!

!

archive

log config

  hidekeys

!

!

controller DSL 0

mode atm

line-rate 2048

!        

vlan 10

!

vlan 1002

ring 0

!

vlan 1003

parent 0

!

vlan 1004

bridge 0

stp type ieee

!

!

!

!

interface BRI0

no ip address

encapsulation hdlc

no ip route-cache

shutdown

!

interface ATM0

no ip address

no ip route-cache

no atm ilmi-keepalive

pvc 8/35

  encapsulation aal5snap

!

bridge-group 1

!

interface FastEthernet0

switchport mode trunk

!

interface FastEthernet1

switchport mode trunk

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Vlan1

no ip address

no ip route-cache

bridge-group 1

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

!

!

!

!

!

!

control-plane

!

bridge 1 protocol ieee

!

line con 0

no modem enable

line aux 0

line vty 0 4

login

!

scheduler max-task-time 5000

end

Cisco IOS Software, C870 Software (C870-ADVIPSERVICESK9-M), Version 12.4(24)T7, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2012 by Cisco Systems, Inc.
Compiled Tue 28-Feb-12 14:33 by prod_rel_team

ROM: System Bootstrap, Version 12.3(8r)YI4, RELEASE SOFTWARE

Client uptime is 3 hours, 57 minutes
System returned to ROM by reload
System image file is "flash:c870-advipservicesk9-mz.124-24.T7.bin"
Last reload reason: Reload Command


Current configuration : 1228 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname XXXXXX
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
!
!
dot11 syslog
ip source-route
no ip routing
!
!        
!
!
no ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
vtp domain IE
vtp mode transparent
!
!
!
archive
log config
  hidekeys
!
!
controller DSL 0
mode atm
line-rate 2048
!        
vlan 10
!
vlan 1002
ring 0
!
vlan 1003
parent 0
!
vlan 1004
bridge 0
stp type ieee
!
!
!
!
interface BRI0
no ip address
encapsulation hdlc
no ip route-cache
shutdown
!
interface ATM0
no ip address
no ip route-cache
no atm ilmi-keepalive
pvc 8/35
  encapsulation aal5snap
!
bridge-group 1
!
interface FastEthernet0
switchport mode trunk
!
interface FastEthernet1
switchport mode trunk
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
no ip address
no ip route-cache
bridge-group 1
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
control-plane
!
bridge 1 protocol ieee
!
line con 0
no modem enable
line aux 0
line vty 0 4
login
!
scheduler max-task-time 5000
end


The ATM interfaces are up.


show version (partial):


Cisco IOS Software, C870 Software (C870-ADVIPSERVICESK9-M), Version 12.4(24)T7, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2012 by Cisco Systems, Inc.
Compiled Tue 28-Feb-12 14:33 by prod_rel_team

ROM: System Bootstrap, Version 12.3(8r)YI4, RELEASE SOFTWARE

Client uptime is 3 hours, 57 minutes
System returned to ROM by reload
System image file is "flash:c870-advipservicesk9-mz.124-24.T7.bin"
Last reload reason: Reload Command


Everything seems to be fine except for the VTP cannot reach the vtp client switch..

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 2.5 (2 ratings)
Loading.
Richard Burts Sat, 05/26/2012 - 19:26
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

I have examined the configs that you have posted. And from a bridging perspective I believe that they are fine.


Perhaps I am not correctly understanding your question. You say that the VTP cannot reach the vtp client switch. And I do not understand this since both switches seem to configure the VTP mode as transparent. So in this mode there is not a client switch.


Perhaps you can clarify the issue so that I understand it better?


HTH


Rick

Konstantinos Le... Sun, 05/27/2012 - 12:36
User Badges:

Thank you for your response, Rick!!

Richard Burts wrote:


I have examined the configs that you have posted. And from a bridging perspective I believe that they are fine.


Perhaps I am not correctly understanding your question. You say that the VTP cannot reach the vtp client switch. And I do not understand this since both switches seem to configure the VTP mode as transparent. So in this mode there is not a client switch.


Perhaps you can clarify the issue so that I understand it better?


HTH


Rick

You 're right. I must clarify that the switches I'm using are two separate 3560 devices (apart from the two 878 routers). The configs of these switches are not included in the post...

However, I can assure you that the VTP client-server settings are correct, since I've tested the switches directly connected to eachother and the VTP works just fine.


Thanks again,

               Kostas.


P.S: The VTP settings that do appear in the posted configuration are only the settings of the internal switch of the 878 router.

paolo bevilacqua Sun, 05/27/2012 - 13:26
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Why bridging? Use routing and you will have all the advantages, and none of the trouble.

Konstantinos Le... Mon, 05/28/2012 - 00:19
User Badges:

That was my exact reaction when my client client asked me to do this!!


Probably, he has to deal with IP range restrictions... To be honest I don't know exactly the reason my client wants to waste two 878 routers by using them as bridges.


I must also say that I had recently upgraded the IOS software of the routers, before I posted the question here.

Is there any possibility that these 878 routers are just not healthy? I've already tried different ATM encapsulation with no luck..

paolo bevilacqua Mon, 05/28/2012 - 01:38
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

To better help you customer, you should try to understand why he thinks he needs bridging, and help him remove the need by renumbering, fixing network, etc,


Even if you can get bridging to work, is not a good solution, that is not worth pursuing.


Then for the specific of your problem, I don't think that VTP cab be extended over router bridging, same story for wireless bridging.

Actions

This Discussion