Anyone attempt Jabber on Sprint EVO 4G?

Unanswered Question
May 25th, 2012

Hello!

Has anyone attempted to install the Jabber Android client on a Spring EVO 4G? We have it running, but the directory does not appear to be working. Unsure if it's just an incompatibility with the phone or a configuration issue. Thanks!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
jasmsand Fri, 05/25/2012 - 11:39

Hey Ben,

To verify if its a configuration issue, can you please provide the screenshot of the Directory Search Setting for the BOT device so that we can verify what values have been configured for following:

Is LDAP User Authentication Setting TRUE or FALSE?

LDAP Server:

Is LDAP SSL enabled or disabled?

LDAP Search Base

Any LDAP Field Mapping done?

Regards,

Jas

jasmsand Fri, 05/25/2012 - 12:14

Hey Ben,

The config seems correct. What I'd need at this point is to provide the Problem Report from Jabber for Android, so we can see what error we get during Directory Integration.

http://www.cisco.com/en/US/docs/voice_ip_comm/jabber/Android/8_6/JABA_BK_A940B90D_00_jabber-for-android-admin-guide_chapter_0100.html#JABA_TK_OCDFA606_00

Can you also let me know what the OS version running on EVO 4g is?

Attach the PRT here and I'll go through it to see is what error is in there.

Regards,

Jas

benrobinson1 Fri, 05/25/2012 - 14:21

Hi!

Android v2.3.3 - and it's rooted.

I noticed this in the logs - it says anonymous bind??

05-25 10:33:04.723 D/soundwave_tag( 1303): LDAPManager: [Thread-65]getConnection anonymous bind result: LDAPResult(resultCode=0 (success))

05-25 10:33:04.743 D/soundwave_tag( 1303): LDAPManager: [Thread-65]getSearchBase: This is active directory server

05-25 10:33:04.743 D/soundwave_tag( 1303): AndroidValueStore: [Thread-65]get(): got [LDAP_SEARCH_BASE, DC=ksbe,DC=edu] of type class java.lang.String from cached prefs

05-25 10:33:04.753 D/soundwave_tag( 1303): LDAPManager SearchBase check: [Thread-65]Search returned with code operations error int value 1

05-25 10:33:04.753 E/soundwave_tag( 1303): LDAPManager: [Thread-65]getConnection anonymous bind error

05-25 10:33:04.753 E/soundwave_tag( 1303): LDAPException(resultCode=82 (local error), errorMessage='Please contact your system administrator.')

05-25 10:33:04.753 E/soundwave_tag( 1303):           at com.cisco.soundwave.ldap.LDAPManager.getConnection(LDAPManager.java:392)

05-25 10:33:04.753 E/soundwave_tag( 1303):           at com.cisco.soundwave.ldap.LDAPManager.connectImmediately(LDAPManager.java:208)

05-25 10:33:04.753 E/soundwave_tag( 1303):           at com.cisco.soundwave.ldap.LDAPManager$2.run(LDAPManager.java:188)

05-25 10:33:04.753 E/soundwave_tag( 1303):           at java.lang.Thread.run(Thread.java)

05-25 10:33:04.763 D/soundwave_tag( 1303): AndroidValueStore: [Thread-65]put(): added [LDAP_CONNECTION_STATUS, 500] of type class java.lang.Integer to cached prefs

05-25 10:33:04.763 E/soundwave_tag( 1303): LDAPManager: [Thread-65]connect(): LDAPException(resultCode=82 (local error), errorMessage='Please contact your system administrator.')

05-25 10:33:04.773 D/soundwave_tag( 1303): AndroidValueStore: [Pipeline-Thread-16]put().run(): added [LDAP_CONNECTION_STATUS, 500] of type class java.lang.Integer to native prefs

05-25 10:33:04.813 D/soundwave_tag( 1303): AndroidValueStore: [main]onSharedPreferenceChanged(): notifying change for pref [LDAP_CONNECTION_STATUS]

benrobinson1 Fri, 05/25/2012 - 14:25

BTW when I look at the config file from the device there doesn't appear to be any LDAP fields except for the server?

ldapUseLDAPUserAuthentication>10.96.12.2540

jasmsand Fri, 05/25/2012 - 21:04

Hey Ben,

The error message "getConnection anonymous bind error" basically means that the setting "Enable LDAP User Authentication" is not taking affect If you search within the logs, do you see the following ("LDAP_USER_AUTH=false")?

Since we have configured it on CCM already, can you RESET and RESTART the device from Call Manager to make sure the correct settings are passed through.

Just goto CCM Admin -> Device -> Phones -> Search for this device -> Reset and Restart and test again.

If it still fails, I'd need the new PRT itself.

Regards,

Jas

solivarr Fri, 05/25/2012 - 21:14

Hi Ben,

Change your username to UPN format (user@domain.com) and add :3268 to the end of the ldap server , save and apply config. You may have to set Allow Enduser editing to disabled as well.

benrobinson1 Mon, 06/04/2012 - 02:54

Hi! We tried all these - but alas, no go. We're just going to bypass trying to support the device until Cisco gives explicit support.

ssadorra Thu, 06/14/2012 - 15:44

Hi Ben

Have you tried to set a different search base where based on your environment which adds the user conatiner (ie cn= or ou=)

a typical MSAD uses: cn=users, dc=xx, dc=xx 

other commonly use are organization units  :  ou=xx,dc=xx,dc=xx

I briefly glanced at the log above and i did not see the "user containier" in the search base parameter.

-sheila

benrobinson1 Thu, 06/14/2012 - 15:51

Hello!

We did not. The search base was the same that was setup on the iPhones - should should work, no?

ssadorra Thu, 06/14/2012 - 15:56

Hi, Yes they should. But i did find some sublte differences between the two products. Let me know if it works or not. If it turns out to be a defect i can forward to the appropriate team.

Actions

Login or Register to take actions

This Discussion

Posted May 25, 2012 at 11:29 AM
Stats:
Replies:11 Avg. Rating:
Views:1052 Votes:0
Shares:0
Categories: Jabber for Android
+

Related Content

Discussions Leaderboard