×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

BGP WEBSERVER PUBLISHING

Unanswered Question
May 28th, 2012
User Badges:

Hi,

I wanted to publish a webserver without using nat.

With bgp I publish full network.. network 103.10.168.0

If I put one of the ip from the pool to webserver it avialable from internet???


103.10.168.4

255.255.255.0

103.10.168.1







interface GigabitEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$

ip address 117.239.74.241 255.255.255.252

ip virtual-reassembly in

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 103.10.168.1 255.255.255.0

duplex auto

speed auto


router bgp 131787

bgp log-neighbor-changes

neighbor 117.239.74.242 remote-as 9829

neighbor 117.239.74.242 version 4

!

address-family ipv4

  network 103.10.168.0 mask 255.255.255.0

  neighbor 117.239.74.242 activate

exit-address-family



show ip bgp summ


Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd

117.239.74.242  4         9829       4       5        3    0    0 00:00:33        1




thanks


Sihanu N

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ahmad82pkn Mon, 05/28/2012 - 07:05
User Badges:

You dont need NAT if you are assigning public IP directly to Server.

All you need is routing available.


by the on which interface your bandwidht is connected on this router?

Giuseppe Larosa Mon, 05/28/2012 - 09:55
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Sihanu,

yes without NAT, If there is OSI layer2 connectivity between the web server NIC and  router gi0/1 interface for example with a LAN switch in the middle


note: your prefix is on the internet so eBGP is fine.


Hope to help

Giuseppe

Actions

This Discussion