B2BUA Calls Disconnecting at 4min 10sec

Unanswered Question
Jun 1st, 2012

Hi Guys

I have the following solution in place.

VCS Control Cluster Neighboured to a VCS control running B2BUA application for Lync Call and an Advanced Media Gateway.

We have a large number of Lync Calls to our video environment that are being disconnected at 4min 10sec.

The logs show that the participant ended the calls but this is not the case.

As a test we removed the AM Gateway from the solution but calls are still being disconnected at 4min 10sec.

Any ideas on this?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 3 (2 ratings)
awinter2 Fri, 06/01/2012 - 02:46

HI Haydn,

this problem is most likely related to SIP session refreshes.

Cisco (TANDBERG) endpoints will normally attempt to refresh SIP sessions after half of the session expiry time has passed. 500 seconds is the most common SIP session refresh time in a VCS environment, and 4 minutes 10 seconds equals 250 seconds.

To diagnose this issue further we would need to collect a diagnostics log from your VCS to see why the session refresh fails, and I would therefore recommend you raise a case with TAC to get this further looked into.

- Andreas

daniel27203 Thu, 03/27/2014 - 01:21

Hi Andreas,

May i have more information about the Cisco (TANDBERG) endpoints refresh SIP sessions after half of the session expiry time? i cannot find it document. Please kindly share more information to me if you can.

thanks!
Daniel

awinter2 Fri, 06/01/2012 - 06:43

Haydn,

yes that is likely.

You can try increasing VCS Configuration > Protocols > SIP > Configuration > Session Refresh Interval and Minimum Session Refresh Interval, as this should aid in keeping the calls up for a longer period of time.

- Andreas

haydnv@omegadig... Tue, 06/05/2012 - 06:24

Just wanted to give an update.

I upped the Session Refresh Interval and Minimum Session Refresh Interval values to their maximum 7200.

Calls are still disconnecting but now at random time. Some 3min, some 10min and other make it to 1 hr.

Still waiting for a response from TAC.

Martin Koch Tue, 06/05/2012 - 06:36

in general I would say you have an issue with your network, like firewall, tcp timeouts, inspection, loadbalancers, ...

or some other config issue (like wong port, dns, ...)

How is your setup anyhow

* tcp/tls towards lync?

* do you use a dedicated gw vcs?

* any load balancers used?

* any firewalls / algs / ... in between the components?

* lync clients on the frontend server?

* any particular direction where the calls fail (like cisco2lync or lync2cisco)?

* sip to sip or interworked calls?

* which endpoint types are involved?

* findme used?

* any "tweaks" from the lync deployment guide?

* ... ... ... ?

haydnv@omegadig... Tue, 06/05/2012 - 06:55

Hi Martin

* tcp/tls towards lync?
- TLS

* do you use a dedicated gw vcs?
- Yes

* any load balancers used?
- Yes.

* any firewalls / algs / ... in between the components?
- No

* lync clients on the frontend server?
- Yes

* any particular direction where the calls fail (like cisco2lync or lync2cisco)?
- Both but mostly Lync 2 Cisco

* sip to sip or interworked calls?
- From the Lync Gateway VCS to the VCS Cluster SIP, from the Cluster to Endpoints and MCU Sip > H323.

* which endpoint types are involved?
- MCU 8510, C20, C40, Polycom VSX & HDX Systems

* findme used?
- No

* any "tweaks" from the lync deployment guide?
- None – We have an Advanced Media Gateway but we removed it as a test.

haydnv@omegadig... Fri, 06/08/2012 - 06:45

Ok so an update.

First off…Thanks Andreas and Sager for all your help.

Its seems the issue is caused by a limitation with the B2BUA application on X 7.1

The B2BUA application has a pool of 20 TCP connections available to it.

Due to our large Lync environment we hit this limit.

When calls tried to initiate sip refreshes there were no connection available so the calls would drop at random based on if a connection could be made or not.

The problem has been identified as CDETS CSCty97430 which should be resolved in 7.2

Paulo.Trilho Wed, 01/09/2013 - 14:23

HI Haydn,

do you know what fix was actually implemented in 7.2? Was this number increased, and to what value?

I am experiencing a similar problem, and I'd like to understand if this is a limitation on the B2BUA application or some kind of problem in my network.

Thanks

Regards

awinter2 Thu, 01/10/2013 - 05:57

Hi Paulo,

the number of connections was increased to 500.

A diagnostics log of 'Debug' detail level would be the way to go for investigating a problem with SIP session refreshes.

- Andreas

Actions

Login or Register to take actions

This Discussion

Posted June 1, 2012 at 12:56 AM
Stats:
Replies:11 Avg. Rating:3
Views:1133 Votes:0
Shares:0

Related Content

Discussions Leaderboard