×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Need advice of QoS config before implementation

Unanswered Question
Jun 12th, 2012
User Badges:

Hi team,


I am going to be implementing some QoS across the network of the company I work for. I am no expert in it but have come up with the following, but would love it if some more experienced professionals could look over it before I implement it.


What am I trying to achieve? Simple, we have a 20mbps link and I want 50% to always be used for our SAN traffic that is being backed up to another site and then after hours and weekends, this goes up to 70% and 80% respectively.


We have video conferencing so I want that to always go first. The LAN is setup and the switches are tagging DSCP values to the video and SAN traffic.


With the Policy map SHAPE_TRAFFIC, I am not sure which one to use. Thanks in advance.



class-map match-aLL VIDEO_QoS

match  dscp cs5


class-map match-aLL SAN_REPLICATION

match  dscp cs1


policy-map QoS_POLICY

class VIDEO_QoS

  priority percent 10

class SAN_REPLICATION

  priority percent 50                 


policy-map SAN_AFTERHOURS

class SAN_REPLICATION

  priority percent 70

  ip access-list SAN_AFTERHOURS


policy-map SAN_WEEKENDS

class SAN_REPLICATION

  priority percent 80

  ip access-list SAN_WEEKENDS


Policy map SHAPE_TRAFFIC

Class class-default

  shape average 20000000

  service policy QoS_POLICY

  service policy SAN_AFTERHOURS

  service policy SAN_WEEKENDS


OR


Policy map SHAPE_TRAFFIC

Class SHAPE_TRAFFIC

  Shape average 2000000

  service policy QoS_POLICY

  service policy SAN_AFTERHOURS

  service policy SAN_WEEKENDS

Class class-default

Fair-queue


ip access-list extended SAN_AFTERHOURS

permit ip any any time-range SAN_REPLICATION_WEEKDAYS


ip access-list extended SAN_WEEKENDS

permit ip any any time-range SAN_REPLICATION_WEEKENDS


time-range SAN_REPLICATION_WEEKDAYS

periodic weekdays 17:30 to 23:59

periodic weekdays 00:00 to 07:00


time-range SAN_REPLICATION_WEEKENDS

periodic weekend 00:00 to 23:59

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
David Salazar Wed, 06/13/2012 - 07:07
User Badges:

Hi,


1) By default on the Cisco routers you can setup the 75% of the interface bandwidth, the 25% is reserved for control traffic. For this when you are configure the policy map you can not exceed on all classes (exclude default-class) 75%.


2) the priority queue is only one, if you mixed diference type of traffic (example: video and SAN) on separate class-map but both using the priority queue is not a good idea.


3) What type os traffic is your SAN traffic, who much rate of bandwidth consume it? Is UDP or TFP traffic?


4) how are you controlling the traffic rate now for the lin of 20Mbps?


5) one more thing, why you are using time-range for the same traffic? Its important point here is modify the bandwidth assign to the class reference to the date. Maybe you can schedule a cron job or use EEM.


HTH

Cory Dryden Wed, 06/13/2012 - 15:03
User Badges:

1) Thanks for that. Previously the max-reserved bandwidth command is implemented and has 90 after it.

2) I did read after posting this what you are referring to.

3) The guy who runs it says TCP

4) There is not any shaping on the router at present. Theinterface is 100mbps full duplex.

5) Time range was so that after hours or weekends, the SAN traffic uses more of the link.


Thanks

Joseph W. Doherty Wed, 06/13/2012 - 10:11
User Badges:
  • Super Bronze, 10000 points or more

Disclaimer


The  Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.  Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind. Usage of this  posting's information is solely at reader's own risk.


Liability Disclaimer


In  no event shall Author be liable for any damages whatsoever (including,  without limitation, damages for loss of use, data or profit) arising out  of the use or inability to use the posting's information even if Author  has been advised of the possibility of such damage.


Posting


You shouldn't be able to define multiple service-polices within the same class.  Also when you shape, most shapers don't account for L2 overhead, so you then need to shape 5 to 15% slower to allow for it.


Although your time based ACLs could be used to effectively match different classes, the problem is it doesn't deactivate the class and the class percentages are always active and you can't exceed total available.  However non-LLQ classes are relative so you could get something close to what you desire if you work ratios. 50% is 1:1, 70% is 7:3 and 80% is 4:1.  So, something like:


time-range SAN_REPLICATION_AFTERHOURS

periodic weekdays 17:30 to 23:59

periodic weekdays 00:00 to 07:00


time-range SAN_REPLICATION_WEEKENDS

periodic weekend 00:00 to 23:59


ip access-list extended SAN_AFTERHOURS

permit ip any any time-range SAN_REPLICATION_AFTERHOURS


ip access-list extended SAN_WEEKENDS

permit ip any any time-range SAN_REPLICATION_WEEKENDS


class-map match-aLL VIDEO_QoS

match  dscp cs5


class-map match-aLL SAN_REPLICATION

match  dscp cs1


class-map match-all SAN_AFTERHOURS

match access-group SAN_AFTERHOURS

match class-map SAN_REPLICATION


class-map match-all SAN_WEEKENDS

match access-group SAN_WEEKENDS

match class-map SAN_REPLICATION


policy-map QoS_POLICY

class VIDEO_QoS

  priority percent 10


class SAN_WEEKENDS

  bandwidth percent 12


class SAN_AFTERHOURS

  bandwidth percent 7


class SAN_REPLICATION

  bandwidth percent 3


class class-default

  bandwidth percent 3


Policy map SHAPE_TRAFFIC_20Mbps

Class class-default

  shape average 18000000

  service policy QoS_POLICY


NB: QoS features vary by platform and IOS, so the above might need editing.

Cory Dryden Wed, 06/13/2012 - 15:05
User Badges:

Thanks Joseph for taking the time to write that up. I understand what you are saying except for why you use the ratios you were talking about.


If anyone can point me to some doco on QoS that would be awesome. Right from the start would be great!

Joseph W. Doherty Wed, 06/13/2012 - 15:42
User Badges:
  • Super Bronze, 10000 points or more

Disclaimer


The   Author of this posting offers the information contained within this   posting without consideration and with the reader's understanding that   there's no implied or expressed suitability or fitness for any purpose.   Information provided is for informational purposes only and should not   be construed as rendering professional advice of any kind. Usage of  this  posting's information is solely at reader's own risk.


Liability Disclaimer


In   no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising  out  of the use or inability to use the posting's information even if  Author  has been advised of the possibility of such damage.


Posting


I used ratios to provide your requested 50%, 70% and 80% allocations for SAN traffic.


You noted, during weekdays, you wanted to provide SAN 50% of the bandwidth but 70% weeknights and 80% weekends.  You did this by using 3 different policies, but you cannot have all 3 active.  You need the desired policy at the desired time.  You could probably set up some complex scheduling to change configs on the fly, but what I did was define a single policy that will deliver the same results.  I did this by using ratios between classes to correspond to your desired percentages.


For example, on weekends when you want 80% for SAN, that leaves 20% for other non-SAN traffic.  The ratios between 80% to 20% is 4:1.  In the policy map I defined, I set bandwidths to 12% and 3%, for SAN traffic during weekends, which is also 4:1, so you obtain your desired 80% to 20%.  For non-LLQ classes the percentages used aren't caps, they just set a relative scheduling weights.

Cory Dryden Thu, 06/14/2012 - 15:27
User Badges:

Ok I understand that. Why 12 and 3 though? Why not any other numbers that make up a 4:1 ratio or am I looking into that too much?

Joseph W. Doherty Thu, 06/14/2012 - 17:46
User Badges:
  • Super Bronze, 10000 points or more

Disclaimer


The   Author of this posting offers the information contained within this   posting without consideration and with the reader's understanding that   there's no implied or expressed suitability or fitness for any purpose.   Information provided is for informational purposes only and should not   be construed as rendering professional advice of any kind. Usage of  this  posting's information is solely at reader's own risk.


Liability Disclaimer


In   no event shall Author be liable for any damages whatsoever (including,   without limitation, damages for loss of use, data or profit) arising  out  of the use or inability to use the posting's information even if  Author  has been advised of the possibility of such damage.


Posting


Least common denominator with the other two ratios.

80:20=4:1=12:3

70:30=7:3

50:50=1:1=3:3

Actions

This Discussion

Related Content