Cannot add SIP command

Unanswered Question
Jun 18th, 2012

Hi,

I have a 2811 router with c2800nm-adventerprisek9-mz.124-24.T4.bin IOS

I amtrying to add the command:

"bind media source-interface loopback 1" and "bind control source-interface loopback 1"

I am can apply these commands but, but in the show run, I never see them.

We tried another IOS, we tried to bind to another interface, but it just won't show these commands.

Erase flash: format flash: nothinh helps.

Any idea?

Jan

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (2 ratings)
j.huizinga Mon, 06/18/2012 - 03:04

hI,

This is the simple configuration:

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname VOIP

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

!

no aaa new-model

!

dot11 syslog

ip source-route

!

!

ip cef

!

!

no ipv6 cef

!

multilink bundle-name authenticated

!

voice service voip

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

no supplementary-service sip moved-temporarily

redirect ip2ip

fax protocol pass-through g711alaw

h323

sip

  rel1xx disable

!

voice-card 0

dspfarm

dsp services dspfarm

!

archive

log config

  hidekeys

!

interface Loopback1

ip address 80.80.80.80 255.255.255.255

!

interface FastEthernet0/0

ip address 172.16.0.220 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 172.16.0.1

no ip http server

no ip http secure-server

!

control-plane

!

line con 0

line aux 0

line vty 0 4

login

!

scheduler allocate 20000 1000

end

Under sip we can see and type the bind commands, but we don't see them in the runing config.

This is a simple config, because I have taken the router out of the rack and brought to the lab.

Thanks,

Jan

Gordon Ross Mon, 06/18/2012 - 03:35

Sorry, I've got nothing insightful to offer.

One *very* silly thing to try, is "Loopback1" rather than "loopback1" (Yes, the case is important)

Maybe someone else can chime in with suggestions.

GTG

j.huizinga Thu, 06/21/2012 - 02:18

mmm

Aperantly for the "sip bind" commands to work you have to add:

!

sccp local FastEthernet0/0

sccp

!

Don't really get it why, but at least it works.

Jan

Gordon Ross Thu, 06/21/2012 - 02:22

Weird - my 2900 doesn't need that !

How did you stumble upon that ?

GTG

j.huizinga Thu, 06/21/2012 - 02:33

I am using a 2811

I saw that I could apply this command on another 2811, so I got exactly the same IOS on my router.

Still nothing.

Finally I took the whole configuration removed stuff from which I was sure that it has nothing to do with SIP (routes access-lists etc) and then from what was left I added line by line till I saw the bind commands.

This happens to be the SCCP commands.

What has SCCP to do with SIP? I don't know.

Jan

acampbell Thu, 06/21/2012 - 04:33

Guys,

The correct syntax to add the bindings should be :-

!

!

voice service voip

sip

bind control source-interface loop 1

bind media source-interface loop 1

!

!

!

Works every time for me on a 3845

Regards,
Alex.
Please rate useful posts.

j.huizinga Thu, 06/21/2012 - 04:54

I have applied these command a zillion times

With different IOS's, and not once I did see the bind command.

Here are some IOS's I tried:

c2800nm-adventerprisek9-mz.124-15.T9.bin

c2800nm-adventerprisek9-mz.124-20.T6.bin

c2800nm-adventerprisek9-mz.124-24.T4.bin

c2800nm-adventerprisek9-mz.124-24.T5.bin

c2800nm-adventerprisek9-mz.124-24.T7.bin

c2800nm-advipservicesk9-mz.124-15.T11.bin

c2800nm-ipvoice_ivs-mz.124-20.T6.bin

All with 2811

Jan

acampbell Thu, 06/21/2012 - 05:48

Jan,

Looks like an unresolved bug

CSCsg68896

CSCsg68896 Bug Details
unable to bind sip protocol to interface

Symptom:

configured binding to interfaces for the sip protocol not visible on the show run
Conditions:

A regular configuration under voice services voip --> sip

Workaround:

none

Further Problem Description:
Status Status
Open
(Assigned)
Severity Severity
4 - minor

Last Modified Last Modified
Any Time

Product Product
Cisco IOS software

Technology Technology
IP Telephony/Voice over IP (VoIP)

1st Found-In 1st Found-in
12.4M

Component(s) Component

Regards,
Alex.
Please rate useful posts.

Gordon Ross Thu, 06/21/2012 - 05:51

Grrr. How did you find that, Alex ? I tried searching BugTrack didn't find that bug.

GTG

acampbell Thu, 06/21/2012 - 05:56

Hi Gordon,

Hope you are well.

I used the new beta bug tool

Tried a search for SIP BIND and bingo !!!

I prefer the text in the original bug tool so I just pasted the BUD ID in there.

Still- they could do with updating the bug itself to explain which IOS are affected and which are fixed.

Life is never perfect unless your lying on the sand under the sun with a cool one

Not that we get much of that here in Scotland

Regards,
Alex.
Please rate useful posts.

j.huizinga Fri, 06/22/2012 - 00:05

That seems to be the issue.

But still, you don't see it in the show run, but it works, or you don't see it and it doesn't work.

If it is the last one, then this is really not a minor bug!

Thanks for all the help!

Jan

Actions

Login or Register to take actions

This Discussion

Posted June 18, 2012 at 2:46 AM
Stats:
Replies:13 Avg. Rating:5
Views:590 Votes:0
Shares:0
Tags: cannot, sip, command, add
+

Related Content

Discussions Leaderboard

Rank Username Points
1 21,051
2 15,047
3 10,325
4 8,014
5 4,856
Rank Username Points
116
105
103
76
72