×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Transcoding between CME (G729 to G711)

Answered Question
Jun 21st, 2012
User Badges:
  • Gold, 750 points or more

Hi,


Im tryng to make  transcoding between two CME Version 15.1(3)T3, both have almost the same configuration but after have dial the phone number I received fastbusy tone not matther in which direction the call is made. Transcoding DSPFarm in both ends are registered.


Scenario:

                                               H323

CME 1 (Codec: G729) <------------------------> CME 2 (Codec: G711)



CME 1

=====

CME-Legacy#show sdspfarm units

mtp-1 Device:CME-TRANSC TCP socket:[1]  REGISTERED in SCCP ver 18/18
actual_stream:4 max_stream 4 IP:192.168.100.1 * 11902  MTP Dixieland keepalive 2102
Supported codec:
                 G711Ulaw
                 G711Alaw
                 G729
                 G729a
                 G729ab

max-mtps:5, max-streams:4, alloc-streams:4, act-streams:0
CME-Legacy#





CME-Legacy#show run
Building configuration...


Current configuration : 2720 bytes
!
! Last configuration change at 14:03:54 UTC Thu Jun 21 2012
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-Legacy
!
boot-start-marker
boot-end-marker
!
!
card type t1 0 3
enable secret 5 $1$0iFd$Um7r8JhKS6fMrEpFH64rB0
!
no aaa new-model
!
network-clock-participate wic 3
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-qsig
!
!
!
!
!
!
!
voice-card 0
dspfarm
dsp services dspfarm
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO2811 sn FHK1246F3KE
archive
log config
  hidekeys
!
redundancy
!
!
controller DSL 0/0/0
!
controller T1 0/3/0
clock source internal
cablelength long 0db
pri-group timeslots 1-2,24
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 192.168.100.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.4.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/2/0
ip address 192.168.3.2 255.255.255.0
encapsulation ppp
!
interface Serial0/2/1
no ip address
shutdown
clock rate 2000000
!
interface Serial0/3/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-qsig
isdn incoming-voice voice
no cdp enable
!
!
router eigrp 1
network 192.168.3.0
network 192.168.4.0
network 192.168.100.0
auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
logging esm config
!
!
!
!
!
!
control-plane
!
!
voice-port 0/3/0:23
!
voice-port 0/1/0
!
voice-port 0/1/1
!
!
mgcp fax t38 ecm
!
mgcp profile default
!
sccp local Loopback0
sccp ccm 192.168.100.1 identifier 1 priority 1 version 7.0
sccp
!
sccp ccm group 1
bind interface Loopback0
associate ccm 1 priority 1
associate profile 1 register CME-TRANSC
!
dspfarm profile 1 transcode
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
codec g729r8
maximum sessions 2
associate application SCCP
!
dial-peer voice 3001 pots
destination-pattern 3001
port 0/1/0
!
dial-peer voice 3002 pots
destination-pattern 3002
port 0/1/1
!
dial-peer voice 101 voip
destination-pattern 2...
session target ipv4:192.168.2.1
!
!
!
!
telephony-service
sdspfarm units 5
sdspfarm transcode sessions 2
sdspfarm tag 1 CME-TRANSC
em logout 0:0 0:0 0:0
max-ephones 4
max-dn 4
ip source-address 192.168.100.1 port 2000
max-conferences 8 gain -6
transfer-system full-consult
create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
!
line con 0
password leoleo
login
line aux 0
line vty 0 4
password leoleo
login
transport input all
!
scheduler allocate 20000 1000
end

CME-Legacy#







CME2

=====

mtp-1 Device:CME-TRANSC TCP socket:[3]  REGISTERED in SCCP ver 18/18
actual_stream:8 max_stream 8 IP:192.168.2.1 * 18292  MTP Dixieland keepalive 160
Supported codec:
                 G711Ulaw
                 G711Alaw
                 G729a
                 G729b
                 G729ab

max-mtps:5, max-streams:8, alloc-streams:8, act-streams:0
CME-Lab#




CME-Lab#show run
Building configuration...


Current configuration : 7670 bytes
!
! Last configuration change at 09:50:46 LAPAZ Thu Jun 21 2012
! NVRAM config last updated at 09:46:42 LAPAZ Thu Jun 21 2012
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-Lab
!
boot-start-marker
boot system flash c2800nm-adventerprisek9-mz.151-3.T3.bin
boot-end-marker
!
!
card type t1 0 2
enable secret 5 $1$jJ.7$b/Yaq0M36fgZSrYpCK5LD/
!
no aaa new-model
!
clock timezone LAPAZ -4 0
network-clock-participate wic 2
!
dot11 syslog
ip source-route
!
!
ip cef
!
ip dhcp excluded-address 192.168.1.1 192.168.1.20
ip dhcp excluded-address 192.168.2.1 192.168.2.20
ip dhcp excluded-address 192.168.3.1 192.168.3.20
ip dhcp excluded-address 192.168.6.1 192.168.6.20
!
ip dhcp pool DATA
   network 192.168.1.0 255.255.255.0
   option 150 ip 192.168.2.1
   default-router 192.168.1.1
!
ip dhcp pool VOZ-CME
   network 192.168.2.0 255.255.255.0
   option 150 ip 192.168.2.1
   default-router 192.168.2.1
!
ip dhcp pool VOZ-CUCM
   network 192.168.6.0 255.255.255.0
   option 150 ip 192.168.6.10
   default-router 192.168.6.1
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-qsig
!
!
!
!
!
!
voice translation-rule 1
rule 1 /3.../ /1809544\0/
!
voice translation-rule 100
rule 1 /2/ /1002/
!
voice translation-rule 101
rule 1 /1002/ /2/
!
!
voice translation-profile SITE-CODE-CallerID
translate calling 100
!
voice translation-profile SITE-CODE-DNIS
translate called 101
!
!
voice-card 0
dspfarm
dsp services dspfarm
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO2811 sn FHK1225F3GX
archive
log config
  hidekeys
!
redundancy
!
!
controller T1 0/2/0
clock source internal
cablelength long 0db
pri-group timeslots 1-2,24
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.2.1 255.255.255.0
h323-gateway voip interface
h323-gateway voip id zone1 ipaddr 192.168.4.1 1719
h323-gateway voip h323-id CME-Lab
h323-gateway voip bind srcaddr 192.168.2.1
!
interface FastEthernet0/0.11
encapsulation dot1Q 11
ip address 192.168.6.1 255.255.255.0
!
interface FastEthernet0/0.50
encapsulation dot1Q 50
ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
ip address 192.168.3.1 255.255.255.0
encapsulation ppp
clock rate 64000
!
interface Serial0/0/1
no ip address
shutdown
clock rate 2000000
!
interface Serial0/2/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-qsig
isdn timer T310 120000
isdn protocol-emulate network
isdn incoming-voice voice
no cdp enable
!
!
router eigrp 1
network 192.168.1.0
network 192.168.2.0
network 192.168.3.0
network 192.168.6.0
auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
logging esm config
!
!
!
!
!
tftp-server flash:/PHONE/6921_6941_6961/Sccp/cmterm-69xx-sccp.9-2-1-0.tar alias cmterm-69xx-sccp.9-2-1-0.tar
tftp-server flash:/PHONE/6921_6941_6961/Sccp/BOOT69xx.0-0-0-14.zz.sgn alias BOOT69xx.0-0-0-14.zz.sgn
tftp-server flash:/PHONE/6921_6941_6961/Sccp/SP69xx.0-0-0-8.zz.sgn alias SP69xx.0-0-0-8.zz.sgn
tftp-server flash:/PHONE/6921_6941_6961/Sccp/SCCP69xx.9-2-1-0.loads alias SCCP69xx.9-2-1-0.loads
tftp-server flash:/PHONE/6921_6941_6961/Sccp/SCCP69xx.9-2-1-0.zz.sgn alias SCCP69xx.9-2-1-0.zz.sgn
tftp-server flash:/PHONE/7942_7962/Sccp/apps42.9-2-1TH1-13.sbn alias apps42.9-2-1TH1-13.sbn
tftp-server flash:/PHONE/7942_7962/Sccp/cnu42.9-2-1TH1-13.sbn alias cnu42.9-2-1TH1-13.sbn
tftp-server flash:/PHONE/7942_7962/Sccp/cvm42sccp.9-2-1TH1-13.sbn alias cvm42sccp.9-2-1TH1-13.sbn
tftp-server flash:/PHONE/7942_7962/Sccp/dsp42.9-2-1TH1-13.sbn alias dsp42.9-2-1TH1-13.sbn
tftp-server flash:/PHONE/7942_7962/Sccp/jar42sccp.9-2-1TH1-13.sbn alias jar42sccp.9-2-1TH1-13.sbn
tftp-server flash:/PHONE/7942_7962/Sccp/SCCP42.9-2-1S.loads alias SCCP42.9-2-1S.loads
tftp-server flash:/PHONE/7942_7962/Sccp/term42.default.loads alias term42.default.loads
tftp-server flash:/PHONE/7942_7962/Sccp/term62.default.loads alias term62.default.loads
tftp-server flash:/PHONE/7945_7965/Sccp/cmterm-7945_7965-sccp.9-2-1.tar alias cmterm-7945_7965-sccp.9-2-1.tar
tftp-server flash:/PHONE/7945_7965/Sccp/apps45.9-2-1TH1-13.sbn alias apps45.9-2-1TH1-13.sbn
tftp-server flash:/PHONE/7945_7965/Sccp/cnu45.9-2-1TH1-13.sbn alias cnu45.9-2-1TH1-13.sbn
tftp-server flash:/PHONE/7945_7965/Sccp/cvm45sccp.9-2-1TH1-13.sbn alias cvm45sccp.9-2-1TH1-13.sbn
tftp-server flash:/PHONE/7945_7965/Sccp/dsp45.9-2-1TH1-13.sbn alias dsp45.9-2-1TH1-13.sbn
tftp-server flash:/PHONE/7945_7965/Sccp/jar45sccp.9-2-1TH1-13.sbn alias jar45sccp.9-2-1TH1-13.sbn
tftp-server flash:/PHONE/7945_7965/Sccp/SCCP45.9-2-1S.loads alias SCCP45.9-2-1S.loads
tftp-server flash:/PHONE/7945_7965/Sccp/term45.default.loads alias term45.default.loads
tftp-server flash:/PHONE/7945_7965/Sccp/term65.default.loads alias term65.default.loads
tftp-server flash:/PHONE/6921_6941_6961/Sccp/DSP69xx.0-0-0-8.zz.sgn alias DSP69xx.0-0-0-8.zz.sgn
!
control-plane
!
!
voice-port 0/2/0:23
!
voice-port 0/1/0
signal groundStart
station-id name Leo Salcie
caller-id enable
!
voice-port 0/1/1
!
voice-port 0/3/0
!
voice-port 0/3/1
!
voice-port 0/3/2
!
voice-port 0/3/3
!
!
mgcp fax t38 ecm
!
mgcp profile default
!
sccp local FastEthernet0/0.10
sccp ccm 192.168.2.1 identifier 1 priority 1 version 4.1
sccp
!
sccp ccm group 1
associate ccm 1 priority 1
associate profile 1 register CME-TRANSC
!
dspfarm profile 1 transcode
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
codec g729br8
maximum sessions 4
associate application SCCP
!
dial-peer cor custom
name 911call
name localcall
name ldcall
!
!
dial-peer cor list 911call
member 911call
!
dial-peer cor list LD
member 911call
member localcall
member ldcall
!
dial-peer cor list localcall
member localcall
!
dial-peer cor list ldcall
member ldcall
!
dial-peer cor list LOCAL
member localcall
!
!
dial-peer voice 9809 pots
corlist outgoing localcall
destination-pattern 99809.......
port 0/3/0
forward-digits 11
!
dial-peer voice 91809 pots
corlist outgoing ldcall
destination-pattern 991809.......
port 0/3/0
forward-digits 12
!
dial-peer voice 100 voip
destination-pattern 3...
session target ipv4:192.168.3.2
incoming called-number 2...
codec g711ulaw
!
!
!
!
telephony-service
sdspfarm units 5
sdspfarm transcode sessions 4
sdspfarm tag 1 CME-TRANSC
em logout 0:0 0:0 0:0
max-ephones 12
max-dn 12
ip source-address 192.168.2.1 port 2000
auto assign 1 to 6
load 7965 SCCP45.9-2-1S
max-conferences 8 gain -6
transfer-system full-consult
create cnf-files version-stamp 7960 Jun 21 2012 09:37:02
!
!
ephone-dn  1
number 2001
!
!
ephone-dn  2
number 2002
!
!
ephone-dn  3
number 2003
!
!
ephone-dn  4
number 2004
!
!
ephone-dn  5
number 2005
!
!
ephone-dn  6
number 2006
!
!
ephone-dn  9  dual-line
number 9999
!
!
ephone  1
device-security-mode none
mac-address 503D.E5E9.2001
max-calls-per-button 2
type 6921
button  1:1
!
!
!
ephone  2
device-security-mode none
mac-address 64A0.E715.F5B2
type 7965
button  1:2
!
!
!
ephone  5
device-security-mode none
mac-address 503D.E52F.C3E4
max-calls-per-button 2
button  1:3
!
!
!
ephone  9
device-security-mode none
mac-address 00F0.1D00.0081
!
!
!
ephone  99
device-security-mode none
mac-address AABB.CC11.2233
button  1:9
!
!
!
!
line con 0
line aux 0
line vty 0 4
password leoleo
login
transport input all
!
scheduler allocate 20000 1000
ntp master 3
ntp server 192.168.2.1
end

CME-Lab#


Any help would be appreciated

Regards

Correct Answer by Ayodeji Okanlawon about 5 years 1 month ago

If you want to force xcoding..


On cme 2, configure the dial-peer to cme 1 to use G723 codec.


On cme 3, configure this..


dial-peer voice 103 voip

incoming called number 3...

codec g723

no vad


Ensure that your xcoder has G723 codec as one of the codecs.


The call should invoke a xcoder because cisco ip phones cant do G723.



Please rate useful posts


"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Ayodeji Okanlawon Thu, 06/21/2012 - 08:27
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

Try this on cme 1


dial-peer voice 103 voip

incoming called number 3...

codec g711u

no vad


Then do a test call from cme 2 to cme 1..



Please rate useful posts


"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Leo Salcie Tejeda Thu, 06/21/2012 - 08:57
User Badges:
  • Gold, 750 points or more

it worked, but with dial-peer 103 there's not need to use transcoding because is G711 to G711...At least we know that calls are rececived.

Ayodeji Okanlawon Thu, 06/21/2012 - 09:04
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

The way you have set it up it cant work.. The reason is because the call cant even get into the gateway. Your call from cme 2 is g711, your incoming dial-peer on cme 1 is g729. So at the ingress of the router the call does not even gets accepted. Transcoding cant be invoked like that.


If you want to do G729 over the IP network or WAN then configure your dial-peer to do G729. Your internal phones will still use G711. So internally you will use G711 and calls to the CME2 will use G729.


In this setup I dont see what you need a xcoder for. IP Phones can do both G729 and G711.




Please rate useful posts


"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Leo Salcie Tejeda Thu, 06/21/2012 - 10:17
User Badges:
  • Gold, 750 points or more

Thanks for you response, I would like to force a call using transcoding just for test porpose.


Do you know how can I achive that? I thought with this scenario I'll be able.

Correct Answer
Ayodeji Okanlawon Thu, 06/21/2012 - 10:41
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

If you want to force xcoding..


On cme 2, configure the dial-peer to cme 1 to use G723 codec.


On cme 3, configure this..


dial-peer voice 103 voip

incoming called number 3...

codec g723

no vad


Ensure that your xcoder has G723 codec as one of the codecs.


The call should invoke a xcoder because cisco ip phones cant do G723.



Please rate useful posts


"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Leo Salcie Tejeda Thu, 06/21/2012 - 11:27
User Badges:
  • Gold, 750 points or more

It worked great!!!! I need to enable the codec G.723 in the trascoding dsp farm in both CME and enable the dial-peer codec G.723 line too.


Just one question more, If both CME have transcoding resources which one will be assignig the trasnscode channel? In my case the CME1 always assign the trasncode channel.


CME-Lab#sh dspfarm dsp all
SLOT DSP VERSION  STATUS CHNL USE   TYPE    RSC_ID BRIDGE_ID PKTS_TXED PKTS_RXED

0    5   27.3.4   UP     1    USED  xcode   1      0x1F        167       170
0    5   27.3.4   UP     1    USED  xcode   1      0x1E        251       235
0    5   27.3.4   UP     N/A  FREE  xcode  1      -         -         -
0    5   27.3.4   UP     N/A  FREE  xcode  1      -         -         -
0    5   27.3.4   UP     N/A  FREE  xcode  1      -         -         -

Total number of DSPFARM DSP channel(s) 4

CME-Lab#


Thanks aokanlawon, Im very glad... today I have learned a lot from you!!!!

Ayodeji Okanlawon Thu, 06/21/2012 - 13:34
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony


Leo,


I am glad I could help. We are all learning and it is fun to learn and solve problems.


Ideally the side that origiates the call should invoke a xcoder.  This is the call flow.


phone--g711-->cme1-------g723--->|-----g723----->cme2---g711-----phone


We can investiage this further for learning purposes


1. Place a call from cme 1 to cme 2 when the call is establihed, do the ff:


sh voip rtp connection

show sdspfarm sessions


2. Repeat the same for cme 2 to cme 1. From here we should see what we are looking for. You can post the output here.

Actions

This Discussion

Related Content