Problem with AnyConnect VPN on ASA 5505

Answered Question
Jun 21st, 2012

Hello everyone,

We're troubleshooting an issue where a client cannot pass any traffic across an AnyConnect VPN with an ASA5505 as the endpoint. The client receives and IP address in the 172.16.0.1/24 range and the ASA creates a static route to the 10.0.0.0/24 internal network but we cannot ping or connect to any internal IP address. The connection appears to fully build and pass traffic (based on the byte counts which increase) but we can't talk to the main network.

Does anyone have any ideas as to what I can check?

Thanks!

Ryan

I have this problem too.
0 votes
Correct Answer by Jennifer Halim about 1 year 10 months ago

Thanks for the update.

Pls kindly mark the post as answered so others can learn from your question.

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
John Blakley Fri, 06/22/2012 - 02:26

Is it only 1 client having the problem or all clients? Is this subnet separate from the standard ipsec vpn pool? If so, make sure that you have a route back to the 172.16.0.0/24 subnet from your 10.x.x.x network.

If it's just the one client, how are they connecting? Cell card, DSL, cable?

HTH,

John

JohnTylerPearce Sat, 06/23/2012 - 02:25

I agree with Blakley. I ahd this problem the other day on a 5510. I felt completely stupid, since we have a POS Checkpoint and an ASA side by side for testing purposes. Both the ASA and Checkpoint have the same VPN DHCP Pool range. So when I was testing the Remote Access VPN on the ASA, I could see the pings going to the outside interface but they never responded because all the clients on the internal network are still using the Checkpoint as the default gateway. When I manually had a co-worker, put a route add command in WIndows to point back to the ASA for the VPN DHCP Pool, I received ping replies like a champ.

r.stalets Sat, 06/23/2012 - 12:16

So I tried using the internal DHCP server to get clients onto the same subnet as internal hosts but no dice, still not getting ping replies.

Jennifer Halim Sat, 06/23/2012 - 18:21

AnyConnect client should not be in the same subnet as the internal hosts. It needs to be unique subnet within your environment, so you were on the right path initially.

If you can share your config, that would be easier for us to check.

In the meantime, a few things to check:

1) Have you configured split tunnel policy?

2) Do you have NAT exemption configured?

3) Any VPN filter configured that might be blocking the traffic?

4) Does the internal network know how to route back to the VPN Pool subnet (ie: via the ASA)

5) Lastly, do you have "inspect icmp" configured?

r.stalets Mon, 06/25/2012 - 16:38

Thanks everyone for your suggestions. I referred to the syslog and discovered that even with a NAT exemption configured, it was denying the traffic between the VPN and internal networks because of a NAT conflict (I can't remember the exact error). I manually configured an extra NAT entry to do (inside, outside) 10.0.0.0/24 -> 172.16.1.0/24 Original and it works. Then I configured split tunneling to make everything work perfectly.

Thanks again!

Ryan

Correct Answer
Jennifer Halim Mon, 06/25/2012 - 19:05

Thanks for the update.

Pls kindly mark the post as answered so others can learn from your question.

Actions

Login or Register to take actions

This Discussion

Posted June 21, 2012 at 8:10 AM
Stats:
Replies:6 Avg. Rating:5
Views:2859 Votes:0
Shares:0

Related Content

Discussions Leaderboard