SIP trunk, CUBE and CUCM 8.5

Answered Question
Jun 25th, 2012

I have a SIP trunk from a TSP terminated on the CUBE. - c2901 gateway connected via H323 to a CUCM 8.5 cluster. The signalling looks OK but I have no voice. The provider seems to support only G.729br8 codec and my phones (c6901 and c6921) seem to talk G.729r8 only so I need to do some transcoding. I'm in the UK btw.Now, I can do it on the CUBE and utilize dspfarm but that is I think only possible with SCCP. How do I register the gateway in CUCM, if it's already there as the H323 gateway?

Is there any way to do the transcoding on the CUCM? Any general advise would be much appreciated.

Cheers

I have this problem too.
0 votes
Correct Answer by Ayodeji oladipo... about 1 year 9 months ago

The reason why this is not working is because the called number is not 5811 from the sip provider..

Your dial-peer 1 is like this..

dial-peer voice 1 voip

  incoming called-number 5[8-9].. (this is not the incoming called number)

it should be this..

dial-peer voice 1 voip

incoming called-number 01387345[8-9]..

Then when this dial-peer is matched, the xlation will be applied.

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Correct Answer by Ayodeji oladipo... about 1 year 9 months ago

Hi,

I have looked at the trace in detail and I have an idea why this is not working..

Can you please remove this from your dial-peers to cucm. Please ensure you remove from all dial-peers to cucm and sip provider.

progress_ind setup enable 3

progress_ind alert enable 8

Please do another test call and send me debug ccsip messages.

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Correct Answer by Ayodeji oladipo... about 1 year 9 months ago

Ok,

You still have not configured the dial-peer to CUCM to use SIP. But here is what I see..

Sent:

SIP/2.0 183 Session Progress

Via: SIP/2.0/UDP 146.191.243.4:6280;branch=z9hG4bK7kljtp2088b0cmgv34l0.1

From: ;tag=536c8c54

To: ;tag=44F7878-C23

Date: Wed, 27 Jun 2012 09:38:06 GMT

Call-ID: ODE1Y2E4ZTlhZDg1NjM0MmRhZDE4YmNhNTRiMjhkN2M.

CSeq: 1 INVITE

Require: 100rel

RSeq: 650

Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER

Allow-Events: telephone-event

Remote-Party-ID: "Michelle  Walters" ;party=called;screen=no;privacy=off

Contact:

Supported: sdp-anat

Server: Cisco-SIPGateway/IOS-12.x

Content-Type: application/sdp

Content-Disposition: session;handling=required

Content-Length: 262


v=0

o=CiscoSystemsSIP-GW-UserAgent 5886 9981 IN IP4 146.191.201.41

s=SIP Call

c=IN IP4 146.191.201.41

t=0 0

m=audio 20748 RTP/AVP 18 96

c=IN IP4 146.191.201.41

a=rtpmap:18 G729/8000

a=fmtp:18 annexb=yes

a=rtpmap:96 telephone-event/8000

a=fmtp:96 0-16

You are sending G729br8 to your provider but they do not support annexb because in their invite we do not see annexb.

INVITE sip:5811@UniWestScot:5060 SIP/2.0

Via: SIP/2.0/UDP 146.191.243.4:6280;branch=z9hG4bK7kljtp2088b0cmgv34l0.1

Max-Forwards: 68

Contact:

To:

From: ;tag=536c8c54

Call-ID: ODE1Y2E4ZTlhZDg1NjM0MmRhZDE4YmNhNTRiMjhkN2M.

CSeq: 1 INVITE

Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, REFER, PRACK

Content-Type: application/sdp

Supported: 100rel

P-Asserted-Identity:

Content-Length: 278


v=0

o=Redwood_INX 347015 347015 IN IP4 146.191.243.4

s=Redwood Media Server

c=IN IP4 146.191.243.4

t=0 0

m=audio 50002 RTP/AVP 8 18 96

a=rtpmap:8 PCMA/8000

a=rtpmap:18 G729/8000

a=rtpmap:96 telephone-event/8000

a=sendrecv

a=silenceSupp:off

a=ecan:on

a=fmtp:96 0-15

So either configure your cube to transcode from g729br8 to g729r8 or send your provider g729r8

Here is the document to use to setup xcoding on your cube..

http://www.cisco.com/en/US/products/sw/voicesw/ps5640/products_configuration_example09186a008092d6b3.shtml

Ensure you add g729br8 in your list of codecs

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 4.4 (12 ratings)
Ayodeji oladipo... Mon, 06/25/2012 - 14:19

Hi,

I doubt if yourprovide ronly support G729br8. Most providers support a variety of codecs. You can turn on "debug ccsip messages" on your cube and see what codecs your provider is sending to you..

I will suggest you start with this before going down the xcoding route

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

pjiracek Tue, 06/26/2012 - 01:24

Have had a look already. The provider offers PCMA/8000 and G729/8000 codecs which seem to translate to g711a and g729br8 in cisco speak. And the flavour g729br8 is not liked by our phones.

pjiracek Tue, 06/26/2012 - 02:45

OK, I've progressed a bit - our phones should do g729br8 so no transcoding needed.

I still cannot get any voice. I have the right codec set up on the CUBE for the SIP trunk and for the CUCM.(g729br8)

I have the CUBE and the phones in regions set up for G.729.

One thing - my CUBE is just an IP host (with 1 ethernet interface) and I have no ip routing. It's on a remote site so I cannot easily turn it on - but I cannot think it would make a difference.

pjiracek Tue, 06/26/2012 - 04:05

So now I have only g729br8 codec on the CUBE gateway. I make a inbound call over the SIP trunk, phone rings, when I pick it up (no audio) I can check the Sender codec = G711u and RCVR codec =G711u on the phone. What's going on? The phone is in a different region than the CUBE and the Max Audio bit rate between the 2 regions is 8kbps -> G729. Why does the phone insist on G711u?

leosalcie Tue, 06/26/2012 - 05:03

Hi pijaracek,

Look like is not a CODEC negotiation problem because the call is established. Are you using Media Flow around or Passtrought?

pjiracek Tue, 06/26/2012 - 05:12

No media flow,

I have only

fax protocol pass-through g711ulaw

I'm starting to suspect the config of the gateway in CUCM needs some change

Ayodeji oladipo... Tue, 06/26/2012 - 06:42

I am not sure why you want help but you dont want to send over the things that can be used to help. I asked earlier for "debug ccsip messages". If you want us to help..please send the debug and your sh run.

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

pjiracek Tue, 06/26/2012 - 09:02

I suspect now the SIP trunk and the CUBE configuration is OK.

For inbound calls over the SIP trunk I cannot hear the ringing tone although the phone is ringing and then if I redirect in CUCM using

Forward No Answer External

to Voicemail or another internal number, suddenly it works - the redirected call is ringing and there is audio after pick up.

Anything I should try to change in CUCM H323 gateway configuration?

It looks like this:

Ayodeji oladipo... Tue, 06/26/2012 - 12:09

Hi first of all I will advise to tidy up your configuration. This two dial-peers are not right.

dial-peer voice 2 voip

description *** INBOUND VOIP PEER ***

incoming called-number .

voice-class codec 1

dtmf-relay h245-alphanumeric

fax rate disable

ip qos dscp cs3 signaling

no vad

!

dial-peer voice 1 voip

description *** INBOUND SIP TRUNK PEER ***

translation-profile incoming SIP-TRUNK-IN

session protocol sipv2

session target ipv4:XXX.XXX.243.4

incoming called-number .

voice-class codec 2

dtmf-relay rtp-nte

no vad

Both dial-peers are used for inbound calls from CUCM and from your SIP provider. Your sip provider sends a sip leg and one of these dial-peers is doing a h323 leg. I will advise that you either configure a specific dial-peer to match incoming calls from your sip provider and configure sip protocol on that dial-peer or you configure a single dial-peer with incoming called number. and session protocl sip. Then configure a sip trunk from your cucm to your cube.

So before we troubleshoot further, please do what I suggest.

The best scenario is to have an and to end sip solution like this..

CUCM-----SIP Trunk--->CUBE------>ITSP.

To do this, you need to configure a sip trunk on cucm to CUBE and then configure this interface like this..(make the IP on the destination siup trunk to be=ip of gig0/1)

voice service voip

sip

  bind control source-interface GigabitEthernet0/1

  bind media source-interface GigabitEthernet0/1

After configuring this then configure the ff:

dial-peer voice 1 voip

description *** INBOUND DIAL-PEER ***

translation-profile incoming SIP-TRUNK-IN

session protocol sipv2

incoming called-number .

voice-class codec 2

dtmf-relay rtp-nte

no vad

no dial-peer voice 2 voip (remove this dial-peer).

Do a test call and send debug ccsip messages.

If you want to stick with the h323 scenario, your call flow will look like this..

cucm----h323----CUBE---sip--->ITSP

You need to configure the ff: in addition to what you have now

interface GigabitEthernet0/1

h323-gateway voip interface

dial-peer voice 1 voip

description *** INBOUND SIP TRUNK DIAL-PEER ***

translation-profile incoming SIP-TRUNK-IN

session protocol sipv2

incoming called-number 5[8-9]..

voice-class codec 2

dtmf-relay rtp-nte

no vad

dial-peer voice 2 voip

description *** INBOUND VOIP PEER ***

incoming called-number .

voice-class codec 1

dtmf-relay h245-alphanumeric

fax rate disable

ip qos dscp cs3 signaling

no vad

 

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

pjiracek Wed, 06/27/2012 - 01:27

Thanks for the reply.

I'd like to keep the h323 - sip scenario. So I changed the config as you suggested (I think in dial-peer voice 2 voip you missed session target clause). It still doesn't work. There is no dial tone for the inbound calls, although the phone rings and the call can even be successfully redirected and it rings once for the outbound calls and then the CUBE cancels the call and there is busy tone.

Here is the inbound call debug:

Volodymyr Morskyy Tue, 06/26/2012 - 15:09

Need to check the config but the symptoms are like the call is matching default dial peer

Sent from Cisco Technical Support iPad App

Ayodeji oladipo... Wed, 06/27/2012 - 01:58

Hi,

First of I didnt miss the session target command, I omitted because you dont need. This is an incoming called number dial-peer. You dont not have a destination-pattern on this dial-peer so you dont need session target.

Secondly, I dont see the benefit of you keeping h323.  I helped resolved a problem similar to this on this forum by changing to SIP. So i strongly suggest you consider this..

Thirdly, I cdan see a disconnect cause of 47

Sent:

CANCEL sip:01413330661@146.191.243.4:6280 SIP/2.0

Via: SIP/2.0/UDP 146.191.201.41:5060;branch=z9hG4bK217CC

From: "Michelle  Walters" ;tag=40B9354-944

To:

Date: Wed, 27 Jun 2012 08:23:56 GMT

Call-ID: 45C8BC2C-BF6811E1-80BAA4DC-D76223A2@146.191.201.41

CSeq: 101 CANCEL

Max-Forwards: 70

Timestamp: 1340785438

Reason: Q.850;cause=47

This is usually points to a codec issue.

We need to know what is happening on the call leg to cucm. Because you are using h323, you need to send debug voip ccapi inout.

I honestly advise changing to sip.

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

pjiracek Wed, 06/27/2012 - 02:14

OK, if I go SIP from cucm to CUBE, do I add the CUBE in cucm as gateway or as trunk? I'll give it a try. Thanks again. The reason why I started off with h323 is we have other gateways configured like this:

cucm -->h323 -->gateway --> PSTN

I understand it makes sense to keep it SIP all way through.

Ayodeji oladipo... Wed, 06/27/2012 - 02:17

Yes you need to add a sip trunk on cucm as I explained in the other post. Thats all. Then configure your sip binding on your gig0/1 interface as I also explained.

Once you have done this, do a test call and send the debug ccsip messages. With this we will see the interactuion between cucm and cube on the debug.

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Correct Answer
Ayodeji oladipo... Wed, 06/27/2012 - 03:05

Ok,

You still have not configured the dial-peer to CUCM to use SIP. But here is what I see..

Sent:

SIP/2.0 183 Session Progress

Via: SIP/2.0/UDP 146.191.243.4:6280;branch=z9hG4bK7kljtp2088b0cmgv34l0.1

From: ;tag=536c8c54

To: ;tag=44F7878-C23

Date: Wed, 27 Jun 2012 09:38:06 GMT

Call-ID: ODE1Y2E4ZTlhZDg1NjM0MmRhZDE4YmNhNTRiMjhkN2M.

CSeq: 1 INVITE

Require: 100rel

RSeq: 650

Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER

Allow-Events: telephone-event

Remote-Party-ID: "Michelle  Walters" ;party=called;screen=no;privacy=off

Contact:

Supported: sdp-anat

Server: Cisco-SIPGateway/IOS-12.x

Content-Type: application/sdp

Content-Disposition: session;handling=required

Content-Length: 262


v=0

o=CiscoSystemsSIP-GW-UserAgent 5886 9981 IN IP4 146.191.201.41

s=SIP Call

c=IN IP4 146.191.201.41

t=0 0

m=audio 20748 RTP/AVP 18 96

c=IN IP4 146.191.201.41

a=rtpmap:18 G729/8000

a=fmtp:18 annexb=yes

a=rtpmap:96 telephone-event/8000

a=fmtp:96 0-16

You are sending G729br8 to your provider but they do not support annexb because in their invite we do not see annexb.

INVITE sip:5811@UniWestScot:5060 SIP/2.0

Via: SIP/2.0/UDP 146.191.243.4:6280;branch=z9hG4bK7kljtp2088b0cmgv34l0.1

Max-Forwards: 68

Contact:

To:

From: ;tag=536c8c54

Call-ID: ODE1Y2E4ZTlhZDg1NjM0MmRhZDE4YmNhNTRiMjhkN2M.

CSeq: 1 INVITE

Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, REFER, PRACK

Content-Type: application/sdp

Supported: 100rel

P-Asserted-Identity:

Content-Length: 278


v=0

o=Redwood_INX 347015 347015 IN IP4 146.191.243.4

s=Redwood Media Server

c=IN IP4 146.191.243.4

t=0 0

m=audio 50002 RTP/AVP 8 18 96

a=rtpmap:8 PCMA/8000

a=rtpmap:18 G729/8000

a=rtpmap:96 telephone-event/8000

a=sendrecv

a=silenceSupp:off

a=ecan:on

a=fmtp:96 0-15

So either configure your cube to transcode from g729br8 to g729r8 or send your provider g729r8

Here is the document to use to setup xcoding on your cube..

http://www.cisco.com/en/US/products/sw/voicesw/ps5640/products_configuration_example09186a008092d6b3.shtml

Ensure you add g729br8 in your list of codecs

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

pjiracek Wed, 06/27/2012 - 03:54

Hi there,

I've replaced the codec g729br8 with g729r8 - it didn't like it at all - our cube SENT SIP/2.0 488 Not Acceptable Media.

Is it possible the provider doesn't support either of the 2 codecs? I'm having difficulties to get a list from them.

Cheers

pjiracek Wed, 06/27/2012 - 04:04

What do you mean by

You still have not configured the dial-peer to CUCM to use SIP

Is it replacing voice-class h323 with session protocol sipv2 in the CUCM dial peers 5001, 5002, 5555?

Ayodeji oladipo... Wed, 06/27/2012 - 04:26

configure

dial-peer voice 5002 voip

session protocol sipv2

do the same for all dial-peers to cucm.

do a test call and send "debug ccsip all"

remove the voice class h323 command..

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

pjiracek Wed, 06/27/2012 - 05:41

Hi

I got the outbound calls working.

The pronblem is a codec mismatch.

I added

g729 annexb-all

on the CUBE. However, that doesn't fix the inbound calls.

Ayodeji oladipo... Wed, 06/27/2012 - 06:48

Hi, I have looked at the trace again and I can see again the codec issue.

Here is a summary of trace analysis..

+++CUBE sends SDP to ITSP with g729br8+++

Sent:

SIP/2.0 183 Session Progress

Via: SIP/2.0/UDP 146.191.243.4:6280;branch=z9hG4bKg8plvd1008sg4n86i2p0.1

From: ;tag=5e3b5435

To: ;tag=4D1597C-40E

Date: Wed, 27 Jun 2012 11:59:58 GMT

Call-ID: NmRhNmJlZGJkNjZhMmNiYTk1MmFmMjdlOGU0MzU1NDk.

CSeq: 1 INVITE

Require: 100rel

RSeq: 5815

Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER

Allow-Events: telephone-event

Remote-Party-ID: ;party=called;screen=yes;privacy=off

Contact:

Supported: sdp-anat

Server: Cisco-SIPGateway/IOS-12.x

Content-Type: application/sdp

Content-Disposition: session;handling=required

Content-Length: 260


v=0

o=CiscoSystemsSIP-GW-UserAgent 3479 16 IN IP4 146.191.201.41

s=SIP Call

c=IN IP4 146.191.201.41

t=0 0

m=audio 26048 RTP/AVP 18 96

c=IN IP4 146.191.201.41

a=rtpmap:18 G729/8000

a=fmtp:18 annexb=yes

a=rtpmap:96 telephone-event/8000

a=fmtp:96 0-16

++++CUBE receives 200 ok from ITSP with G729br8+++So ITSP supports G729br8

Received:

SIP/2.0 200 OK

Via: SIP/2.0/UDP 146.191.201.41:5060;branch=z9hG4bK35E20

From: ;tag=4D1597C-40E

To: ;tag=5e3b5435

Call-ID: NmRhNmJlZGJkNjZhMmNiYTk1MmFmMjdlOGU0MzU1NDk.

CSeq: 101 INVITE

Timestamp: 1340798408

Contact:

Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, REFER, PRACK

Content-Type: application/sdp

Content-Length: 258


v=0

o=Redwood_INX 432119 432238 IN IP4 146.191.243.4

s=Redwood Media Server

c=IN IP4 146.191.243.4

t=0 0

m=audio 50038 RTP/AVP 18 96

a=rtpmap:18 G729/8000

a=fmtp:18 annexb=yes

a=rtpmap:96 telephone-event/8000

a=fmtp:96 0-16

a=sendrecv

a=ptime:20

++++CUBE receives 200 ok from cucm with only g729r8 (no annex-b)+++

Received:

SIP/2.0 200 OK

Via: SIP/2.0/UDP 146.191.201.41:5060;branch=z9hG4bK3021ED

From: ;tag=4D156B4-A23

To: ;tag=107724~58ef7c6e-6d55-43ea-a324-3eb4beb02da5-75265600

Date: Wed, 27 Jun 2012 12:00:12 GMT

Call-ID: 72E7D3B6-BF8611E1-81BEA4DC-D76223A2@146.191.201.41

CSeq: 101 INVITE

Allow: INVITE, OPTIONS, INFO, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY

Allow-Events: presence, kpml

Supported: replaces

Supported: X-cisco-srtp-fallback

Supported: Geolocation

Session-Expires:  1800;refresher=uas

Require:  timer

P-Asserted-Identity: "Michelle  Walters"

Remote-Party-ID: "Michelle  Walters" ;party=called;screen=yes;privacy=off

Contact:

Content-Type: application/sdp

Content-Length: 182


v=0

o=CiscoSystemsCCM-SIP 2000 1 IN IP4 146.191.2.102

s=SIP Call

c=IN IP4 146.191.199.29

t=0 0

m=audio 16438 RTP/AVP 18

a=rtpmap:18 G729/8000

a=ptime:20

a=fmtp:18 annexb=no

+++CUBE rejects call and sends a BYE to CUCM with cause code of 65++++++++++++


Sent:

BYE sip:5811@146.191.2.102:5060 SIP/2.0

Via: SIP/2.0/UDP 146.191.201.41:5060;branch=z9hG4bK32180E

From: ;tag=4D156B4-A23

To: ;tag=107724~58ef7c6e-6d55-43ea-a324-3eb4beb02da5-75265600

Date: Wed, 27 Jun 2012 11:59:57 GMT

Call-ID: 72E7D3B6-BF8611E1-81BEA4DC-D76223A2@146.191.201.41

User-Agent: Cisco-SIPGateway/IOS-12.x

Max-Forwards: 70

Timestamp: 1340798404

CSeq: 102 BYE

Reason: Q.850;cause=65

Now cause code of 65 is saying that CUBE does not support the codec call manager is trying to use.

Can you please configure your voice class codec to include g729r8 (I am not sure if the voice class codec you are using on dial-pee 5001, 500..is voice class codec 1 or 2. use the correct one.

eg

voice class codec 1 or voice class codec 2 (whichever o ne you are using on the dp to cucm

codec preference 1 g729r8

codec preference 2 g729br8

Please test again and send debug ccsip messages. Please attach debug in a text file dontg post here..cause the thread is getting too long

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

pjiracek Wed, 06/27/2012 - 07:07

Hi,

Thanks a lot for your help.

Stupid but I am unable to find a way how to atach a file to this discussion!

Anyway - the command

g729 annexb-all

did this:

- outbound calls work

- inbound calls still no audio, but codec g729r8 is now accepted by the ITSP.

Here is the inbound trace:

Ayodeji oladipo... Wed, 06/27/2012 - 07:38

Ok, Your codec look okay now as I can see that g729r8 is used all the way from CUCM to your ITSP.

I can also see that your cube has 2 IP addresses..

Can you do a "sh voip rtp connection" when you do an inbound call. From your trace I can see the the ff IPs

10.0.48.98..what is this ip?

10.0.16.21..what is this IP?

146.191.243.4---------ITSP IP

146.191.201.41--------CUBE IP

146.191.251.40---------CUCM IP

146.191.199.29-----IP Phone IP

Your RTP connection should look like this..

146.191.201.41------------->146.191.199.29

146.191.201.41-------------->146.191.243.4

Can the CUBE reach the IP of the Phone 146.191.199.29? Can you ping this IP from the CUBE?

Can you please attach the updated config onf your CUBE. To attach click on the advanced editor on the right corner of the writing window. Then at the bottom you will see where to attach a file

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

pjiracek Wed, 06/27/2012 - 07:44

Hi, yes the RTP connections are

VoIP RTP active connections :

No. CallId     dstCallId  LocalRTP RmtRTP     LocalIP                                RemoteIP

1     267        268        25010    50026    146.191.201.41                         146.191.243.4

2     268        267        31480    16496    146.191.201.41                         146.191.199.29

Found 2 active RTP connections

The 2 private IP addresses are coming from the ITSP. Our CUBE has 1 IP

hcpgw01#sh ip int brief

Interface                  IP-Address      OK? Method Status                Protocol

Embedded-Service-Engine0/0 unassigned      YES NVRAM  administratively down down

GigabitEthernet0/0         unassigned      YES NVRAM  administratively down down

GigabitEthernet0/1         146.191.201.41  YES NVRAM  up                    up

Ayodeji oladipo... Wed, 06/27/2012 - 07:49

Can the CUBE reach the IP of the Phone 146.191.199.29? Can you ping this IP from the CUBE?

Can you please attach the updated config onf your CUBE. To attach click on the advanced editor on the right corner of the writing window. Then at the bottom you will see where to attach a file

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Ayodeji oladipo... Wed, 06/27/2012 - 08:07

OK. Please remove the dtmf-relay h245 from this dial-peer and add dtmf-relay rtp-nte

dial-peer voice 5555 voip

tone ringback alert-no-PI-------------pls remove this command also (why do you have it ?)

dtmf-relay h245-alphanumeric-----------------Pls remove this and add dtmf-relay rtp-nte

 

pls do the same for all cucm dial-peer. Test again

When you receive an inbound call what happens? Do you hear it ring?

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

pjiracek Wed, 06/27/2012 - 08:19

Great progress - thanks very much - I forgot about the leftovers from the h323 trunk.

I now have audio both ways for the incoming calls!

The only oustanding issue is that there is no ringing tone (or busy tone) in the receiver when the inbound DDI is dialed.

pjiracek Wed, 06/27/2012 - 08:32

All this has been done and I've doublechecked and all is in place.

It works for internal calls and other gateways.

I even tried to assign different MRGLs to the SIP trunk - made no difference.

Ayodeji oladipo... Wed, 06/27/2012 - 08:47

This is a CUCM problem. Because CUCM is sending 183 with SDP. Hence The calling device will listen to whatever cucm is sending either ringback or Busy. Can you send me CUCM trace.

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Ayodeji oladipo... Thu, 06/28/2012 - 01:56

There is nothing in the trace. Did you enable detailed tracing on cucm? You need to use RTMT to collect the trace. You need CUCM sdi trace

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

pjiracek Thu, 06/28/2012 - 02:02

Sorry, posted too early before I got your reply. Attached is the detailed trace. I have removed the

"tone ringback alert-no-PI"

The calling number is 01418483762, the called number is 01387345345811

Attachment: 
Ayodeji oladipo... Thu, 06/28/2012 - 02:15

Can you confirm what type of phone this is 5811. Is it a sip phone? or a phone using sip protocol.

Never mind I have seen that it is a Cisco-CP6921/9.1.1

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

pjiracek Thu, 06/28/2012 - 01:36

Hi there,

I've collected the cucm trace files - which file should I look at and attach?

If I redirect the call, I can hear the callback and I can see in sh voip rtp connection the connection to the ANN.

Thanks

Pavel

Ayodeji oladipo... Thu, 06/28/2012 - 01:46

The redirected call case is correct, because when the call is transfered, the ANN is invoked to play ringback. So that proves ANN is working. However ANN is not needed to play ringback for the direct call. Please send the cucm sdi trace. Please send calling number and called number. Did you remove this command from your dial-peers "tone ringback alert-no-PI"

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

pjiracek Thu, 06/28/2012 - 02:18

Yes, it is

Product Type: Cisco 6921
Device Protocol: SIP
Ayodeji oladipo... Thu, 06/28/2012 - 02:47

I am not sure what is going with this phone..

+++I see the  phone sending a ringing to cucm+++

Incoming SIP TCP message from 146.191.199.29 on port 35767 index 108 with 954 bytes:

[153229,NET]

SIP/2.0 180 Ringing

Via: SIP/2.0/TCP 146.191.251.40:5060;branch=z9hG4bK355385e14f

From: ;tag=50181~58ef7c6e-6d55-43ea-a324-3eb4beb02da5-143377335

To: ;tag=442b031a9eba03dc00003362-00004cfe

Call-ID: 7deaba80-fec11cd2-1a9-28fbbf92@146.191.251.40

+++++++And then cucm sends the ringing to the CUBE+++++++++++

09:58:58.905 |//SIP/SIPUdp/wait_SdlSPISignal: Outgoing SIP UDP message to 146.191.201.41:[5060]:

[153230,NET]

SIP/2.0 180 Ringing

Via: SIP/2.0/UDP 146.191.201.41:5060;branch=z9hG4bKBEED4

From: ;tag=951C870-2458

To: ;tag=50180~58ef7c6e-6d55-43ea-a324-3eb4beb02da5-143377334

Date: Thu, 28 Jun 2012 08:58:58 GMT

Call-ID:

4C4263AF-C03611E1-832AA4DC-D76223A2@146.191.201.41

So ideally the other party should hear the ringing.

Does the called phone ring? I.e this 5811 does it ring?

Does ir ring when you call it internally from another ip phone, do you hear ring on both sides?

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

pjiracek Thu, 06/28/2012 - 02:54

The 5811 phone rings if called externally.

If it is called internally, all is OK: the phone rings and I can hear ringing in the calling receiver.

Correct Answer
Ayodeji oladipo... Thu, 06/28/2012 - 03:39

Hi,

I have looked at the trace in detail and I have an idea why this is not working..

Can you please remove this from your dial-peers to cucm. Please ensure you remove from all dial-peers to cucm and sip provider.

progress_ind setup enable 3

progress_ind alert enable 8

Please do another test call and send me debug ccsip messages.

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

pjiracek Thu, 06/28/2012 - 04:09

Great stuff - that did it.

Thanks a lot for your excellent advice and spending your time on this.

The only remaining thing I'm having with this SIP trunk is that the translation profile doesn't seem to work as I want to.

The profile on the CUBE

voice translation-profile SIP-TRUNK-IN

translate calling 200

translate called 100

with the rule (I've tested it with "test voice translation-rule")

voice translation-rule 100

rule 1 /^01387345\([8-9]..\)$/ /5\1/

is assigned to

dial-peer voice 1 voip

description *** INBOUND SIP TRUNK PEER ***

translation-profile incoming SIP-TRUNK-IN

but it won't do the translation from 013873458XX to 58XX. The CUCM dial peers are then not matched for 5[8-9]..

I can go round this because I can manipulate the format of the called number coming from the ITSP (I can change it on a web portal from 013873458XX to 58XX) but it's not nice. And it puzzles me why the translation profile won't apply.

Pavel

Ayodeji oladipo... Thu, 06/28/2012 - 04:39

I am happy that fixed it. Its always a good idea to mark the post as correct asnwer so it will help others to see that a suggestion fixed it. So feel free to mark the post that fixed the issue as correct answer

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

Correct Answer
Ayodeji oladipo... Thu, 06/28/2012 - 04:20

The reason why this is not working is because the called number is not 5811 from the sip provider..

Your dial-peer 1 is like this..

dial-peer voice 1 voip

  incoming called-number 5[8-9].. (this is not the incoming called number)

it should be this..

dial-peer voice 1 voip

incoming called-number 01387345[8-9]..

Then when this dial-peer is matched, the xlation will be applied.

Please rate useful posts

"For the love of God is broader than the measure of man's mind And the heart of the Eternal is most wonderfully kind"

majoeville Fri, 09/21/2012 - 03:57

Hi pjiracek,

Well done. Im in the UK too and would like to test mine. Could you tell me who's your SIP provider please. Thanks

Jeff

pjiracek Fri, 09/21/2012 - 04:05

Hi Jeff,

We use Thus (C&W) as our SIP trunk provider. They are also our WAN provider.

Cheers

Pavel

Actions

Login or Register to take actions

This Discussion

Posted June 25, 2012 at 1:21 PM
Stats:
Replies:49 Avg. Rating:4.41667
Views:9602 Votes:0
Shares:0

Related Content

Discussions Leaderboard