Jabber DeskPhone Mode Issue

Unanswered Question
Jun 27th, 2012

Im using CUPS 8.6 with CUCM 8.6 with Jabber 9.0.1

I have an issue with Deskphone mode and selecting Use my phone for calls option below.

When I select use my Computer for calls, everything is fine, i can make calls using my PC and my Deskphone is working in synch.

When I select Use my Phone for Calls, most of the time it fails to select this option, When it does choose the option the option it takes a long time and the the Call users is greyed out.

Please see screenshot.

Can somebody please advise why this is happenning or help me troubleshoot?

This was working fine with CUPC 8.5, with Jabber I am having this issue.

To select use my Deskphone option shoud be pretty quick, in this mode should softphone calling functionailty be disabled as in the screenshot below.

I have this problem too.
1 vote
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 4.9 (14 ratings)
navdipatwal Wed, 06/27/2012 - 05:16

I suspect this is a firewall issue between PC and CUCM and various ports being blocked.

Im getting a list of all ports and will get these opened up and then test, if someone can confirm list of all ports used between PC and CUCM for Deskphone mode

mamushta Wed, 06/27/2012 - 07:02

Hi Navdip,

Ports and Protocols used by Jabber for Windows can be found in the Admin Guide. Port 2748 is used to connect to CTI gateway of call manager. Regarding,

"When I select Use my Phone for Calls, most of the time it fails to  select this option, When it does choose the option it takes a  long time and the the Call users is greyed out."

the switch should be pretty quick and the option to click to call a user should be available. Can you provide a problem report to investigate this?

Thanks,

Maqsood

mamushta Wed, 06/27/2012 - 07:28

In reply window click on "Use advaced editor" in the top right corner. You will have the option to upload a file there.

Thanks,

Maqsood

mamushta Wed, 06/27/2012 - 10:04

Hi Navdip,

This is a configuration problem somewhere in your setup. Jabber is trying to connect to Cti server 45.9.110.100 for deskphone control but the connection is timing out. Is this the correct Cti server? Is it up and running properly and accessible from your machine? For softphone client is connecting to 45.9.110.125 and connection works fine.

Main problem is that the CTI server is not accessible to Jabber to switch to deskphone control mode.

Thanks,

Maqsood

navdipatwal Wed, 06/27/2012 - 10:13

Hi there,

Many thanks for the quick reply.

The Cluster Publisher IP address is 45.9.110.100, this will not have the CTI Service Running.

The CCMCIP Defined IP addresses with CUPS of Primary Call Managers for Jabber CSF Devices are 45.4.12.1 and 45.9.110.101 and should have the CTI Service running.

The profile of the Jabber end user has the correct CCMCIP profile.

The Softphone Device is accessing another CallManager (45.9.110.125) which is not listed in the CCMCIP Profile.

Where should I change the setting to reference the correct CTI Server?

mamushta Wed, 06/27/2012 - 11:59

Hi Navdeep,

Check the section Setup a CTI gateway of Jabber for Windows admin guide to find the location and process of specifying this setting.

Thanks,

Maqsood

navdipatwal Thu, 06/28/2012 - 02:50

Hi there,

The CTI Gateways that are referenced were set-up automaticaly when CUPS was tested in a mock-up environment.

I have removed these references and changed user profiles to use the correct CTI Servers.

It is still not working so I am assuming that some services need to be re-started for these settings to take effect.

Can you please confirm whhich services need to be re-started.

mamushta Thu, 06/28/2012 - 03:58

I am not sure about any services that need to be restarted. Did you restart client after making the changes? If that did not help then please open a TAC case for further assistance.

Thanks,

Maqsood

navdipatwal Thu, 06/28/2012 - 04:02

Hi there,

I have re-started client, and restarted SIP Proxy and Presence Engine but it is still not working.

Already raised issue with TAC and awaiting for the right level of engineer to help.

anis_cisco Tue, 07/10/2012 - 14:59

Hello Navdip,

I am having the same problem. can you tell me how you fixed this issue ?

your urgent help will be appreciated.

Regards,

Anis

testspa Wed, 01/23/2013 - 02:20

I had the same issue, i solved it changing the LDAP authentication port on CUCM, from 389 to 3268.

(CUCM>System>LDAP>LDAP Authentication)

Hope this helps, bye

Denis Roman Fulin

thorstenn Mon, 04/22/2013 - 00:08

This also solved the problem for me. Thx,

But could anyone told me why port 389 works for some month and suddenly not? What are the dependencies between LDAP Authentication and control of deskphone?

dsobrinho Sun, 05/05/2013 - 09:59

Hi

I recently had a similar problem. We're testing Jabber for iPhone using ASA VPN (AnyConnect), after completing the creation of the profile TCT, noted that the windowns Jabber is not transited more so for Desk Phone Mode. 

I have a notice in windows jabber is stating the problem in CTI integration. I have check the Line associate with user and CTI Enable  in the group. Everything is okay.

I figured it might be some port configuration in ASA. So I went to connect the laptop on the local network. And the same problem persisted.

Any sugestion?

t.rageth Fri, 05/31/2013 - 04:38

Hi,

I had the same problem with Jabber for Windows not working for controlling deskphones. Well, sometimes it worked, sometimes not. Changing the LDAP authentication from 389 to 3268 (followed by a restart of the CTI Service on the CCM!) solved the problem

Here is the explanation from TAC:

The issue is not with the CUCM or Jabber, but with the LDAP server itself.  The real heart of the problem is the time it takes Microsoft to respond back to CUCM on port 389. The port is valid, and the authentication attempts from CTI Manager will work (sporadically as you have seen) but for best practice we would always recommend for customers that are using any CTI or IMAP/VMREST application to use 3268 as this port is more reliable at responding in the correct amount of time. Basic directory connections for user lookups should be fine with 389, as this issue would only effect CTI Authentication for desk phone control and IMAP/VMREST authentication for Unity Conn. Connections.

Hope this information helps.

Cheers,

Thomas

daviddunaway Tue, 05/07/2013 - 07:13

I think I just figured this one out.

In presence, look under Application>Cisco Jabber>CCMCIP Profile.

Select a user who is not working properly. Make sure that they have a valid CTI Gateway Profile. (Only some of my users did)

It seems that a CTI Gateway Profile is automatically created for each device pool you have in UCM, but there should be a default one. Go to Application>Cisco Jabber>CTI Gateway Profile and look for the default. Check the box that says " Make this the default CTI Gateway Profile for the system". This will  correct the issue for any new user. However, you will need to manually set the  CTI Gateway Profile for existing users. I'm not sure if there is a bulk  administration way of doing so. Luckily I only had a dozen users to fix.

Hope this helps!

David

dsobrinho Tue, 05/07/2013 - 07:46

Hi David,

The problem have been resolved yestarday.

The user had a device 9971 and his  CCM end user did not have the appropriate CTI Access Group applied?

For Cisco Unfied IP Phone 9900 or 8900 series we need, select the

- Standard CCM End Users

- Standard CTI enable

- Standard CTI Allow Control of Phones Supporting Connected Xfer and Conf

For phones 6900 series need

- Standard CCM End Users

- Standard CTI enable

- Standard CTI Allow Control of Phones Supporting Rollover mode

After apply this, everything backs to work properly.

Thank you guys

Daniel

ssareen1810 Mon, 05/20/2013 - 06:48

Mate

You need to make sure that CTI Gateway Profile is configured correctly in the CUPS.

Also make sure that it is applied to all Users.

The next this is to make sure that CCMCIP profile is created and configured properly and is applied to all users.

Make sure User in the CUCM is having Standard CTI Enabled / Standard CCM End User / Standard EM Proxy Authentication rights. Also make sure that all the Phones / Profiles are associated with the end user.

Logout from Jabber and exit the application. Log back in again, it will work for sure.

mohamedessoufy Mon, 10/14/2013 - 05:19

Hello,

I have the same problem and i tryed all above but it's not work.

CUPS 9.1.1.3000 and Jabber 9.2.5.

Any idea please ?

Regards,

Mohamed

Actions

Login or Register to take actions

This Discussion

Posted June 27, 2012 at 5:04 AM
Stats:
Replies:21 Avg. Rating:4.875
Views:7169 Votes:1
Shares:0

Related Content

Discussions Leaderboard