×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

How to Configure SIP

Unanswered Question
Jun 30th, 2012
User Badges:

HI All, 


We are planing impliment SIP in our organisation for making  Long distence calls .with present Setup we are using H.323 and PRI for making Calls. We need H323 and SIP at same time.


Please find the Our Network Diagram and Router Configuration.


Vmoksha IP Telephone System.JPG

Note: Our CCM Has no conectivity to internet.


Router Configutation:


=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2012.06.30 16:38:51 =~=~=~=~=~=~=~=~=~=~=~=

sh run

Building configuration...


Current configuration : 8338 bytes

!

version 12.4

service timestamps debug datetime

service timestamps log datetime

service password-encryption

!

hostname oh-rt2

!

boot-start-marker

boot system flash c3745-advipservicesk9-mz.123-26.bin

boot-end-marker

!

logging buffered 4096 notifications

enable secret 5 $1$AgBh$dCd1NSglSXBbZXmjcdO/I.

!

no aaa new-model

clock timezone IST 5 30

no network-clock-participate slot 2

no network-clock-participate slot 4

voice-card 2

dspfarm

dsp services dspfarm

!

voice-card 4

dspfarm

dsp services dspfarm

!

ip cef

!

!

!

!

ip domain name vmoksha.com

isdn switch-type primary-4ess

!

!

voice hunt user-busy

voice rtp send-recv

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

h323

sip

  bind control source-interface FastEthernet0/1

  bind media source-interface FastEthernet0/1

  transport switch udp tcp

  call service stop forced

!

!

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g711alaw

codec preference 3 g729r8

!

!

!

voice class h323 1

h225 timeout tcp establish 3

!

!

!

!

!

!

!

fax interface-type fax-mail

!

!

controller E1 2/0

framing NO-CRC4

clock source internal

pri-group timeslots 1-24

description for BSnl

!

controller E1 4/0

framing NO-CRC4

pri-group timeslots 1-31

description For Outgoing

!

controller E1 4/1

framing NO-CRC4

pri-group timeslots 1-31 service mgcp

description For Incoming BSNL

!

ip tcp synwait-time 13

!

!

!

interface Multilink1

bandwidth 256

ip address 172.16.16.45 255.255.255.252

ip tcp header-compression iphc-format

ppp multilink

ppp multilink group 1

ip rtp header-compression iphc-format

!

interface FastEthernet0/0

ip address 10.10.14.5 255.255.255.0

ip broadcast-address 10.10.14.255

ip accounting output-packets

ip nbar protocol-discovery

ip route-cache flow

no ip mroute-cache

duplex auto

speed auto

h323-gateway voip bind srcaddr 10.10.14.5

!

interface Serial0/0

description Circuit #1 initiating in India via Bharti

bandwidth 128

no ip address

encapsulation ppp

no ip route-cache cef

no ip route-cache

no ip mroute-cache

clock rate 2000000

ppp multilink

!

interface FastEthernet0/1

ip address 10.10.3.10 255.255.255.0

duplex auto

speed auto

no cdp enable

!

interface Serial0/1

description Circuit #2 initiating in India via BSNL

bandwidth 128

no ip address

no ip route-cache cef

no ip route-cache

no ip mroute-cache

clock rate 2000000

!

interface Serial0/2

description initiating in India via TATA

bandwidth 128

no ip address

encapsulation ppp

clock rate 2000000

ppp multilink

ppp multilink group 1

!

interface Serial0/3

no ip address

shutdown

clock rate 2000000

no cdp enable

!

interface Serial2/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

interface Serial4/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

interface Serial4/1:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

ip forward-protocol nd

ip route 10.10.0.0 255.255.0.0 10.10.14.1

ip route 172.18.252.0 255.255.255.192 10.10.14.1

ip route 192.168.2.0 255.255.255.0 10.10.3.111

ip route 203.92.42.2 255.255.255.255 10.10.3.1 permanent

!

ip http server

!

logging trap errors

access-list 1 permit 10.10.3.18 log

access-list 1 deny   any

access-list 2 permit 10.10.3.18 log

access-list 2 deny   any

dialer-list 1 protocol ip permit

snmp-server community public RO 1

snmp-server community private RW 2

snmp-server location OH/BLR/IN/vMoksha

snmp-server contact [email protected]

snmp-server enable traps tty

!

!

!

control-plane

!

!

!

voice-port 1/0/0

!

voice-port 1/0/1

!

voice-port 1/1/0

cptone IN

timeouts interdigit 3

connection plar 500

!

voice-port 1/1/1

cptone IN

timeouts interdigit 3

connection plar 500

!

voice-port 2/0:15

connection plar 500

!

voice-port 3/0/0

cptone IN

timeouts interdigit 3

connection plar 810

!

voice-port 3/0/1

cptone IN

timeouts interdigit 3

connection plar 500

!

voice-port 3/1/0

cptone IN

timeouts interdigit 3

connection plar 500

!

voice-port 3/1/1

cptone IN

timeouts interdigit 3

connection plar 500

!

voice-port 4/0:15

connection plar 500

!

voice-port 4/1:15

!

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 10.10.14.11 

ccm-manager config

!

mgcp

mgcp call-agent 10.10.14.11 2427 service-type mgcp version 0.1

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

no mgcp package-capability res-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

!

mgcp profile default

!

sccp local FastEthernet0/0

sccp

sccp ccm 10.10.14.11 priority 1

!

dspfarm rtp timeout 60

!

dial-peer cor custom

!

!

!

dial-peer voice 3 pots

service mgcpapp

direct-inward-dial

!

dial-peer voice 4 pots

service mgcpapp

!

dial-peer voice 5 pots

service mgcpapp

!

dial-peer voice 3000 voip

destination-pattern 3...

session target ipv4:160.100.160.151

!

dial-peer voice 9999 voip

destination-pattern 9T

session target ipv4:160.100.160.151

!

dial-peer voice 6 pots

service mgcpapp

!

dial-peer voice 14 pots

destination-pattern 0T

progress_ind setup enable 3

progress_ind progress enable 8

progress_ind connect enable 8

direct-inward-dial

port 4/0:15

!

dial-peer voice 101 voip

destination-pattern 7..

session target ipv4:10.10.14.11

dtmf-relay h245-alphanumeric

codec g711ulaw

ip qos dscp cs5 media

no vad

!

dial-peer voice 102 voip

destination-pattern 8..

session target ipv4:10.10.14.11

dtmf-relay h245-alphanumeric

codec g711ulaw

ip qos dscp cs5 media

no vad

!

dial-peer voice 103 voip

destination-pattern 9..

session target ipv4:10.10.14.11

dtmf-relay h245-alphanumeric

codec g711ulaw

ip qos dscp cs5 media

no vad

!

dial-peer voice 104 voip

session target ipv4:10.10.14.11

dtmf-relay h245-alphanumeric

codec g711ulaw

ip qos dscp cs5 media

no vad

!

dial-peer voice 105 voip

destination-pattern 6..

session target ipv4:10.10.14.11

dtmf-relay h245-alphanumeric

codec g711ulaw

ip qos dscp cs5 media

no vad

!

dial-peer voice 106 voip

destination-pattern 5..

voice-class codec 1

voice-class h323 1

session target ipv4:10.10.14.11

incoming called-number .

dtmf-relay h245-alphanumeric

ip qos dscp cs5 media

no vad

!

dial-peer voice 30 pots

preference 2

destination-pattern *5T

!

dial-peer voice 77 pots

preference 2

destination-pattern *7T

!

dial-peer voice 29 pots

preference 1

destination-pattern *5T

port 1/1/0

!

dial-peer voice 78 pots

preference 1

destination-pattern *7T

port 3/0/1

!

dial-peer voice 2 pots

incoming called-number 8025053.T

direct-inward-dial

!

dial-peer voice 1 pots

description **** For Income Dial Peer***

incoming called-number .

direct-inward-dial

port 4/0:15

!

dial-peer voice 11 pots

description **For income dial*****

incoming called-number .

direct-inward-dial

!

dial-peer voice 45 pots

preference 2

destination-pattern *8T

!

dial-peer voice 44 pots

preference 1

destination-pattern *8T

port 3/0/0

!

dial-peer voice 55 pots

preference 2

destination-pattern *4T

!

dial-peer voice 54 pots

preference 1

destination-pattern *4T

port 3/1/0

!

dial-peer voice 95 pots

preference 2

destination-pattern *6T

!

dial-peer voice 94 pots

preference 1

destination-pattern *6T

port 1/1/1

!

dial-peer voice 5555 voip

destination-pattern *9T

session protocol sipv2

session target ipv4:10.10.14.11

session transport tcp

!

num-exp 8025053... ...

gateway

timer receive-rtp 1200

!

sip-ua

authentication username 123456 password 256487675C

registrar ipv4:10.10.14.11 expires 3600

sip-server ipv4:x.x.x.x

!

!

gatekeeper

shutdown

!

banner motd ^C

!!!AUTHORIZED ACCESS ONLY !!!

Hostname : OH-RTR2.

Location : OH/BLR/IN/

Contact  :IS Helpdesk

!!! AUTHORIZED ACCESS ONLY !!!

^C

!

line con 0

transport output all

line aux 0

transport preferred none

transport output none

line vty 0 5

password 7 1511021F0725

login

transport input all

transport output all

!

ntp clock-period 17180604

ntp server 10.10.8.1

!

end



Thanks

Roopesh

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Chris Deren Sat, 06/30/2012 - 07:34
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,
  • Cisco Designated VIP,

    2017 IP Telephony, Contact Center, Unified Communications

Who is your SIP provider?

Config may vary based primarily on whether they need authentication or not.

Have you searched this forum for examples as similar question was posted many times before.

SIP and H323 can coexist on the same router but SIP requires CUBE licenses when integrating to SIP provider.


Chris


Sent from Cisco Technical Support iPhone App

roopesh.n Sun, 07/01/2012 - 23:16
User Badges:

Hi chris,


Thanks for the Replay.

Our SIP provider is TATA Communications. They have Given the User ID and Password  also SIP Proxy address.


We need help in configuration whether we need to configure the authentication in our Getaway(Router) or in CCM.


Please suggest.


Thanks


Roopesh

Chris Deren Mon, 07/02/2012 - 05:58
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,
  • Cisco Designated VIP,

    2017 IP Telephony, Contact Center, Unified Communications

Authentication can only be done on CUBE as CUCM does not support authentication of SIP trunks (one of many benefits of having CUBE).  So, you configure SIP trunk between CUBE and CUCM that is not authenticated and CUBE and service provider that configures authentication, you can either define the credentials on dial-peers or under sip-ua.


HTH,


Chris

Actions

This Discussion

Related Content