×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

SSLVPN and Windows 7

Unanswered Question

Hello all,


I trying to setup the SSLVPN Portforwarding on the Cisco SA 540.

Now I am at the stage where I want to actually test it on a remote machine.

The remote machine I am using is a Windows 7 Home Premium 64bit machine.

On this machine is installed IE9 (version 9.0.8112.16421) 64bit and the latest version of Java (version 6 update 32)

The Cisco SA 540 is running with firmware 2.1.71


I am running IE with administrator priviliges.


When I logon to the SSL portal and I go to "Port Forwarding" and then click on the icon the client is trying to install but crashes with the attached error message.


If there is no solution then I would like to hear if Cisco is having plans to get this fixed in maybe the next coming firmware update?


I hope that anyone can help me out here :-(


It is really important that I get this working.......

Installing a normal Cisco VPN client is not an option since I don't want a "normal' user browsing through all the systems on the network. With SSL VPN this is something I can nicely configure with the help of policy's



Cheers and thanx,


Dave Diependaal

JouwFM

The Netherlands

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Tom Watts Mon, 07/02/2012 - 22:42
User Badges:
  • Green, 3000 points or more

Hello Dave Diependaal,


This issue may be related to a bug CSCtf62341. Please follow these steps mentioned below.  In addtion, I would recommended to install the Microsoft Visual C++ 2010 distribution. If this does not resolve your issue, please call the SBSC support center at 0800 023 3416 and please have prepared your CCOID, Serial Number and provide the agent this community forum post.


Workaround This can indicate that the previous VPN client did not uninstall

correctly from your PC.

Clean up the previous client installation by following these steps:

a. In Internet Explorer, on the Tools menu, click Internet Options.

b. On the General tab, click Settings.

c. Click View Objects.

d. Delete all object files then relaunch the browser.

If this workaround does not resolve the problem, do the following:

a. Click Start and then click Control Panel. Double-click System.

b. On the Hardware tab, click Device Manager.

c. Double-click Network Adapters. Right-click the Vpn Tunnel ssldrv adapter

and click Uninstall.

d. Restart your system.



Here is also a link with some useful information;

https://supportforums.cisco.com/message/3671862#3671862

Hello Thomas,


First of all thank you for the quick response.

The first part of your solution (Deleting all objects) is not solving the problem.

The second part, uninstall VPN Tunnel SSL Adapter, I can not do since I don't have it.


I also installed the Microsoft Visual C++ 2010 distribution.


Any other suggestions?


Kind regards,

Dave Diependaal

Tom Watts Tue, 07/03/2012 - 08:41
User Badges:
  • Green, 3000 points or more

Dave,


Are you able to connect to the SSL VPN at all without using the port forwarding?

If not, what error do you receive?

When you're testing, you are on an external network from the SA540?

Are you using a 64-bit internet explorer?

Can you test with a 32-bit machine?

Dear Thomas,


I've sended you a private message with a URL and a test account.

I was testing the Port Forwarding on an iMac (both Safari and Firefox) and I was testing on a Windows 7 Starter machine.

It all ends with the same error message:"Error: Virtual Transport Execution Failed".


Hopefully this helps and you are able to help me further,


Kind regards,

Dave Diependaal

Tom Watts Wed, 07/04/2012 - 07:55
User Badges:
  • Green, 3000 points or more

Thanks Dave, I tried the test account and sent you a screen shot.

The successful connect is using a Window 7 Home Premium 64-bit with IE9 64-bit.



Since you're using MAC, there are some other issues.... Give this a try


CSCtj02357

Unable to connect to an SSL VPN tunnel when running Mac OS X Snow Leopard.

Workaround To connect to the tunnel, the root user must add the following

line in the /etc/sudoers file:

test ALL=NOPASSWD: /usr/sbin/chown,/bin/chmod,/bin/rm where test is the

admin username.

Note: This line only needs to be added “once” for each Mac and corresponding

line for every admin user.

Hi Thomas,


I've seen your private posting and I am now wondering what to do next?

You have it working on your machine, I am still here with a Windows environment that I can't get working :-(

Did you had to make changes to your Internet Explorer? Setting the URL that I gave you to the Intranet / Trusted Sites?

The machine where I have the problem is running Java 7 update 5 (build 1.7.0_05-b05).


In a IE9 32 bit I get an error message saying that the software (the SSL Tunnel) can only be installed in IE 64 bit.

In IE(9) 64 bit I get the message "Installing transport engine failed".


What to do now?


Cheers

Dave

Tom Watts Wed, 07/04/2012 - 10:21
User Badges:
  • Green, 3000 points or more

Hi Dave, no I didn't modify my internet explorer, This computer I am presently using never had a VPN software / client install.


Are you able to default your IE9 64 bit to a fresh install?

I never use IE9 and it's probably the first I ever had on this computer since I only use Mozilla. Are you using a VM on your MAC computer or are you using a completely different machine?

Are you trying to connect from the same local network or are you remote to the router?

Tom Watts Wed, 07/04/2012 - 12:24
User Badges:
  • Green, 3000 points or more

On this particular machine I am running JRE 6, update 22. I wonder if I update to the latest and greatest if it still works.


I just updated to the latest Java build and successfully connected again.


I think this would warrant a call to the SBSC to see if we can get it working and at least have a service request created for you.

Here is the contact number list

http://www.cisco.com/en/US/support/tsd_cisco_small_business_support_center_contacts.html

jeffreychien Wed, 09/12/2012 - 11:58
User Badges:

I called and Cisco was no help what so ever.  The client installs fine if you do it correctly the first time.  But once the install fails for any reason you are SOL.  I have removed all files assoicated with the SSL VPN and also removed any registry items that hav xtunnel referenced.


Does anyone else have any suggestion?

Tom Watts Wed, 09/12/2012 - 14:47
User Badges:
  • Green, 3000 points or more

Hi Jeffrey, when you configure the SSL adapter, there should be a option to uninstall the adapter upon closing the browser.


When I generate a 'failed' install, I do not have the symptom you mention using Windows Vista 64 bit or Window 7 Home Premium 64 bit.


Check this post out, it is a great reference;

https://supportforums.cisco.com/message/3732439



-Tom
Please rate helpful posts

Actions

This Discussion

Related Content