Port-Channel Issue: SP-5-CANNOT_BUNDLE_LACP

Answered Question
Jul 3rd, 2012

I'm having an issue with the port-channel coming up. Right now it's "down down". I'm not really sure why. All other port-channels on the 6500's in VSS work fine. This one seems to be giving me an issue though.

-Both interfaces that are using this port-channel are "up up".

-I've done "shut's, no shut's" on all interfaces involved.

sh etherchannel summary

Flags:  D - down        P - bundled in port-channel

        I - stand-alone s - suspended

        H - Hot-standby (LACP only)

        R - Layer3      S - Layer2

        U - in use      N - not in use, no aggregation

        f - failed to allocate aggregator

        M - not in use, no aggregation due to minimum links not met

        m - not in use, port not aggregated due to minimum links not met

        u - unsuitable for bundling

        d - default port

Po4(SD)         LACP      Gi1/1/4(I)     Gi2/1/4(I)  

interface Port-channel4

switchport

switchport access vlan (vlan number)

switchport mode access

load-interval 30

flowcontrol receive desired

spanning-tree portfast edge

end

interface GigabitEthernet1/1/4

switchport

switchport access vlan   (vlan number)

switchport mode access

load-interval 30

flowcontrol receive desired

spanning-tree portfast edge

channel-protocol lacp

channel-group 4 mode active

end

interface GigabitEthernet2/1/4

switchport

switchport access vlan  (vlan number)

switchport mode access

load-interval 30

flowcontrol receive desired

spanning-tree portfast edge

channel-protocol lacp

channel-group 4 mode active

end

sh log

149886: Jul  3 15:20:34 CDT: %EC-SW1_SP-5-CANNOT_BUNDLE_LACP: Gi2/1/4 is not compatible with aggregators in channel 4 and cannot attach to them (flow control receive of Gi2/1/4 is desired, Gi1/1/4 is on)

149887: Jul  3 15:20:35 CDT: %EC-SW2_SPSTBY-5-CANNOT_BUNDLE_LACP: Gi2/1/4 is not compatible with aggregators in channel 4 and cannot attach to them (flow control receive of Gi2/1/4 is desired, Gi1/1/4 is on)


Thank you for your help.

I have this problem too.
0 votes
Correct Answer by pstebner10 about 1 year 9 months ago

Hi Mark-

What is on the other end of the port-channel? It looks like Gi1/1/4 is negotiating flow control with the far end and going into a receive 'on' state, while Gi2/1/4 is not. They both need to be in the same state to form a bundle. You can check the status with sh int Gi1/1/4 flowcontrol for example.

I would either look to change the other side's config or set flowcontrol receive off on both local switchports.

HTH,

Paul

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
Correct Answer
pstebner10 Tue, 07/03/2012 - 19:35

Hi Mark-

What is on the other end of the port-channel? It looks like Gi1/1/4 is negotiating flow control with the far end and going into a receive 'on' state, while Gi2/1/4 is not. They both need to be in the same state to form a bundle. You can check the status with sh int Gi1/1/4 flowcontrol for example.

I would either look to change the other side's config or set flowcontrol receive off on both local switchports.

HTH,

Paul

mark76ped Wed, 07/04/2012 - 06:47

show inter gig 1/1/4 flowcontrol

Port          Send FlowControl  Receive FlowControl  RxPause TxPause

                admin    oper         admin    oper                      

-----------     -------- --------           --------     --------           ------- -------

Gi1/1/4      desired  on            on         on                0       0     

show inter gig 2/1/4 flowcontrol

Port          Send FlowControl  Receive FlowControl  RxPause TxPause

                admin    oper           admin    oper                      

-----------     -------- --------             --------   --------             -------       -------

Gi2/1/4      desired  on              on         on                 0          0   

I turned off flowcontrol receive like you suggested but still no luck. Then I disjoined the two interfaces from the port-channel, deleted the port-channel, recreated it, and then rejoined the interfaces to the port-channel while having flowcontrol receive off. Still no luck. I am assuming the other end, which is not a cisco device, doesn't support port-channeling in its current state. I will get with the people who administer it and see what I can work out.

Thank you all for your help.

mark76ped Thu, 03/14/2013 - 07:53

It turns out the non-cisco devices on the other end weren't capable of handling port-channeling.

dmamadjanov Tue, 07/03/2012 - 20:18

Trying changing the mode to Desirable

Sent from Cisco Technical Support iPhone App

Sandeep Choudhary Wed, 07/04/2012 - 07:18

HI Mark,

1. Can you please check your ethernet card ...where this port channel connected..on the server.

    may be there are 2 different card.

2. from cisco websites:

Error Message

Explanation

This port has different port attributes than other ports within the port channel.

Recommended Action

Match the port attributes to that of the port channel.

Regards

Please rate if it helps.

Match the port attributes to that of the port channel.

This port has different port attributes than other ports within the port channel.

EC-5-CANNOT_BUNDLE_LACP: [char] is not compatible with aggregators in

channel [dec] and cannot attach to them ([char])

Actions

Login or Register to take actions

This Discussion

Posted July 3, 2012 at 2:08 PM
Stats:
Replies:6 Avg. Rating:5
Views:2953 Votes:0
Shares:0
Categories: Switches
+

Related Content

Discussions Leaderboard

Rank Username Points
1 15,007
2 8,150
3 7,730
4 7,083
5 6,742
Rank Username Points
155
77
70
69
50