Cisco 887 slow loading web page

Answered Question
Jul 3rd, 2012

Hello all!

I've just recently upgraded a Cisco 877 to 887W router.

I basically copied most of the config across to the router with no problem.

ppp chap hostname and password all ok. ATM and Dialer1 interface comes up.

The problem I'm having is when I open Internet Explorer up, default homepage is Google. Google loads up fine, type a search is fine but when you click on the link or type URL, for example BBC News or Sky Sports, it takes a long time to load or times out (Page cannot be displayed)

DNS servers configured on Cisco router are:

8.8.8.8 and Virgin's DNS servers.

NSLOOKUP in cmd prompt it returns IP add no problem. however in web browser it fails except for Google.

However, with the same config on a 877 everything works perfectly... any ideas guys?

Cisco 877 running 12.4

Cisco 887 running 15.0

Thanks in advance

I have this problem too.
0 votes
Correct Answer by Cadet Alain about 1 year 9 months ago

Hi,

have you got ip tcp mss-adjust 1452 and ip mtu 1492 configured on dialer  interface ?

Regards.

Alain.

Don't forget to rate helpful posts.

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
Correct Answer
Cadet Alain Wed, 07/04/2012 - 01:58

Hi,

have you got ip tcp mss-adjust 1452 and ip mtu 1492 configured on dialer  interface ?

Regards.

Alain.

Don't forget to rate helpful posts.

JDMJeffy84 Tue, 11/20/2012 - 02:39

slow reply but yeah it was MTU issue, adjusted MTU size on VLAN 1 to 1412 and dialer & ATM to 1452, bingo everything started working, cheers

mgrevtech Tue, 11/19/2013 - 05:23

@JDMJeffy84

Got a question for you, just for myself to understand the config - why do you have:

!

!

ip dns server

ip nat inside source list 1 interface Dialer1 overload

ip route 0.0.0.0 0.0.0.0 Dialer1 interface Dialer0
!

!
ip dns server
ip nat inside source list 1 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1

!

these commands in two places (top and bottom) or was that just a typo?

And you have the "ip route" command as different in both?

JDMJeffy84 Wed, 07/04/2012 - 03:09

Hi Alain,

yes both configs confirgured on dialer interface.

interface ATM0

ip virtual-reassembly in

ip tcp adjust-mss 1452

no atm ilmi-keepalive

hold-queue 224 in

!

interface ATM0.1 point-to-point

ip flow ingress

pvc 0/38

  pppoe-client dial-pool-number 1

!

!

ip dns server

ip nat inside source list 1 interface Dialer1 overload

ip route 0.0.0.0 0.0.0.0 Dialer1 interface Dialer0
!
interface Dialer1
ip address negotiated
ip access-group 102 in
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
ppp authentication chap callin
ppp chap hostname abc@abc.com

ppp chap password 7 xxxx

no cdp enable
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip dns server
ip nat inside source list 1 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1

!

it's wierd only www.google.com works fine and making a search but click on the link it fails or takes an age to load.

if I type show host on the router I can see the hostname resolving

johnlloyd_13 Wed, 07/04/2012 - 03:22

hi,

could you temporarily remove these lines and see if performance gets any better?

no ip nbar protocol-discovery

no ip inspect CO_Firewall in

no ip inspect CO_Firewall out

JDMJeffy84 Wed, 07/04/2012 - 03:47

1. removed :

no ip nbar protocol-discovery

no ip inspect CO_Firewall in

no ip inspect CO_Firewall out

Google does not load

2.

no ip nbar protocol-discovery

no ip inspect CO_Firewall in

ip inspect CO_Firewall out

Google takes a long time to load but other webpages still take a long time or times out

3.

no ip nbar protocol-discovery

no ip inspect CO_Firewall in

ip inspect CO_Firewall out

Google loads up instantly but other webpages still take a long time or times out

johnlloyd_13 Wed, 07/04/2012 - 03:53

thanks for the update! could you post your running-config and remove any sensitive info?

Cadet Alain Wed, 07/04/2012 - 03:55

Hi,

could you post the entire running-config.

Regards.

Alain.

Don't forget to rate helpful posts.

johnlloyd_13 Thu, 07/05/2012 - 07:19

Hi,

Remove this line under your ATM interface and try again. Are you doing web surfing from a wired or wireless LAN connection?

int atm0

no hold-queue 224 in

Sent from Cisco Technical Support iPhone App

JDMJeffy84 Thu, 07/05/2012 - 08:34

same John, I am using wired connection.

I have looked into the ip inspect part. I can get a established connection for google.

But only Half open session for any other webpages. I can see the IP Address so DNS is working? nslookup brings up the correct web name.

So I'm guessing IP inspect is the problem?

I've removed all the inspect only leaving UDP and TCP - still the same.

If I remove TCP everything fails

AHH headache

johnlloyd_13 Fri, 07/06/2012 - 02:31

Hi,

Retain the ip inspect command in VLAN 1 interface and remove these lines:

int d1

no ip inspect CO_Firewall in

no ip inspect CO_Firewall out

int atm0

no hold-queue 224 in

Sent from Cisco Technical Support iPhone App

phoenix3195 Fri, 07/06/2012 - 06:56

Hi,

Try to lower MTU and adjust TCP mss to a value lower than 1450

conf t

int di 1

ip mtu 1480

ip tcp adjust-mss 1420 (or you migh need to have it lower than that, i usually adjust it to 1380)

rizwanr74 Fri, 07/06/2012 - 07:28

Hi Jeffy,

Please remove the highlighted lines below.

interface ATM0

ip tcp adjust-mss 1452

--------------------------------------------

Please copy the highlighted line on the interface wlan-ap0.

interface wlan-ap0

ip tcp adjust-mss 1452

Please update me.

thanks

JDMJeffy84 Sun, 07/08/2012 - 01:46

Guys, I think I resolved this the model we're using doesn't support ADSL only supports ADSL2/ 2+ (

CISCO887W-GN-E-K9)

Can someone confirm this? Cisco release notes doesn't state this.

if it doesn't support ADSL then why does the ATM/ Dialer interface come up and establishes ppp connection with provider.

And why does Google homepage and search function works?

Thanks

ericsonmisagal Sun, 07/08/2012 - 05:42

Try with clean configuration and see...

interface ATM0

no ip address

no atm ilmi-keepalive

pvc vpi/vci

  pppoe-client dial-pool-number 1

!

interface Vlan1

ip address aaa.bbb.ccc.ddd yyy.yyy.yyy.yyy

ip nat inside

ip virtual-reassembly in

ip tcp adjust-mss 1452

!

interface Dialer0

ip address negotiated

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer pool 1

ppp authentication chap callin

ppp chap hostname xxxx

ppp chap password yyyy

!

ip nat inside source list 1 interface Dialer0 overload

ip route 0.0.0.0 0.0.0.0 Dialer0

!

access-list 1 permit any

Good Luck.

Paolo Bevilacqua Fri, 09/07/2012 - 22:31

JDMJeffy84 wrote:

Guys, I think I resolved this the model we're using doesn't support ADSL only supports ADSL2/ 2+ (

CISCO887W-GN-E-K9)

Actually it supports all types of ADSL.

eoghan_murtagh Fri, 09/07/2012 - 06:37

Hi All,

Thanks for this post the ip tcp adjust-mss 1452 (on the dialer interface) setting solved this problem for me on 2 new Cisco 887 routers.

Thanks for your help,

Eoghan

Actions

Login or Register to take actions

This Discussion

Posted July 3, 2012 at 2:19 PM
Stats:
Replies:19 Avg. Rating:5
Views:6547 Votes:0
Shares:0

Related Content

Discussions Leaderboard