IP Phone not registering to the Call Manager

Answered Question
Jul 4th, 2012

Hello

I hope someone can help me with this.

I have an IP Phone model 7942 which I am trying to register to a Call Manager but it is saying registration rejected.

There are other IP Phones all of 7942 which are registering to the Call Manager no problem and are working fine.

All these IP Phones are in the same subnet connected to the same switch and have same configuration on the switch ports.

When I am doing a sh arp i am seeing that there is an IP address associated with the MAC address of this IP phone which is not working but when i am trying to ping this IP address I cannot.

I tried to plug this IP Phone into a same port using the same cable by replacing an IP Phone which was already registered to check whether this could be a cable / port issue without any luck and see the same issue.

The status on the Call Manager is saying Unknown and the IP address is showing Unknown as well on the Call Manager.

Can anybody please advice on where the issue could lie.

Many Thanks in advance.

Regards

Kaushik

I have this problem too.
0 votes
Correct Answer by Ayodeji oladipo... about 1 year 9 months ago

If it says registration rejected, then you should see registration rejected on cucm. This is usually a configuration problem. Check that you have the correct mac address on cucm and check that the tftp server on the phone is the right one

Please rate all useful posts

"There is a wideness in God's mercy Like the wideness of the sea.There's a kindness in His justice Which is more than liberty"

Correct Answer by ronpatel about 1 year 9 months ago

Hi

Have you added this phone in CUCM. Or do you have auto reg on in CUCM.

Yes the method you have written is the correct method for factory reset.

Regards

Ronak patel

Rate helpful posts.

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (4 ratings)
ronpatel Wed, 07/04/2012 - 03:43

Hi Kaushik,

Try to do factory rest of the phone and see if it regester. 

Regards

Ronak Patel

Rate helpful posts by clicking stars below the answer.

kaushik.ray Wed, 07/04/2012 - 03:46

Thanks Ronak

Will the following be the best way to carry out the factory reset?

Procedure

Step 1 Unplug the power cable from the phone and then plug it back in.

The phone begins its power up cycle.

Step 2 While the phone is powering up, and before the Speaker button flashes on and off,

press and hold #.

Continue to hold # until each line button flashes on and off in sequence in amber.

Step 3 Release # and press 123456789*0#.

You can press a key twice in a row, but if you press the keys out of sequence, the factory reset will not take place.

After you press these keys, the line buttons on the phone flash red and the phone goes through the factory reset process.

Do not power down the phone until it completes the factory reset process and the main screen appears.

Thanks

Kaushik

Ayodeji oladipo... Wed, 07/04/2012 - 03:49

Before you do a factory reset. What does the status messages on the phone show ?

Please rate all useful posts

"There is a wideness in God's mercy Like the wideness of the sea.There's a kindness in His justice Which is more than liberty"

Correct Answer
ronpatel Wed, 07/04/2012 - 03:55

Hi

Have you added this phone in CUCM. Or do you have auto reg on in CUCM.

Yes the method you have written is the correct method for factory reset.

Regards

Ronak patel

Rate helpful posts.

Correct Answer
Ayodeji oladipo... Wed, 07/04/2012 - 03:57

If it says registration rejected, then you should see registration rejected on cucm. This is usually a configuration problem. Check that you have the correct mac address on cucm and check that the tftp server on the phone is the right one

Please rate all useful posts

"There is a wideness in God's mercy Like the wideness of the sea.There's a kindness in His justice Which is more than liberty"

kaushik.ray Wed, 07/04/2012 - 04:41

The exact error message on the phone is

Phone displays “Registration rejected: Error DBconfig”

I checked that the error relates to Auto Registration but the Auto Registration Disabled option is ticked on the CUCM

ronpatel Wed, 07/04/2012 - 04:46

Hi,

Since the Auto Reg is disable. Have you added this phone manually in CUCM.  If not , please add this phone manually using following procedure example is for 7961 but remains same for other ip phones.

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_configuration_example09186a0080b48df1.shtml

After that you may restart tftp services on CUCM.

Regards

Ronak Patel

Rate helpful posts.

kaushik.ray Wed, 07/04/2012 - 06:25

HI

It was manually added before

how do i restart the tftp services on CUCM?

Regards

etamminga Wed, 07/04/2012 - 14:45

Hi,

Have you checked your db replication state?

Have you checked that the phone type and protocol are correct on cucm?

Have you tried registering with the default phone button template selected? (yes I've seen this fail, bug)

Have you double checked the Mac address?

Have you verified 2 phone configs (working/non-working) side by side to see what's different?

Have you restarted all tftp services?

regards,

Erik

Sent from Cisco Technical Support iPad App

kaushik.ray Thu, 07/05/2012 - 01:39

The DB Replication state is shwowing 0

The phone type is checked is 7942 and protocol is SCCP as with other phones that are working

Yes the MAC addresses i have checked and also compared the configs. i also deleted the non - working phone did a super copy of the one which is working and changed the extension.

I have checked that the Auto Registration Disabled box is ticked as well and there are no duplicate DNs

Will a factory reset of the phone help?

Thanks once again.

Regards

ronpatel Thu, 07/05/2012 - 01:46

Hi

Can you send us screen shot of the Phone configuration. And MAC address of the Ip phone.

Regards

Ronak Patel

ronpatel Thu, 07/05/2012 - 02:01

Hi Kaushik,

I cant find attachment....

Regards

Ronak Patel

Ayodeji oladipo... Thu, 07/05/2012 - 01:58

Can you run this command from a windows based machine. If you are on windows 7 you will need to turn of tftp, if you are on windows xp then this will work. Here is the command

tftp -i 10.1.1.1 get SEP0000DEADBEEF.cnf.xml

Change 10.1.1.1 to the tftp ip of your cluster

SEP0000DEADBEEF to the mac address of the phone in question. Once downloaded attach the xml file here

Please rate all useful posts

"There is a wideness in God's mercy Like the wideness of the sea.There's a kindness in His justice Which is more than liberty"

kaushik.ray Thu, 07/05/2012 - 02:13

aokanlawon

the window version is Windows Server 2008 and is returing as

C:\Users\abcd>tftp -i xxx.xxx.xxx.xxx get SEPXXXXXXXXXXXX.cnf.xml

'tftp' is not recognized as an internal or external command,

operable program or batch file.

Aaron Harrison Thu, 07/05/2012 - 02:21

Hi

On Win7 upwards (including 2008) tftp client isn't installed by default.

You can run this command as admin to install it (or go through the 'add features' menus):

dism /online /enable-feature /featurename:TFTP

Regards

Aaron Harrison

Principal Engineer at Logicalis UK

Please rate helpful posts...

Ayodeji oladipo... Thu, 07/05/2012 - 02:29

Please run the command as Aaron suggested. If you dont have admin access then use the

Role/Service or Main Feature menu and install tftp client.

Please rate all useful posts

"There is a wideness in God's mercy Like the wideness of the sea.There's a kindness in His justice Which is more than liberty"

Actions

Login or Register to take actions

This Discussion

Posted July 4, 2012 at 3:39 AM
Stats:
Replies:20 Avg. Rating:5
Views:4368 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard