TEO 2.3 and Powershell remote execution error

Answered Question
Jul 6th, 2012


I am running into errors when trying to run powershell scripts on a remote target. I have tried the following things so far using just "get-date" as a command in the script.

1. Set remote execution policy to unrestricted.

2. Enable the checkbox for accessing remote resources.

And after setting the above, I get the following error.

Exception has been thrown by the target of an invocation.

Access is denied.

Now, if I try using the Run Windows Command activity, I am able to run the required commands on the remote target, but powershell script activity fails for the same target.

Surprisingly, this works fine on TEO2.2


Rishikesh R.

I have this problem too.
0 votes
Correct Answer by Christopher Roberts about 2 years 7 months ago

This was fixed in HF3 for 2.3.0. Please install it to fix this issue.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Christopher Roberts Fri, 07/06/2012 - 04:02

For #2, why did you enable that? This means you need to enable remote resources, like a remote shared drive or something like that. So you make a double hop(in Microsoft terms). You hop once to your target and once again to your remote shared drive. WMI does not allow this for security policy reasons so we have to do something else when you select that.

Try unchecking it and running it and see if that helps. If not, open a TAC case and someone from support can assist you.

-shaun roberts

CPO/CIAC Support Team Lead


Rishikesh Radha... Fri, 07/06/2012 - 04:10


Thanks for your response. I tried the workflow without checking that too. But since it didnt work, I assumed that perhaps that checkbox enables running powershell scripts on remote targets too, I wasn't aware that the implications for that checkbox relate to other shared resources.

I just tried running the Get-Date command without the option for remote resources and it failed again.

Let me reach out to TAC.


Rishikesh R.

Correct Answer
Christopher Roberts Fri, 08/24/2012 - 12:27

This was fixed in HF3 for 2.3.0. Please install it to fix this issue.


Rishikesh Radha... Fri, 08/24/2012 - 12:30

Hi Shaun,

Yes, the HF3 fixed the problem. Thanks for your help!!


Rishikesh R.


Login or Register to take actions

This Discussion

Posted July 6, 2012 at 1:53 AM
Replies:4 Overall Rating:5
Views:438 Votes:0
Tags: powershell
Categories: 2.2, CPO 2.3, CPO 2.3

Related Content


Discussions Leaderboard

Rank Username Points
Paul Jeffrey
vigneswara rao ...