Corporate Directory on CUCM 8.6

Answered Question
Jul 9th, 2012
User Badges:

Hi voice team,

     I am with the following problem: Only the model 7942G does not access the corporate directory the message (host not found), the other models usually access. I realized that only this model tries to access the corporate directory via https://CUCM_IP:8443/ccmcip/authenticate.jsp, others access via http on port 8080. How to fix this?


Thanks.

Correct Answer by Ayodeji Okanlawon about 4 years 10 months ago

Thiago,


This is where the problem is. The TVS





2445

cur1sr07





The TVS entry is a hostname, which is why you're getting the host not found because your phone isn't configured for DNS or cannot resolve that name.  The fix is to change under System > Server, the hostname to an IP address there, save it, then restart th Trust Verification Service (TVS),


Please rate all useful posts


"There is a wideness in God's mercy Like the wideness of the sea.There's a kindness in His justice Which is more than liberty"

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (10 ratings)
Loading.
William Bell Mon, 07/09/2012 - 09:29
User Badges:
  • Purple, 4500 points or more

Thiago,


That is definitely interesting. One, that this phone model is going its own way and two that is going the authenticate.jsp application instead the correct corporate direct url (xmldirectory.jsp). My UCM 8.6 lab system is offline at the moment so I can't check locally. However, this is either a config issue or a bug.


First, if you have a 7962G, check that phone. The 7942G and 7962G run the same firmware. If the 7962G is OK, check the device defaults page to ensure you are using the same version of firmware across both platforms.


Next, check to see if your 7942G is configured to use a different provisioning model for services (Internal, External, Both). Compare it to a known good. Check the device level and the phone template assigned. Focus on differences.


Next, I would pull the 7942G's TFTP config file from the TFTP server. You can use any TFTP client that is allowed to communicate to your UCM. Pull the config down and look inside. Compare it to a known working config. The config file is a little bit of a beast but there is a section for phone services (like the directories) and you are basically comparing to see what's different there (if anything).


Finally, I would test a theory and see if you can get the 7942G working by bypassing the Enterprise Subscription. Provision a sample phone for External services provisioning. Then go to that phone and "hardcode" the directories URL to point to the correct application. You can copy from Enterprise Parameters, just make sure that you are using IP address or a hostname that the phone can resolve. See if that causes the phone to go where you want it to. This isn't a solution but a test that will help determine whether you are dealing with a software issue or not.


If you find strong indication of a software defect then Tac is where you should go. Or, if you wait a little while I am sure Mr. Huffman will come in with the bug ID (he is a master at the bug query).


HTH.


Regards,

Bill

http://ucguerrilla.com

Ayodeji Okanlawon Mon, 07/09/2012 - 09:41
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

Thiago,


Can you do the ff: From a windows machine run the following command


tftp -i 10.1.1.1 get SEP0000DEADBEEF.cnf.xml


change 10.1.1.1 to your cucm ip address, and sep00000..to one of the 7942 phone mac address.


If you are using windows 7 you will need to enable the tftp client feature...You can run this command to enable it if you have admin rights..


dism /online/enable-feature/featurename:TFTP


Please attach the config file.


Please rate all useful posts


"There is a wideness in God's mercy Like the wideness of the sea.There's a kindness in His justice Which is more than liberty"

Aaron Harrison Mon, 07/09/2012 - 10:13
User Badges:
  • Super Bronze, 10000 points or more
  • Community Spotlight Award,

    Member's Choice, May 2015

Depending what model phones you have in your org, this may or may not be strange.


If it happens that the 7942/62 is the only model modern enough to support ITL then that's likely where the problem is.


It is possible to disable the https access, but not generally a good idea as you are only masking the problem.


Perhaps:


1) Respond with the list of other phone models that you have

2) Verify whether your 7942s trust the TFTP service (best way is to assign the phone a new CCM group, and then verify that it correctly registers to the new primary CUCM - if it does not, then you have a problem)

3) Try restarting the TVS (Trust Verification Service) on the server that the phone is registered to, restart the phone, and try it again.


Regards


Aaron

Thiago Gandara Mon, 07/09/2012 - 10:34
User Badges:

Hi, the models that I have here are: 7911, 7937, 7941 and 7921, these models the corporate directory works perfectly. Here in the company, we only have a CUCM, i restarted the TVS and the phone, but doesn´t work.


Thanks.

Thiago Gandara Mon, 07/09/2012 - 10:36
User Badges:

Hi, I use Win 7 and I have permission, but I could not run these commands.

Rob Huffman Mon, 07/09/2012 - 10:35
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Thiago,


I'll just add one more note to the great tips from Bill, Deji and Aaron (+5 each guys )


In CUCM 8.x there is a new config setting for Secure Directories that it appears

the 7942 is trying to use. This is where I would start looking;


Overview


Prior to Cisco Unified Communications Manager Release 8.0, Cisco Unified  IP Phones and services did not support HTTPS communication over port  8443.


For Cisco Unified Communications Manager Release, the following features support HTTPS:


Extension Mobility


Extension Mobility Cross Cluster


Manager Assistant


IP Phone Services (See the "Phone Configuration Settings" section.


Personal Directory (CCMPD)


Change Credentials



Phone Configuration Settings


To support HTTPS in Cisco Unified Communications Manager Release 8.0(1),  the Phone Configuration Settings include the secure URL parameters  shown in Table 3-9.




Table 3-9     Phone Configuration Settings for Secure URLs 

Field
Description

Secure Authentication URL

Enter the secure URL that the phone uses to validate requests that are made to the phone web server.

Note If  you do not provide a Secure Authentication URL, the device uses the  nonsecure URL. If you provide both a secure URL and a nonsecure URL, the  device chooses the appropriate URL, based on its capabilities.

By default, this URL accesses a Cisco Unified CM User Options window that was configured during installation.

Leave this field blank to accept the default setting.

Maximum length: 255

Secure Directory URL

Enter the secure URL for the server from which the phone obtains  directory information. This parameter specifies the URL that secured  Cisco Unified IP Phones use when you press the Directory button.

Note If  you do not provide a Secure Directory URL, the device uses the  nonsecure URL. If you provide both a secure URL and a nonsecure URL, the  device chooses the appropriate URL, based on its capabilities.

Leave this field blank to accept the default setting.

Maximum length: 255



http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/rel_notes/8_0_1/delta/security.html#wp1105189


Make sure this entry is not set as NULL



Cheers!

Rob





"Show a little faith, there's magic in the night" - Springsteen

Rob Huffman Mon, 07/09/2012 - 11:09
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Thiago,


I would copy the url into notepad to save a copy and then try deleting

this setting so the 7942 can use the 8080 non-secure setup


Cheers!

Rob




"Show a little faith, there's magic in the night" - Springsteen

Thiago Gandara Mon, 07/09/2012 - 11:17
User Badges:

OK Rob, I'll do it, I will do outside of working hours because the phone will restart to apply, but thanks for the help.


After I communicate if this action is worked.


Thanks.

Ayodeji Okanlawon Mon, 07/09/2012 - 11:29
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

Thiago,


Yes it is a good start to delete the secure url, but dont forget to restart tftp service so that the phone can downbload a new url. 


Please rate all useful posts


"There is a wideness in God's mercy Like the wideness of the sea.There's a kindness in His justice Which is more than liberty"

Thiago Gandara Mon, 07/09/2012 - 11:33
User Badges:

Ok, thanks a lot, as soon as possible, I will perform these procedures then I notice if it worked.


Thanks.

William Bell Mon, 07/09/2012 - 12:24
User Badges:
  • Purple, 4500 points or more

This thread has me pondering a couple of things. Perhaps I should load 8.6 sooner rather than later but here is my understanding of these various URLs from a 8.5 perspective.


First, if a phone is configured for "Internal" services provisioning then that station would not be using the directory URL (or SURL) configured on the device level or Enterprise parameter level. They would use the Corporate Directory that is configured with Enterprise Subscription.


Second, I have found that you can put a non-secure URL (i.e. http://blah:8080/xmldirectory.jsp) in a Secure URL parameter field and it will still work. The only think that makes it 'secure' is the label field;-) The phone uses the field (as provided in the TFTP config file) as-is. I found this out when deploying a custom Corp Directory application for  customer.


Maybe I am slightly off topic, but I felt inspired by the thread.


-Bill

http://ucguerrilla.com

Thiago Gandara Wed, 07/11/2012 - 09:30
User Badges:

Hi voice team, i made a test, removing the Secure URL config on Enterprise Parameters, i reset the TFTP and the phones, but the model 7942G still can not access the corporate directory.


What i do now?


Thanks.

Ayodeji Okanlawon Wed, 07/11/2012 - 09:36
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

Does it still show host not found? What URL is it trying to access? Can you do this test. Delete a single 7942, re-add it and test again



Please rate all useful posts


"There is a wideness in God's mercy Like the wideness of the sea.There's a kindness in His justice Which is more than liberty"

Thiago Gandara Wed, 07/11/2012 - 10:37
User Badges:

I delete the phone 7942 and create again, but still does not access the directory.


Thanks.

Ayodeji Okanlawon Wed, 07/11/2012 - 10:40
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

Can you please send the logs on the phone. You will see them by clicking on the ip address of the phone in cucm. Please attach the logs here



Please rate all useful posts


"There is a wideness in God's mercy Like the wideness of the sea.There's a kindness in His justice Which is more than liberty"

Thiago Gandara Wed, 07/11/2012 - 10:43
User Badges:

Following the log: the language is Portuguese.

14:34:51 SEP88F07789E39E.cnf.xml.sgn(HTTP)

14:34:52 Limite esgotado p/DNS cur1sr07

14:34:53 VPN Not Configured

14:34:54 Limite esgotado p/DNS cur1sr07

14:35:00 Sem IP de servidor DNS

14:35:00 Trust List Updated

14:35:00 SEP88F07789E39E.cnf.xml.sgn(HTTP)

14:35:01 Limite esgotado p/DNS cur1sr07

14:35:02 VPN Not Configured

14:35:02 Limite esgotado p/DNS cur1sr07

The DNS its not configured on CUCM.

Ayodeji Okanlawon Wed, 07/11/2012 - 11:03
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

I was hoping to see the full logs, but since they are in portuguese, then they wont be useful. Can you put the url for directory access : http://CUCM_IP:8080/ccmcip/xmldirectory.jsp (on the phone itself) There is a place where you can set this on the phone and try again.



Please rate all useful posts


"There is a wideness in God's mercy Like the wideness of the sea.There's a kindness in His justice Which is more than liberty"

Thiago Gandara Wed, 07/11/2012 - 11:09
User Badges:

Hi, i put the URL on "Secure Directory URL" on the phone config, but still does not access the directory.

Thiago Gandara Wed, 07/11/2012 - 11:19
User Badges:

is that the problem may be in the DNS, because it has no DNS configured in CUCM, but as he is directly accessing the IP address I do not see why this error.

Ayodeji Okanlawon Wed, 07/11/2012 - 11:23
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

Thiago,


The best thing to do now is to download the phone configuration file and we can see whats in it.


tftp -i 10.1.1.1 get SEP0000DEADBEEF.cnf.xml


change 10.1.1.1 to your cucm ip address, and sep00000..to one of the 7942 phone mac address.


To enable tftp client do this

open Control Panel > Programs and Features > click Turn Windows features on or off in left side > enable  Client TFTP then click in OK


Please attach the phone config file here

Please rate all useful posts


"There is a wideness in God's mercy Like the wideness of the sea.There's a kindness in His justice Which is more than liberty"

Thiago Gandara Wed, 07/11/2012 - 11:32
User Badges:

Hi, following the phone config:


<?xml version="1.0" encoding="UTF-8"?>


true

SCCP



0

true

0


2011h

tzupdater.jar



0

SNR - Brasil


Brasil GMT -3

D/M/Y

E. South America Standard/Daylight Time

America/Sao_Paulo



10.0.0.253

Multicast





CMGroupSNR

true




cur1sr07

CallManager SNR


2000

5060

5061


2427

2428



cur1sr07






Disable

Disable

false


2000


2000


2000


5060


5060


5060

false


000000

Off

Disabled

120





2445

cur1sr07




1



true

2


SCCP42.9-3-1-1S


falsefalse10100011010050510000000011


00



1342031101-10c6d576-1b01-47ab-9942-3b2c3dfac568


Portuguese_Brazil

23

pt_BR

8.6.2.1000-1

iso-8859-1


Brazil


Brazil

5



1

0

http://CUCM_IP:8080/ccmcip/authenticate.jsp

http://CUCM_IP:8080/ccmcip/xmldirectory.jsp


http://CUCM_IP:8080/ccmcip/GetTelecasterHelpText.jsp



http://CUCM_IP:8080/ccmcip/getservicesmenu.jsp






https://CUCM_IP:8443/ccmcip/getservicesmenu.jsp

96

0

96

1

5

0

0

0

0

false

0

0

0



3804





false

1





*81

*82

*83

*84

*85


00089


0


Missed Calls

Application:Cisco/MissedCalls





Voicemail

Application:Cisco/Voicemail





Received Calls

Application:Cisco/ReceivedCalls





Placed Calls

Application:Cisco/PlacedCalls





Personal Directory

Application:Cisco/PersonalDirectory





Corporate Directory

Application:Cisco/CorporateDirectory





Ativar/Desativar Ramal

Ativar/Desativar Ramal

http://CUCM_IP:8080/emapp/EMAppServlet?device=#DEVICENAME#






Correct Answer
Ayodeji Okanlawon Wed, 07/11/2012 - 11:45
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

Thiago,


This is where the problem is. The TVS





2445

cur1sr07





The TVS entry is a hostname, which is why you're getting the host not found because your phone isn't configured for DNS or cannot resolve that name.  The fix is to change under System > Server, the hostname to an IP address there, save it, then restart th Trust Verification Service (TVS),


Please rate all useful posts


"There is a wideness in God's mercy Like the wideness of the sea.There's a kindness in His justice Which is more than liberty"

Thiago Gandara Wed, 07/11/2012 - 11:57
User Badges:

Thats rigth,it worked with the Model 7942, thank you very much.


Att.

Thiago Gandara

Ayodeji Okanlawon Wed, 07/11/2012 - 12:00
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

Thiago ! Hurray!!!!!!!!!!!!!!!!!!!!!!! I love it when we solve problems like this...We never give up! Excellent News! How do you say Vamos! in portuguese?



Please rate all useful posts


"There is a wideness in God's mercy Like the wideness of the sea.There's a kindness in His justice Which is more than liberty"

Thiago Gandara Wed, 07/11/2012 - 12:03
User Badges:

Yeah, never, ever give up, we say: É ISSO AÍ..


Thankssss a lot...


Best regards,


Thiago

William Bell Wed, 07/11/2012 - 13:05
User Badges:
  • Purple, 4500 points or more

Outstanding.  Good work aokanlawan (+5). This thread is a good example of why CSC is the best tech support forum out there. Just sayin'...


Regards,


Bill

http://ucguerrilla.com

Ayodeji Okanlawon Wed, 07/11/2012 - 13:11
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

William, I concur. No forum, no group like CSC. We are make it the quintessence of excellence. What a huge honour to be part of it.


Please rate all useful posts


"There is a wideness in God's mercy Like the wideness of the sea.There's a kindness in His justice Which is more than liberty"

fwalstrom Mon, 04/10/2017 - 23:38
User Badges:

I know this is an old post, but I have the same issue. But it is with a 7821 and my CM is 9.1.2, I downloaded the cnf.xml and see that TVS is using an IP address. The phone isn't configured with DNS. I'm a little stumped and out of ideas. I've been reading the forums, and come across your solutions, all extremely helpful. Any ideas as to why I get a "host not found" when trying to access the corporate directory? I tried resetting the phone, but no joy.

Ayodeji Okanlawon Tue, 04/11/2017 - 01:10
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

I suggest you open a new thread and we can have a look for you

Alex Farah Tue, 01/07/2014 - 21:50
User Badges:

Dear All

   I have the same issue somehow, the problem is I have changed all the CUCM names to its IP address but the error I get is select service.


Any idea?

Actions

This Discussion