show ip router summary this command explain !

Answered Question
Jul 10th, 2012

Hello all ~

I am study the ccnp but I don't understand this command "show ip router summary"

who can explain ?

how can I compare this command and config ?

R2#sh ip route summary

IP routing table name is Default-IP-Routing-Table(0)

Route Source    Networks    Subnets     Overhead    Memory (bytes)

connected       0           4           256         608

static          0           0           0           0

internal        2                                   2344

Total           2           4           256         2952

R2#

interface Loopback1

ip address 192.168.200.1 255.255.255.252

!

interface Loopback5

ip address 192.168.200.5 255.255.255.252

!        

interface Loopback9

ip address 192.168.200.9 255.255.255.252

!

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0

ip address 172.16.1.1 255.255.255.0

I have this problem too.
0 votes
Correct Answer by Sandeep Choudhary about 1 year 9 months ago

Hi Cash,


show ip route summary

R2#sh ip route summary

IP routing table name is Default-IP-Routing-Table(0)

Route Source    Networks    Subnets     Overhead    Memory (bytes)

connected                0                     4                256               608

static                         0                      0                  0                  0

internal                     2                                                            2344

Total                          2                      4               256              2952

  

Table 60     show ip route summary Field Descriptions

Field

Description

Route Source

Routing protocol name, or the connected, static, or internal keyword. "Internal" indicates those routes that are in the routing table that are not owned by any routing protocol.

Networks

Number of prefixes that are present in the routing table for each route source.

Subnets

Number of subnets that are present in the routing table for each route source, including host routes.

Overhead

Any additional memory involved in allocating the routes for the particular route source other than the memory specified in the Memory field.

Memory

Number of bytes allocated to maintain all the routes for the particular route source.

Regards
Please rate if it helps.



  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 4.5 (3 ratings)
Correct Answer
Sandeep Choudhary Tue, 07/10/2012 - 13:40

Hi Cash,


show ip route summary

R2#sh ip route summary

IP routing table name is Default-IP-Routing-Table(0)

Route Source    Networks    Subnets     Overhead    Memory (bytes)

connected                0                     4                256               608

static                         0                      0                  0                  0

internal                     2                                                            2344

Total                          2                      4               256              2952

  

Table 60     show ip route summary Field Descriptions

Field

Description

Route Source

Routing protocol name, or the connected, static, or internal keyword. "Internal" indicates those routes that are in the routing table that are not owned by any routing protocol.

Networks

Number of prefixes that are present in the routing table for each route source.

Subnets

Number of subnets that are present in the routing table for each route source, including host routes.

Overhead

Any additional memory involved in allocating the routes for the particular route source other than the memory specified in the Memory field.

Memory

Number of bytes allocated to maintain all the routes for the particular route source.

Regards
Please rate if it helps.



ganeshh.iyer Wed, 07/11/2012 - 06:26

Hello ,

As stated by the above post ip route summary gives you the current state of the routing table, like where excatly the routes originated and how many prefix are been used by routig protocol with number of bytes used by routes.

This command is mainly used to check the state of the routing table.

Hope to help !!

Ganesh

Actions

Login or Register to take actions

This Discussion

Posted July 10, 2012 at 8:32 AM
Stats:
Replies:2 Avg. Rating:4.5
Views:3914 Votes:0
Shares:0

Related Content

Discussions Leaderboard

Rank Username Points
1 2,069
2 1,736
3 1,675
4 1,624
5 1,529