VTP between ROUTER and SWITCH does not work

Answered Question
Jul 12th, 2012

Hello,

Sorry for my newbie question, but to prepare myself for some CCNA courses in October I made a small setup to try a router on a stick ,this work as expected but ....

In the CISCO 1841 (router) , you can setup VLANS and VPT as SERVER and in my CISCO 2950 (switch) as client:

I expected that if both are on the same domain with the same password and everithing that it will work , I mean by work , when I setup the VLAN DATABASE in the ROUTER that he will send it to the switch , but unfortunatly this does not work.

Just for the fun I created in a other switch a VLAN DATABASE (has a SERVER) and this was dumped directly in the CISCO 2950 , so I know that the CISCO 2950 is workin and able to receive VPT.

Any idea why it does not work from the router ?

It is not urgent , it is just for my personal knowledge

Best Regards,

Didier

Router#sh run

Building configuration...

Current configuration : 2303 bytes

!

version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot system flash c1841-advsecurityk9-mz.151-3.T2.bin

boot-end-marker

!

!

!

no aaa new-model

!

dot11 syslog

ip source-route

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.1.1

ip dhcp excluded-address 192.168.10.1

ip dhcp excluded-address 192.168.20.1

ip dhcp excluded-address 192.168.30.1

ip dhcp excluded-address 192.168.40.1

!

ip dhcp pool VLAN1

   import all

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.1

!

ip dhcp pool VLAN10

   import all

   network 192.168.10.0 255.255.255.0

   default-router 192.168.10.1

!

ip dhcp pool VLAN20

   import all

   network 192.168.20.0 255.255.255.0

   default-router 192.168.20.1

!

ip dhcp pool VLAN30

   import all

   network 192.168.30.0 255.255.255.0

   default-router 192.168.30.1

!

ip dhcp pool VLAN40

   import all

   network 192.168.40.0 255.255.255.0

   default-router 192.168.40.1

!

!

!

ip cef

!

multilink bundle-name authenticated

!

crypto pki token default removal timeout 0

!

!

!

!

license udi pid CISCO1841 sn FCZ1217905C

archive

log config

  hidekeys

!

redundancy

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address 192.168.1.1 255.255.255.0

!

interface FastEthernet0/0.10

encapsulation dot1Q 10

ip address 192.168.10.1 255.255.255.0

!

interface FastEthernet0/0.20

encapsulation dot1Q 20

ip address 192.168.20.1 255.255.255.0

!

interface FastEthernet0/0.30

encapsulation dot1Q 30

ip address 192.168.30.1 255.255.255.0

!

interface FastEthernet0/0.40

encapsulation dot1Q 40

ip address 192.168.40.1 255.255.255.0

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0

no ip address

shutdown

clock rate 2000000

!

interface Serial0/0/1

no ip address

shutdown

clock rate 2000000

!

interface Serial0/1/0

no ip address

shutdown

clock rate 2000000

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

!

logging esm config

!

!

!

!

!

control-plane

!

!

!

line con 0

speed 115200

line aux 0

line vty 0 4

login

transport input all

!

scheduler allocate 20000 1000

end

Router#

Router#

Router#

Router#

Switch#sh run

Building configuration...

Current configuration : 1152 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Switch

!

!

ip subnet-zero

!

no ip domain-lookup

ip host R1 192.168.1.1

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

!

!

interface FastEthernet0/1

switchport access vlan 10

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/2

switchport access vlan 20

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/3

switchport access vlan 30

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

switchport mode trunk

!

interface FastEthernet0/12

switchport mode trunk

!

interface Vlan1

ip address 192.168.1.254 255.255.255.0

no ip route-cache

!

ip http server

!

line con 0

password cisco

login

speed 115200

line vty 0 4

privilege level 15

password cisco

login

line vty 5 15

login

!

!

end

Switch#

Switch#

Switch#

I have this problem too.
0 votes
Correct Answer by Peter Paluch about 2 years 10 months ago

Hello Didier,

While the 1841 router supports VTP commands, they are effective only if you install a switching module (such as HWIC-4ESW) into the router's WIC slots, and they apply only to switchports on this switching module. Routers do not speak VTP on their routed onboard ports - because for VLANs on these routed ports, you create subinterfaces directly. That is why the VTP does not seem to work between your router and the 2950 switch.

Best regards,

Peter

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Correct Answer
Peter Paluch Thu, 07/12/2012 - 06:35

Hello Didier,

While the 1841 router supports VTP commands, they are effective only if you install a switching module (such as HWIC-4ESW) into the router's WIC slots, and they apply only to switchports on this switching module. Routers do not speak VTP on their routed onboard ports - because for VLANs on these routed ports, you create subinterfaces directly. That is why the VTP does not seem to work between your router and the 2950 switch.

Best regards,

Peter

Didier1966 Thu, 07/12/2012 - 11:58

Hello Peter,

Thank You for your prompt reply.

How can I learn this kind of tricks , when you use VPT , CISCO or the IOS do not tell you this , maybe in a next release we will have a message

Thank You Again.

Best Regards,

Didier

Peter Paluch Thu, 07/12/2012 - 12:51

Hello Didier,

Thank you! About learning these tricks... well, it's simply practice. I've been working with Cisco devices since 2001. Don't worry, you will learn these things soon enough, and in the meantime, these forums are exactly what should save you the hard try-and-fail way of doing things. Feel always welcome to come and discuss any topic you might have!

Best regards,

Peter

Actions

Login or Register to take actions

This Discussion

Posted July 12, 2012 at 6:31 AM
Stats:
Replies:3 Overall Rating:5
Views:4452 Votes:0
Shares:0

Related Content