×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

ASDM launching

Unanswered Question
Jul 12th, 2012
User Badges:

Hi All,


I have a ASA 5520 with ASDM641. After I updated my JAVA to v7 update 5 , Build 1.7.0; I cannot launch the ASDM and get this Error: Unable to launch the application.


I have uninstalled and reinstalled the ASDM to no avail.


Any help is appreciated.



Kind regards,


Del

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Dinkar Sharma Thu, 07/12/2012 - 14:45
User Badges:
  • Cisco Employee,

Hi,


We have a bug opened for the same issue.


CSCts17526.


Workaround:- uninsatll the launcher and when you connect click on "RUN ASDM". use internet explorer or mozilla. It won't work with chrome.


hope this helps.


Regards,


Dinkar

Delfino Tiongco Fri, 07/13/2012 - 07:40
User Badges:

Hi Dinkar,


Thanks for the reply.


I used to "RUN ASDM" and it worked before I upgraded to Java ver 1.7.  I opened the details of the error and on the Launch File tab; I see that the code is looking for "j2se version = "1.6+".  Would I be correct that the ASDM code for 6.4.(1) is expecting a 1.6 version?



Kind regards,


Del

Attachment: 
Luis Silva Benavides Fri, 07/13/2012 - 09:52
User Badges:
  • Cisco Employee,

Hi Delfino,


Try to download the lastest ASDM-demo and install it on your PC. This will update the launcher files on your PC (it won't change the image install on your ASA); I know it sounds kind of crazy but I have seen it solving some issues.


Luis Silva

Delfino Tiongco Mon, 07/16/2012 - 08:04
User Badges:

Hi Luis,


I installed the ASDM-Demo 649 and still getting the sare error before.



Kind regards,


del

Nikita Bazan Mon, 02/18/2013 - 11:56
User Badges:

Hi.


I'm think you need to give write permissions for folder c:\data\javaws_cache\user\.


I'm fixed it this way.


Regards

Ramraj Sivagnan... Sat, 07/14/2012 - 23:04
User Badges:
  • Silver, 250 points or more

Hi Bro

I'm assuming you've the correct http commands set in your Cisco ASA Firewall and you can PING the interface from your workstation.


I've encountered similar issues as well. What I did was I went to www.java.com downloaded the latest java version, cleared all cache, cookies etc from my Microsoft IE, and all worked fine. I knew it was a problem with my workstation, because when I used my colleague's workstation, there were no problems.


If all these don't help, please run the debug http 255 command (make sure logging is turned on in the FW) and capture commands, and paste it here.

Delfino Tiongco Mon, 07/16/2012 - 08:47
User Badges:

Hi Ramrai,


I use CCCleaner to clear all my cache, cookies, histories, and etc. I currently using Java ver 7.  I will try installing the ASDM to another box to see if it is my station causing the issue.


After running the debug http 255 command, what command I need to use to capture the 711001 syslog traffic?


Thanks,


Del

Ramraj Sivagnan... Mon, 07/16/2012 - 08:54
User Badges:
  • Silver, 250 points or more

Hi Del

Yes, try accessing the Cisco ASA Firewall via ASDM from another workstation? If that works fine, that means there could be some settings issue in your browser but if that still doesn't work then, enable the debug http 255 command and paste those logs here.


Furthermore, you could also run packet captures in the Cisco ASA Firewall to collect more logs concerning this matter, as shown below,


access-list abc remark ### 10.10.10.30 is your workstation IP Address ###

access-list abc permit ip any host 10.10.10.30

access-list abc permit ip host 10.10.10.30 any


capture abc access-list abc in interface inside

note: "inside" here means the nameif of the interface whereby http has been enabled.


* run the ASDM on more time from your PC...........................


show capture abc <--------------------- this is to collect more logs, and paste them here

Delfino Tiongco Fri, 07/20/2012 - 09:02
User Badges:

Hi All,


I partially solved my issue with ASDM. 


I logged in to another box with a Java ver 6 and was able to get in.  This is surely a config issue on my desktop. In the process, I ended up re-installing my Windows 7 since I had issues with it before.


When  I connect to ASA via HTTPS; I get the regular prompt - whether I want to run and install, run ASDM, or start the Wizard. I CAN only run the ASDM GUI via the run ASDM and it would even accept the Java ver 7 I have. The other options will not work with my set up.


At any rate, I am happy with what I got since I can connect and run the ASDM GUI. I mostly use CLI but the GUI can be handy at times.


Thanks to all that replied to me.

Ramraj Sivagnan... Fri, 07/20/2012 - 09:37
User Badges:
  • Silver, 250 points or more

Hi Bro

I'm glad all is good. I've seen this problem far too many times to know that this is a O/S related issue.




P/S: If you do find my above comments helpful, please do rate them nicely :-)

jocamare Mon, 02/18/2013 - 14:41
User Badges:
  • Silver, 250 points or more

I'm sure you already tried to install the latest ASDM version, right?

Actions

This Discussion

Related Content