how to apply policy map to vlan interface ?

Answered Question
Jul 13th, 2012

hi ,

i have a router that IS A GATEWAY for internet ,  and another router which is Bras which is used to connect to Dslam

my request is , i want to gurantee didicted cir for specific vlan which is vlan 10

im using subinterface connect to router gateway which is the gateway of my vlan 10.

the problem is , i cant use policymap on subinterface !!!!!!!! it is not allowed to use it, im using router ios 7206 .

so i began to think in another solution which is applying the polivy map on the interface Gi0/1 as u see from my gigure below ,

but the problem is , the cpu  takse high and rech up to 90 % , it consume 15 % after adding the polivy map >

i want a solution ,

could i use policy on the swithch ??? and consume the cpu on the other routers ???

is there any other optinal soultion to use QOS ?????

                                                            Bras router

                                                                   |   

                                                                   |

                                                                   |

                                                                   |

                    switch vlan 10  ===========routerGi0/1=============>internet

regards

I have this problem too.
0 votes
Correct Answer by soroushm about 1 year 9 months ago

I believe you could find this link useful:

http://www.cisco.com/en/US/tech/tk543/tk545/technologies_tech_note09186a0080114326.shtml

Hope it Helps,

Soroush.

Correct Answer by soroushm about 1 year 9 months ago

have a look at this link:

http://www.cisco.com/en/US/docs/ios/12_2/qos/command/reference/qrfcmd9.html#wp1077189

rate limitting as its name implies, limits the bandwidth at a certain rate, with a burst. it doesnt guarantee a minimum bandwidth, nor does the shape average. but bandwidth command does it.

if you want a maximum of 1mbps extra to be available, add this command under policy map along with the bandwidth command:

police 16000000 exceed-action drop

fair-queue command enables qos Weighted Fair Queue, allowing other traffic flow to fairly share the bandwidth available. sorry u have to set it under the class-default, it is optional but good to be there.

HTH,


Soroush.

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (4 ratings)
soroushm Fri, 07/13/2012 - 07:06

hi Ahmed

to reserve a minimum bandwidth for accessing internet, u need to do it on the exit point here the router G0/1 is the right choice. applying policy-map to other interfaces and vlan int, wouldnt give u the desired result.

there might be a problem with QoS setting u done, could u post ur QoS settings?

Hope it Helps,

Soroush.

Ahmed Alzaeem Fri, 07/13/2012 - 07:35

hi ,

my config is not complex , here is it

=====================================

Extended IP access list sawa

    10 permit ip xxx.xx.66.128 0.0.0.127 any (387727 matches)

policy-map sawa

class sawa

    bandwidth 15000

    shape average 15000000

class class-default

interface gi0/1

service policy output sawa

=======================================

as u see , i want reserve bw for my subnet to be as a cir ,

but u didnt answered me  , why it will not work on another placce like switch or the Bras router?????

regards

soroushm Fri, 07/13/2012 - 08:04

first of all, i dont see any Class-map there, you have to create a class.

ip access-list extended (sawa)

class-map sawa

match access-list sawa

policy-map sawa

class sawa

  shape average 15000000

interface gi0/1

service policy out sawa

do you want to limit ur vlan 10 to 15Mbps or you want to reserve a bandwith for the vlan too?

whenever you want to limit or guarantee a certain amount of bandwith for a group of users, u have to do it on the exit point or the bottle neck. because the closer to the source (users) it is in ur own LAN and usually there is no bandwidth concerns. besides, there are risks that other traffic flows saturate the link to the internet if u ever want to reserve bw.

if u just want to limit the amount of bandwith ur users can use, then u can apply it on the vlan interface, if ur switch is capable of it.

HTH,


Soroush.

Ahmed Alzaeem Fri, 07/13/2012 - 08:17

sorry , i forgot to post it :

here is my class map

===========================

Class Map match-all sawa (id 10)

   Match access-group name sawa

=============================

i want to reserve at minimum bw for 15 m to be as cir , and and to give the users more if possible , but the most important is to gurantee cir 15 m

im using switch catalysit 2960g  ,

i didnt understand ur menaing with bottle neck ? do u mean to apply the policy on the last point Gi0/1 , or the closer point to the vlan users ???

regards

soroushm Fri, 07/13/2012 - 09:18

Ahmed,

you wouldnt be able to set that kind of QoS on a C2960. if you want to reserve a bandwidth and give more if available, just keep the bandwidth command in ur policy-map, remove the shape average. this way you reserve a minimum bw for that class and users will use extra bandwidth if available. and apply it to Gi0/1. also add fair-queue command under the class-default policy-map.

by bottleneck, i meant the point that has lesser bandwidth so u need to reserve ur minimum there. in ur case, it is the connection to the internet gi0/1.

EDITED.

Hope it Helps,

Soroush.

Ahmed Alzaeem Fri, 07/13/2012 - 09:25

hii , thanks soo much for ur help

i want to correct something , i want users  didicated 15 m , but in the same time if avaiblabe bw , just give them more up to 1 mega  only .

1stly , wts the benifie of shape avergae comand ?? which i will remove ?

2nd thing

on the subinterface which the gateway of my subnet i was typing a rate limit comamnd , do i need this commands ??

im using policy map , do i need this commadns to be on my subinterface ???

=================================

interface GigabitEthernet0/2.13

description OFFICE-VLAN

encapsulation dot1Q 13

ip address xx.xx.79.1 255.255.255.224

rate-limit input 15000000 2812500 5625000 conform-action transmit exceed-action drop

rate-limit output 15000000 2812500 5625000 conform-action transmit exceed-action drop

3rd thing

wts the benifit of using   fair-queue    command ???

im really appreciating ur help

with my best regards

Correct Answer
soroushm Fri, 07/13/2012 - 09:38

have a look at this link:

http://www.cisco.com/en/US/docs/ios/12_2/qos/command/reference/qrfcmd9.html#wp1077189

rate limitting as its name implies, limits the bandwidth at a certain rate, with a burst. it doesnt guarantee a minimum bandwidth, nor does the shape average. but bandwidth command does it.

if you want a maximum of 1mbps extra to be available, add this command under policy map along with the bandwidth command:

police 16000000 exceed-action drop

fair-queue command enables qos Weighted Fair Queue, allowing other traffic flow to fairly share the bandwidth available. sorry u have to set it under the class-default, it is optional but good to be there.

HTH,


Soroush.

Ahmed Alzaeem Fri, 07/13/2012 - 11:08

hi ,

thansk soo much for ur info ,

but

could i apply policymap to subinerface ??? or it is limited  to specific types of    QOS ???

i have two another questions :

1- assume i applied policymao interface gi0/1 as out ,

do i need to apply this policy in the resurn path ??? i mean that i controlled the traffic when it leaved gi0/1 but i didnt control the traffic when i come into interface gi0/1 ??? does applying it out , enoguh???

another thing , how to control upload & dowload  , i mean by bandwith command i controlled the bandwith , but how about if i want to control the upload and download , wt do i need ??

with my best regards

Ahmed Alzaeem Tue, 07/24/2012 - 04:10

hi ,

i tried to type the command

police 16000000 exceed-action drop

under the policymap command ???

i tried it on two ioses one 7200 and the other 7600 but cnt type it !!!!!

did u mean another thing ???

regards

Ahmed Alzaeem Tue, 07/24/2012 - 04:16

here is  output after tryig to type the command

Gateway2(config-pmap-c)#police 16000 ?

  <500-512000000>  Burst bytes

  bc               Conform burst

  conform-action   action when rate is less than conform burst

  pir              Peak Information Rate

 

as u see, there is no exceed-action   option

is there any method to limit the total bw to 16 mega ???

regards

Actions

Login or Register to take actions

This Discussion

Posted July 13, 2012 at 6:22 AM
Stats:
Replies:12 Avg. Rating:5
Views:2050 Votes:0
Shares:0

Related Content

Discussions Leaderboard

Rank Username Points
1 15,007
2 8,150
3 7,725
4 7,083
5 6,742
Rank Username Points
165
82
70
69
55