Cisco Sf300 ,QOS , Access ports

Answered Question
Jul 13th, 2012

SWITCH 1......I have a (2) Cisco SF 300, I have created a voice VLAN 100 and have the default data VLAN 1. I have my IP phones on VLAN 100 and this is tagged traffic.  My VoIP PBX server is on port G1 is set to an  access port assigned to VLAN 100 only untagged and a Cisco SPA8000 to Port 8 untagged and set as access port only also to VLAN 100.  Port 7 is for the data  DHCP server and that is an  access port only to VLAN 1.

SWITCH 2.....Switch 2 are all trunk ports VLAN 1 untagged VLAN 100 tagged

Both switches are in layer (3) mode

IPaddress VLAN 100 192.168.100_

IP address VLAN 1 192.168.16._

1. With this set up I can run (2) DHCP servers and there will be no conficts ?

2.When I plug the second switch into the first switch do I have to configer anything or just go from my G2 switch (1) to G2 switch (2) ?

3.I didnt use the CDP or LLDP I manually set my Voice Vlan 100 how do I configer QOS on it ?

4.Any suggestions on my set up does it look good ?

Thanks for any help in advanced

I have this problem too.
0 votes
Correct Answer by Davidwagman1 about 2 years 10 months ago

Hi Greg,

Yes, you can do this in the web gui, under Quality of Service.

First, under General, QoS Properties change QoS mode to Advanced.

Then go to QoS Advanced Mode drop down. Here, first go to Policy Table and create a policy:

Second, go to Class Mapping and add the following:

Then, go to Policy Class Mapping:

Then go to Policy binding and associate the policy to the applicable ports, and click apply.

Don't forget to the configuration to the switch, or it will be lost after a reboot.

Does your PBX do DHCP for the phones or does your DHCP server do both? Without being in layer 3, you'll have to make sure the DHCP server can communicate on the voice vlan, as there is no inter-vlan routing. I hope thats responsive to your quesiton.

Best,

David

Please remember to rate helpful posts.

Correct Answer by Davidwagman1 about 2 years 10 months ago

Hi Tom,

Very good QOS write up. +5 

Just one thing to note, I think you meant dscp  

class VoIP_SIP_Class

set dhcp 24             ****Sets all SIP traffic to DSCP of 24*****

exit

class VoIP_RTP_Class

set dhcp 46            ****Sets all RTP traffic to DSCP of 46*****

exit

Best,

David

Correct Answer by Tom Watts about 2 years 10 months ago

Okay, thank you.

If you do not use any kind of auto voice vlan, LLDP-MED, telephony OUI or auto voice vlan, your only option is advance QoS.

Any port that connections telephones + computer will need to be defined data vlan untag, voice vlan tag. When implementing the DHCP servers, they of course will be access port and respective vlan as untagged. The ports connecting the switches will be 1u, 100t.

Here is an example;

This will reclassify the traffic as it enters the switch.

enable

config t

qos advanced

(answer yes)

ip access-list extended VoIP_SIP_List ****This is the rule looking for SIP traffic******

permit udp any any any 5060-5080

permit tcp any any any 5060-5080

exit

ip access-list extended VoIP_RTP_List

permit  udp any any 16384-32767  *****This is the rule looking for RTP traffic to PBX *****

exit

ip access-list extended General_Traffic_List   ****This rule matches all other traffic*****

permit ip any any

exit

class-map VoIP_SIP_Class

match access-group VoIP_SIP_List  ****Seperates SIP traffic****

exit

class-map VoIP_RTP_Class

match access-group VoIP_RTP_List  ****Seperates RTP traffic****

exit

class-map General_Traffic_Class

match access-group General_Traffic_List  ****Seperates all other traffic*****

exit

policy-map QoS_Map      ****Binds all traffic selection into one rule*****

class VoIP_SIP_Class

set dscp 24             ****Sets all SIP traffic to DSCP of 24*****

exit

class VoIP_RTP_Class

set dscp 46            ****Sets all RTP traffic to DSCP of 46*****

exit

class General_Traffic_Class       ****Allows all other traffic but dosn't tag*****

exit

interface range gi1-28

service-policy input QoS_Map     *****Binds Policy to ports Modify to the ports you need…*********

exit

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
Tom Watts Fri, 07/13/2012 - 19:58

Hello Greg,

1.) You may set up 2 DHCP server, which will be contained within the VLAN they are connecting

2.)This depends on how you're implementing everything, I will elaborate more below

3.) You can set up a port base QoS

If you're connecting a computer behind the telephones, the ports must be configured 1u, 100t. If you do not plan to do so, your original idea is fine.  The switch (2), does thishave any voice traffic at all? If the voice traffic is staying local to switch (1) then the 100t is not needed for switch (2)

Gtelcom1974 Fri, 07/13/2012 - 20:25

Yes there will be PC's attached to the phone's, and yes switch (2) will have ip phones on it

Thanks again

Correct Answer
Tom Watts Fri, 07/13/2012 - 20:36

Okay, thank you.

If you do not use any kind of auto voice vlan, LLDP-MED, telephony OUI or auto voice vlan, your only option is advance QoS.

Any port that connections telephones + computer will need to be defined data vlan untag, voice vlan tag. When implementing the DHCP servers, they of course will be access port and respective vlan as untagged. The ports connecting the switches will be 1u, 100t.

Here is an example;

This will reclassify the traffic as it enters the switch.

enable

config t

qos advanced

(answer yes)

ip access-list extended VoIP_SIP_List ****This is the rule looking for SIP traffic******

permit udp any any any 5060-5080

permit tcp any any any 5060-5080

exit

ip access-list extended VoIP_RTP_List

permit  udp any any 16384-32767  *****This is the rule looking for RTP traffic to PBX *****

exit

ip access-list extended General_Traffic_List   ****This rule matches all other traffic*****

permit ip any any

exit

class-map VoIP_SIP_Class

match access-group VoIP_SIP_List  ****Seperates SIP traffic****

exit

class-map VoIP_RTP_Class

match access-group VoIP_RTP_List  ****Seperates RTP traffic****

exit

class-map General_Traffic_Class

match access-group General_Traffic_List  ****Seperates all other traffic*****

exit

policy-map QoS_Map      ****Binds all traffic selection into one rule*****

class VoIP_SIP_Class

set dscp 24             ****Sets all SIP traffic to DSCP of 24*****

exit

class VoIP_RTP_Class

set dscp 46            ****Sets all RTP traffic to DSCP of 46*****

exit

class General_Traffic_Class       ****Allows all other traffic but dosn't tag*****

exit

interface range gi1-28

service-policy input QoS_Map     *****Binds Policy to ports Modify to the ports you need…*********

exit

Correct Answer
Davidwagman1 Sat, 07/14/2012 - 05:12

Hi Tom,

Very good QOS write up. +5 

Just one thing to note, I think you meant dscp  

class VoIP_SIP_Class

set dhcp 24             ****Sets all SIP traffic to DSCP of 24*****

exit

class VoIP_RTP_Class

set dhcp 46            ****Sets all RTP traffic to DSCP of 46*****

exit

Best,

David

Gtelcom1974 Sat, 07/14/2012 - 07:53

Thomas and David thank you very much for taking the time to look at my question and answer it. I will follow the instructions above. I'am new to programming I guess called command prompt way and usually use the web interface. Can this also be done threw the web internface ?. Not to push my luck if so could you post the example. Another question with my set up could I keep my switch in layer 2 mode or would that cause me to rely on (1) DHCP server because there would only be one IP address assigned to the Cisco switch.

Thank you again in advance

Correct Answer
Davidwagman1 Sat, 07/14/2012 - 08:04

Hi Greg,

Yes, you can do this in the web gui, under Quality of Service.

First, under General, QoS Properties change QoS mode to Advanced.

Then go to QoS Advanced Mode drop down. Here, first go to Policy Table and create a policy:

Second, go to Class Mapping and add the following:

Then, go to Policy Class Mapping:

Then go to Policy binding and associate the policy to the applicable ports, and click apply.

Don't forget to the configuration to the switch, or it will be lost after a reboot.

Does your PBX do DHCP for the phones or does your DHCP server do both? Without being in layer 3, you'll have to make sure the DHCP server can communicate on the voice vlan, as there is no inter-vlan routing. I hope thats responsive to your quesiton.

Best,

David

Please remember to rate helpful posts.

Actions

Login or Register to take actions

This Discussion

Posted July 13, 2012 at 7:41 PM
Stats:
Replies:6 Overall Rating:5
Views:4227 Votes:0
Shares:0
Tags: qos, access, ports, sf300
+

Related Content