9971 SIP phone re-registering every 10 mins

Unanswered Question
Jul 16th, 2012

On a UC560, is it normal for a 9971 to re-register itself to the UC every 10 mins?

Without fail it happens. Whilst the phone is re-registering it says "Not Registered" and then reconnects.

Only noticed this happening after I configured a SIP trunk. So im not sure if its a coincidence. All configured with CCA:

voice register global

mode cme

source-address 192.168.100.254 port 5060

max-dn 56

max-pool 14

load 9971 sip9971.9-2-2

load 9951 sip9951.9-2-2

load 8961 sip8961.9-2-2

authenticate register

timezone 43

time-format 24

hold-alert

voicemail 399

tftp-path flash:

create profile sync 0001402427654588

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 4.5 (2 ratings)
bjames@snetworks.com Thu, 07/19/2012 - 08:24

It's not normal, ours are fine after they registered the first time. Do all you SCCP phones work fine?

Can you take the SIP trunk off to see if that fixes them?

Bob James

ai.solutions Fri, 07/20/2012 - 03:33

No issues with the skinny phones. I cant really take the SIP trunk out...

I cant find anywhere a setting that would cause the re-registration every 10 mins.

bjames@snetworks.com Mon, 07/23/2012 - 07:10

Do they register and get their parameters, then re-register? Or do they just keep trying and never regster?

Anything in debug showing any info?

Bob James

ai.solutions Mon, 07/23/2012 - 08:01

Yeah the phone registers fine. Then after 10 minutes, it loses registration and then re-registers.

The phone log shows:

21:43:37 CUCM closed TCP connection

21:43:38 No DNS Server IP

21:43:38 Updating Trust List

21:43:38 No trust List Installed

Then the normal registration log messages.

Here's the debug for the register:

http://inetpro.org/pastebin/7f2a60df83444d25a4f325a0254f89cd

bjames@snetworks.com Mon, 07/23/2012 - 09:12

OK this configuration confuses me;is your voice vlan 192.168.100.0? and your PC vlan 192.168.169.0?

I'm no expert but I would try changing your registar and sip-server in sip-ua to the IP v4 addresses:

registrar ipv4:x.x.x.x expires 3600

sip-server ipv4:x.x.x.x:5060  

also add

connection-reuse

And under voice server voip

sip

add

outbound-proxy ipv4:x.x.x.x - pointing to your ITSP

I'm not sure if these will help, like I said this config is a little confusing to me so take backups and try after hours

Bob James

      

Couple more things;

on you dial-peer voice is the internal session target set to ipv4:10.1.10.1?

and your outgoing set to your ITSP?

This route:

ip route 10.1.10.1 255.255.255.255 Vlan90

should be:

ip route 10.1.10.1 255.255.255.255 Integrated-Service-Engine0/0

ai.solutions Fri, 08/03/2012 - 20:08

Hi, very sorry for the late response.

Yes... VLAN 100 (voice) is 192.168.100.0/24

VLAN 1 (data) is 192.168.169.0/24

I have removed the SIP trunk configuration through CCA. However it appears that the re-registration issue still continues.

There is no registrar ipv4, sip-server ipv4 commands configured now that the SIP trunk is removed.

Regarding the route command... that was configured by CCA, and achieves the same thing.

bjames@snetworks.com Thu, 08/09/2012 - 08:34

Are the phones plugged directly into the UC ports or something else?

I would try downgrading the code for the 9971's one version to see if it's a code issue.

Sorry i can't be more help

Bob James

David Trad Thu, 08/09/2012 - 19:00

Hi ai.Solutions,

I am not familiar with these phones as I haven't used one of them yet, but what on earth is this relating too?

"307362: Jul 23 13:53:39.824: VOICE_REG_POOL: No entry for (asterisk) found in contact table"

Was this phone registered to an Asterisk system first before the UC? Or do these phones have an Asterisk forked kernel???? Mystery surrounds me on this one LOL

Also when you added the SIP trunk did it change the SIP registration timers? Maybe this could cause the drop-outs as it sounds like the registration timers may be kicking in and causing the phones to re-register for no reason...

Just a thought.

Cheers,


David Trad.

fabio_henrique Wed, 08/15/2012 - 15:42

Are you using the phones 9971 with wired or wireless connection? I had this problem using wireless connection and resolves fixing a static channel for 802.11a (in my case) on Cisco AP.

Another suggestion is for yoou use new version of SIP phones. For 9971, Im using cmterm-9971.9-2-2SR1-9.

I tried to use the version sip9971.9-3-1-33 but I don´t know why the phones can´t download it from CME.

oliverpowell Mon, 09/17/2012 - 02:08

Hi Fabio,

We have a similar issue with our 9971s over the wireless network.

All the phones are connected via wireless and the customer cann't retain a call for any longer than 10-15 seconds before it re-connects/un-registers.

CCME version 8.5 with SIP9971.9-1-1SR1

I've seen on other posts that this maybe down to CAC on the WLC, but thinking that your solution above may be the answer.

I'm no wireless engineer so was just hoping you could ellaborate on fixing the channel on the AP, or WLC?

Cheers

Oli

fabio_henrique Wed, 09/19/2012 - 12:11

Are you configuring QoS on your WLC for APs?

My APs are standalone and I have this configuration of Qos:

class-map match-all SIP

match ip dscp cs3

class-map match-all Video

match ip dscp af41

class-map match-all RTP

match ip dscp ef

!

!

policy-map Voice

class RTP

  set cos 6

class Video

  set cos 5

class SIP

  set cos 4

interface Dot11Radio1

service-policy input Voice

service-policy output Voice

I have using the auto qos cisco-phone on my switch too.

bkwon Wed, 11/14/2012 - 19:11

basically, this is caused because  TCP againg timer (5 min default) is less than registrtion refresh timer, and the TCP session closed. please try 2 options

1. increase aging timer

     sip-ua

     timer connection againg 70  -> 1 + hour

or

2. decrease regisrtation refresh timer

voice service voip

sip

registrar server expires max 300 min 150  -> 5 minute

please update the any result.

trustedit Mon, 11/19/2012 - 11:20

Hi,

Thanks for the reply, we have tried your second fix and whilst it has stopped them rebooting some of them do seem to drop their incoming extension.

E.g the phones can dial out but will not accept incoming calls.

Any ideas on this?

Best regards,

Tim

Sent from Cisco Technical Support iPad App

bkwon Mon, 11/19/2012 - 11:47

seems like, you hitting another issue,

i believe that you saying that call droped, SCCP phone to 9971, and you have SIP trunk configured which use outbound proxy, if that is your case, please try this.

voice register global

no outbound-proxy

if this is not your case, then what is detail of call flow and please collect debug when it failed

debug ccsip mess

trustedit Mon, 11/19/2012 - 12:00

Hi Bongsu,

All the 9971 phones register ok and work fine but after a while some will not take incoming "internal" calls from other extensions.

If we delete the phone and re-add it in CCA it then works but may stop receiving after some time. Simply rebooting the phone does not help.

All the phones are 9971 or 8961 and of course all running SIP, we do not have any SCCP phones on at the moment. We do have an outbound sip trunk and PSTN lines.

Sent from Cisco Technical Support iPad App

trustedit Mon, 11/19/2012 - 12:48

Also I have just checked and we already have "no outbound-proxy' in the register global section.

bkwon Mon, 11/19/2012 - 13:07

so a call from SCCP phone to SIP phone failed.

please send me the debug ccsip mess, show run, show ver. at bkwon@cisco.com

fahimshah02 Sun, 03/10/2013 - 13:58

Hi,

I had the same issue of 9971 phones getting re-registered to CUCM 8.6.2.22900 via wifi less than every 10 minutes.

Figured out that QOS setting on Cisco AP was least priority for VOICE SSID.

The issue was resolved when QOS setting (on Cisco AP) for Voice SSID was changed to PLATINUM.

Hope this helps.

Rgrds

fahadqureshi Tue, 04/23/2013 - 02:13
  • Hello All,

I am also facing the same porblem. My phones are also going registered and un-registered after 10 mins... Anyone find the solution for that ?

fahimshah02 Tue, 04/23/2013 - 02:39

Hi fahad,

What environment is yours? 9971 is registered with CUCM or CME?

Is 9971 connected via wifi or wired?

Rgrds..

fahadqureshi Tue, 04/23/2013 - 02:58

thanks for your quick reply...

I configured cisco 9971 with Cisco CME ver 9.1. All the phones connected thorugh wire.

fabio_henrique Tue, 04/23/2013 - 05:47

Could you prrint your onfiguration of:

  • One voice register pool
  • One voice register dn
  • Voice register global
fahadqureshi Tue, 04/23/2013 - 15:30

Please find the below.

voice register global

mode cme

source-address x.x.x.x port 5060

timeouts interdigit 3

max-dn 25

max-pool 25

load 9971 sip9971.9-2-2SR1-9 

timezone 31

time-format 24

tftp-path flash:

create profile sync 0266545455593711

!

!

voice register dn  1

number 4000

allow watch

label Reception

!

!

voice register pool  3

registration-timer max 720 min 660

  id mac 64D9.89C2.CDAE

session-transport tcp

type 9971

number 1 dn 3

dtmf-relay rtp-nte sip-kpml cisco-rtp sip-notify

codec g711ulaw

  camera

fabio_henrique Tue, 04/23/2013 - 18:44

Hi Fahadqureshi,

Insert these configurations bellow and all phones will work fine!

voice register global

authenticate register

!

voice register pool  1

username xpto password xpto

The username and password can not be the same for each voice register pool. In my configuration I am using the username and password as the number of voice register dn.

Ex:

voice register dn  1

number 4701

!

voice register pool  1

id mac D4D7.48FF.C1FB

session-transport tcp

type 9971

number 1 dn 1

username 4701 password 4701

codec g711alaw

no vad

camera

video

I have had problems with transfer calls and for resolve this issue I am using the codec g711alaw, but you are using this codec

Try this configuration and if works, report to us.

Regards

fahadqureshi Thu, 04/25/2013 - 01:42

Dear Fabio,

Thank you so much in this.. This work perfectly fine.. Really thankfull to you. You are the only person who resolved this issue and guide me in a proper direction.

Thanks and takecare.

Best regards,

Fahad

Actions

Login or Register to take actions

This Discussion

Posted July 16, 2012 at 7:10 AM
Stats:
Replies:28 Avg. Rating:4.5
Views:5321 Votes:0
Shares:0

Related Content

Discussions Leaderboard