Dhcp Problem

Answered Question
Jul 17th, 2012
User Badges:

Hi,


We have a problem with two switches 2960  and router 2901. we have a trunk between switch and router. In router we have a subinterface g0/1.80 for voip and g0/1.90 for data. we show the config of interface and dhcp server router.


Dhcp works ok  for interface f0/3 only for data. When we conected phone never is assigned ip of range 10.161.80.0. and assgned 10.161.90.0. Awesome we could doing call becouse we can connect to default pbx of philips.


When only config at interface with vlan 80 like f0/2, never assigned ip.


Whe did debug  in router and we think the problem is in redline below.

At switch we can´t any config of dhcp.


I try to red this document before to go to bed . Its is posible that I can find the solution but   Anyone can help me please???


http://www.cisco.com/en/US/docs/ios-xml/ios/ipaddr_dhcp/configuration/15-1mt/dhcp-15-1mt-book.pdf



Anyone can help me please???


Regards.



config Router 2901

_______________________________

ip dhcp pool datos-pool

network 10.161.90.0 255.255.254.0

dns-server 10.161.1.20 10.161.1.22

default-router 10.161.90.2

!

ip dhcp pool voz-pool

network 10.161.80.0 255.255.254.0

option 66 ascii tftp://10.161.17.11   >>>>>>>><<this option is for philips phone.

default-router 10.161.80.2


____________________________-


config switch


interface FastEthernet0/1>>>>>>>>>>>>>>>>>>>>>>>>><trunk to router

description enlace contra SWAdmin_2

switchport mode trunk

!

interface FastEthernet0/2

switchport voice vlan 80>>>>>>>>>>>>>>><vlan voip

spanning-tree portfast

!

interface FastEthernet0/3

switchport access vlan 90>>>>>>>>>>>>>>><vlan data

switchport voice vlan 80

spanning-tree portfast




ul 17 20:26:55.938: DHCPD: checking for expired leases.

Jul 17 20:28:29.690: DHCPD: client's VPN is .

Jul 17 20:28:29.690: DHCPD: No option 125

Jul 17 20:28:29.690: DHCPD: Sending notification of DISCOVER:

Jul 17 20:28:29.690:   DHCPD: htype 1 chaddr 0060.b957.1f3d

Jul 17 20:28:29.690:   DHCPD: remote id 020a00000aa15a020100005a

Jul 17 20:28:29.690:   DHCPD: circuit id 00000000

Jul 17 20:28:29.690: DHCPD: DHCPDISCOVER received from client 0100.60b9.571f.3d on interface GigabitEthernet0/1.90.

Jul 17 20:28:29.690: DHCPD: Seeing if there is an internally specified pool class:

Jul 17 20:28:29.690:   DHCPD: htype 1 chaddr 0060.b957.1f3d

Jul 17 20:28:29.690:   DHCPD: remote id 020a00000aa15a020100005a

Jul 17 20:28:29.690:   DHCPD: circuit id 00000000

Jul 17 20:28:29.690: DHCPD: Found previous server binding

Jul 17 20:28:29.690: DHCPD: Sending DHCPOFFER to client 0100.60b9.571f.3d (10.161.90.78).

Jul 17 20:28:29.690: DHCPD: no option 125

Jul 17 20:28:29.690: DHCPD: ARP entry exists (10.161.90.78, 0060.b957.1f3d).

Jul 17 20:28:29.690: DHCPD: unicasting BOOTREPLY to client 0060.b957.1f3d (10.161.90.78).

Jul 17 20:28:29.690: DHCPD: client's VPN is .

Jul 17 20:28:29.690: DHCPD: No option 125

Jul 17 20:28:29.690: DHCPD: DHCPREQUEST received from client 0100.60b9.571f.3d.

Jul 17 20:28:29.690: DHCPD: Sending notification of ASSIGNMENT:

Jul 17 20:28:29.690:  DHCPD: address 10.161.90.78 mask 255.255.254.0

Jul 17 20:28:29.690:   DHCPD: htype 1 chaddr 0060.b957.1f3d

Jul 17 20:28:29.690:   DHCPD: lease time remaining (secs) = 86400

Jul 17 20:28:29.690: DHCPD: Can't find any hostname to update

Jul 17 20:28:29.690: DHCPD: Sending DHCPACK to client 0100.60b9.571f.3d (10.161.90.78).

Jul 17 20:28:29.690: DHCPD: no option 125

Jul 17 20:28:29.690: DHCPD: ARP entry exists (10.161.90.78, 0060.b957.1f3d).

Jul 17 20:28:29.690: DHCPD: unicasting BOOTREPLY to client 0060.b957.1f3d (10.161.90.78).

Jul 17 20:28:55.938: DHCPD: checking for expired leases.

Jul 17 20:30:55.938: DHCPD: checking for expired leases.

Correct Answer by Alexey Minaev about 5 years 1 month ago

Hi Rafael,


Could you try this config please


Router conf:


ip dhcp pool voz-pool

network 10.161.80.0 255.255.254.0

option 150 10.161.17.11 - voice server?

default-router 10.161.80.254


interface GigabitEthernet0/1

description ---  trunk to (2960) ---

no ip address

ip verify unicast reverse-path

no ip redirects

no ip unreachables

no ip proxy-arp

load-interval 30

duplex auto

speed auto


interface GigabitEthernet0/1.80

description --- VoIP (10.161.80.0/24) ---

encapsulation dot1Q 80

ip address 10.161.80.254 255.255.255.0


Switch conf


interface FastEthernet0/1

switchport trunk encapsulation dot1q (on 2960 enabled by default)

switchport trunk allowed vlan 1,80,90

switchport mode trunk

switchport nonegotiate

load-interval 30


interface FastEthernet0/3

switchport access vlan 90

switchport mode access

switchport voice vlan 80

load-interval 30

spanning-tree portfast

spanning-tree bpduguard enable

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Loading.
acampbell Tue, 07/17/2012 - 16:46
User Badges:
  • Green, 3000 points or more

Hi Rafael,


Your switch config for int f0/2 is the problem


This is your existing config


!

interface FastEthernet0/2

switchport voice vlan 80>>>>>>>>>>>>>>>

spanning-tree portfast

!


If this port is only to support a phone please reconfig to be an access port in vlan 80


!

interface FastEthernet0/2

shut

desc *** PHONE ONLY PORT VLAN 80 ***

no switchport voice vlan 80

switchport access vlan 80

spanning-tree portfast

no shut

!


See if that works



Regards,
Alex.
Please rate useful posts.

Rafael Romero Diaz Wed, 07/18/2012 - 00:21
User Badges:

Hi Alex,

thanks for your soon answer. It´s works ok but the problem is that I need vlan data too in this port.


Internet  10.161.80.3             0   0060.b957.1bc3  ARPA   GigabitEthernet0/1.80 


You think that the we need to put this command in switch???


SHRRHH_3(config)#ip dhcp-client ?

  broadcast-flag     Set the broadcast flag

  default-router     Set DHCP default router related information

  network-discovery  Configure parameters for network discovery



SHRRHH_3(config)#ip dhcp-se      

SHRRHH_3(config)#ip dhcp-server ?

  Hostname or A.B.C.D  IP address or Name of DHCP server



SHRRHH_3(config)#ip dhcp-server


__________________________________-


In other customer, we have this config and works ok.


ip dhcp pool TOIP

   network 10.166.200.0 255.255.248.0

   default-router 10.166.200.1

   option 150 ip 10.166.200.2

   dns-server 10.166.20.35 10.166.20.49



   interface GigabitEthernet1/0/2

switchport access vlan 100

switchport voice vlan 200

switchport port-security maximum 2

srr-queue bandwidth share 1 30 35 5

queue-set 2

priority-queue out

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

spanning-tree portfast

spanning-tree guard root

service-policy input AUTOQOS-SRND4-CISCOPHONE-POLICY


Regards.

cadet alain Wed, 07/18/2012 - 00:25
User Badges:
  • Purple, 4500 points or more

Hi,


in this case just redo your intial config but add this:

switchport access vlan x   where vlan x is the data vlan


Regards.


Alain.


Don't forget to rate helpful posts.

acampbell Wed, 07/18/2012 - 02:52
User Badges:
  • Green, 3000 points or more

Rafael,


The normal config for the kind of port you want would be like this:-


!

interface FastEthernet0/3

desc *** PHONE AND DATA ***

switchport access vlan 90

switchport voice vlan 80

spanning-tree portfast


My question to you is how the phone selects the VOICE vlan.

The VOICE vlan uses 802.1Q vlan taging in the ethernet frames


Cisco AUTOQOS is used for Cisco VOIP (CUCM/CUCME) PBX solutions

Cisco phones use CDP neighbour to find their voice vlan number


Do you enter this manually on the phone config ?


On Nortel/Avaya & Alcatel the Voice VLAN discovery can be part of the DHCP process from the phone.

Phone boot on the DATA vlan, obtain a DATA VLAN ip address.

Other DHCP parameters tell the phone to reset and use 802.1Q tagging to to next find an address on the VOIP Vlan.


I have no experience with Philips IP/PBXs so I dont know their process.




Regards,
Alex.
Please rate useful posts.

Correct Answer
Alexey Minaev Wed, 07/18/2012 - 05:31
User Badges:

Hi Rafael,


Could you try this config please


Router conf:


ip dhcp pool voz-pool

network 10.161.80.0 255.255.254.0

option 150 10.161.17.11 - voice server?

default-router 10.161.80.254


interface GigabitEthernet0/1

description ---  trunk to (2960) ---

no ip address

ip verify unicast reverse-path

no ip redirects

no ip unreachables

no ip proxy-arp

load-interval 30

duplex auto

speed auto


interface GigabitEthernet0/1.80

description --- VoIP (10.161.80.0/24) ---

encapsulation dot1Q 80

ip address 10.161.80.254 255.255.255.0


Switch conf


interface FastEthernet0/1

switchport trunk encapsulation dot1q (on 2960 enabled by default)

switchport trunk allowed vlan 1,80,90

switchport mode trunk

switchport nonegotiate

load-interval 30


interface FastEthernet0/3

switchport access vlan 90

switchport mode access

switchport voice vlan 80

load-interval 30

spanning-tree portfast

spanning-tree bpduguard enable

Rafael Romero Diaz Wed, 07/18/2012 - 14:14
User Badges:

Hi Guys


Thanks for your help.We solved the problem like I show you.

For Nec phone we need to appy option 66. This phone don´t work like a cisco phone. Don´t works with cdp.

In switchport of the phone we put Vlan 90 and works!!!!!!!!! only with this change. With command switchport voice vlan x is for cisco phone or Alcatel-Avaya. Nec don´t works with this config.



Dhcp in Router::::::::::::::::::::::::::::::::::::::::::::::.

ip dhcp pool data-pool

network 10.161.90.0 255.255.254.0

dns-server 10.161.1.20 10.161.1.22

default-router 10.161.90.2


!

ip dhcp pool voip-pool

network 10.161.80.0 255.255.254.0

option 66 ascii tftp://10.161.17.11

default-router 10.161.80.2

dns-server 10.161.1.20 10.161.1.22



Config in switch::::::::::::::::::::::::::::::::::::::::::

interface FastEthernet0/3

switchport trunk native vlan 80

switchport trunk allowed vlan 80-90

switchport mode trunk



Internet  10.161.80.3             1   0060.b9  ARPA   GigabitEthernet0/1.80

Internet  10.161.90.6             4   000f.b0  ARPA   GigabitEthernet0/1.90



Thank you very much.

Cheers.

Actions

This Discussion