Looking for advice on simple HTTP probe

Unanswered Question
Jul 19th, 2012
User Badges:

Hello team.

I proudly have my sticky web server farm up and running after many rounds of questions in this forum :o)


I currently am probing its servers by ckecking TCP 80 only, but each server has more than one web service, so from time to time the programmer needs to move a particular web service for maintenance purposes, while at the same time the remaining web services would still be working.


So I am planning to build more specific probes, one per web service or destination URL. Since this will be my first time building one such probe, I am looking for advice.


The following image is a wireshark snapshot of the request to the VIP and its service http://10.150.3.30/iwsupport

request.png


And the next image is the answer from the ACE on behalf of one server:

reply.png


Based on this information, I think that the following probe should be enough:


probe http IWSUPPORT

   interval 20

   passdetect interval 5

   request method get url /iwsupport

   expect status 200 200


¿Is the previous probe OK for my purpose?

I would appreciate your hints/advice if possible.


Best regards

Rogelio Alvez

Argentina

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jorge Bejarano Thu, 07/19/2012 - 14:44
User Badges:
  • Silver, 250 points or more

Hello Rogelio,


Yes, it looks fine but we may want to test it and see if it give us any error then based on that we can apply any change which may be required


Jorge

rogelioalvez Thu, 07/19/2012 - 16:41
User Badges:

Hi Jorge, it´s nice to meet you again.


I think i will build a new "test farm" with this probe in it, and make a policy call it to see how it behaves.

I will let you know what happened. It is good to know that it should work OK.


TIA, Rogelio


PS: sorry for the very basic questions. I am a poor R&S engineer trying to survive in this arena

Jorge Bejarano Thu, 07/19/2012 - 17:20
User Badges:
  • Silver, 250 points or more

Hola Rogelio,


Aquí tienes otro link que te puede servir:

http://www.cisco.com/en/US/docs/interfaces_modules/services_modules/ace/vA4_2_0/configuration/slb/guide/probe.html#wp1031398


Básicamente, el request method get url /  hace un llamado a ese url que tienes configurado y lo que debería responder es con un código de http: 200, lo que significa que fue éxitosa la solicitud de parte del "probe"


Solo como dato adicional, también se podría configurar puertos en el probe, dado el caso que tu aplicación escuche en otro puerto diferente a 80.


Por otra parte, es bueno antes de probar el "probe", revisar la conectividad desde el ACE a los servidores por ejemplo: # ping y tambien puedes hacer telnet desde el ACE así: telnet 80 ( Es bueno tambien tratar desde los servidores al ACE) Luego de probar la conectividad luego puedes correr el "probe", al principio deberías ver algo como INIT, que viene siendo el proceso inicial de comunicación del probe con el server y finalmente si todo sale bien debería mostrar "SUCESS", esto lo puedes revisar con: #show probe y tambien con #show probe detail.


Espero, te ayude y marcalo si consideras que la información brindada ha sido beneficiosa para que otras la tomen como referencia


Saludos, ahí nos cuentas como te fue


Jorge

Actions

This Discussion