Cisco RV220W + ProtectLink Issues with Netflix Instant on Samsung Device

Unanswered Question
Jul 19th, 2012

I am trying ProtectLink product on my RV220W router. I am having issues with Netflix Instant on a Samsung DVD player and internet features on a Samsung TV (Youtube, Pandora, Flickr, etc.). I am quite certain the issues started after I installed ProtectLink on my router.

I have added the IP address of both devices to "Approved Client" list.

Overflow Control is set to "Temporarily block URL requests", and Web Reputation is enabled set to "medium" (Blocks most Web threats).

URL filtering is also enabled for some categories.

Please let me know if I have misconfigured ProtectLink.

Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
doug_counsil@ya... Thu, 07/19/2012 - 16:58

We have ProtectLink Web configured the exact same as you.

Under URL Filtering we have everything checked under 'Harmful' except for 'Web Advertisements'.  Enabling the filtering of 'Web Advertisements' caused us some issues with some sites.  That was unfortunate because we really liked the able to filter that content.

We have no other filtering enabled.

We haven't run into any issues at all once we unchecked 'Web Advertisements'.  As a matter of fact, we have found that ProtectLink Web does such a good job that none of our IPS signatures are triggered.  ProtectLink filters out the garbage before it gets to that layer.

If you can't tell, we are EXTREMELY pleased with Trend Micro's ProtectLink Web funtionality.  We do not use the Gateway or End Point functionality.  And we don't plan to any time soon.

We have a SA540 whereas you have an RV220W.  From your post above, it seems that the functionality is implemented the same in both devices.

We purchased the 3-year license for ProtectLink Web from www dot provantage dot com.  We buy most of our Cisco stuff from them because their prices are great and we have had nothing but good experiences from them (although I think we bought our 3 year support contract for our SA540 from CDW).

I am not sure why you are running into issues with your devices.  We have 40+ devices that connect to our network on any given day.  The devices include things such as Mac and Windows laptops, Windows workstations running XP and 7 (Ultimate 32-bit and 64-bit), tablets (Xooms, iPads, etc.), smart phones (iPhones, etc.), Samsung TVs, Denon AVRs, D-Link security cameras, even some game consoles (Wii, PS3, Xbox 360).  I could go on and on.  Our SA540 never skips a beat.  It's solid as a rock.

sharam_55 Thu, 07/19/2012 - 17:24

Curtis,

Thank you for your vote of confidence in Trend Micro's ProtectLink. I am also going to buy if I have no issues with it.

I just turned off "URL filtering' and "Web Reputation" and I can now stream Netflix on my Samsung DVD Player! I have configured the DVD Player using static IP address and included it on the "Approved Client" list.

My guess is that the filtering doesn't happen based on client. It must be some sort of protocol filtering.

Do you know if ProtectLink filtering get's logged? Is there a way I can zoom in on the feature that causes this problem?

Thanks,

S Sasson

doug_counsil@ya... Thu, 07/19/2012 - 18:05

Well it's definitely ProtectLink Web, we just don't know yet if it's Web Reputation or URL Filtering.  Would you narrow it down to by turning Web Reputation back on and see if the problem comes back?

I hope it's not the Web Reputation that's giving you fits.  That's the best part of ProtectLink Web IMO.

The SA540 has a Reports link that shows the top ten visited, and top ten blocked, websites.  Not very helpful.  We write our logs to a syslog (and to the log in the SA540).  We set the logging level to "Warning". Even at that level, blocked websites are not logged.  We would probably have to turn on logging all the way down to "Info" or "Debug" to get that info.  You might think about doing that.

We have two *smart* TVs.  A Vizio and a Samsung.  We don't use Netflix any longer, but we do use Amazon VOD.  We are Amazon Prime members so we watch the free content once in a while.  We use both the PS3 or Vizio to watch Amazon VOD.  Both work perfectly.  I haven't tried any Internet functionality on our Samsung TV in a while.  Other than Netflix are you having any other problems with apps on your TV (something that I could try to replicate)?

We have an RV220W sitting in a drawer, but it doesn't have ProtectLink setup on it.  I need to sell it on eBay someday as we don't need it any longer.  We only kept it to use in a Lab environment that we no longer use.  It's only about four months old and we only used it for appx a month!

Sorry I couldn't be of more help.

doug_counsil@ya... Thu, 07/19/2012 - 18:07

I was going to tell you that once you figure out what's preventing you from streaming Netflix, I'd call Trend Micro and have then adjust their service accordingly.  I have a feeling you will have a good chance of getting it fixed since it would be on Trend Micro's side.  If you had to depend on Cisco, well, let's just say you'd be SOL!

sharam_55 Fri, 07/20/2012 - 12:09

Curtis thank you again. I have ruled out Web Reputation. So, I am quite certain that it is in URL Filtering. So, I went through URL Filtering and removed every category one by one. Even with no categories selected I was not able to play any videos. As soon as I disable URL Filtering all together the streaming starts to work.

Since the Samsung DVD players IP is in the approved client list. This suggest either a bug in ProtectLink or some sort of protocol filtering that is triggered by turning URL Filtering on.

It is interesting that I don't see this issue when I play a movie from a computer on the same subnet.

doug_counsil@ya... Fri, 07/20/2012 - 13:32

That's great that you've narrowed it down to simply turning "URL Filtering" on to re-create the issue.  Now's about the time you should contact the SBSC and open a case with them.

I am glad that you are still able to utilize the "Web Reputation" functionality in the mean time.  Trend Micro does any outstanding job not only with the implemention, but keeping it up-to-date in their back-end.  I sometimes verify/test how well they keep it up-to-date by attempting to navigate to some of the malware websites found here:

www dot malwaredomains dot com

They keep that list up-to-date almost on a daily basis, and everytime I attempt to navigate to one of the websites either Firefox or Trend Micro prevent me from doing so.

I wish I had a Netflix subscription so I could try streaming a movie on my Samsung TV to determine if our SA540 exhibits the same behavior.  My brother-in-law has a Netflix account so I could always use his account if you really want me to test it out for you.

I agree with you that enabling "URL Filtering" must be doing something in the background like automatically turning on some protocol filtering, etc.  It could be a bug or it could be that whatever it is doing in the background is too sensitive to how your players are connecting up to Netflix's back-end (weird API call probably).

At any rate, you probably have everything you need to open a case with Cisco.  Make sure you have your router's serial number handy.  They will also ask for your Cisco ID.  It is the same ID that you use to login to this forum.  They will probably ask you to turn on logging and maybe even need you to use Wireshark to provide them with more detailed info.

Good Luck.

doug_counsil@ya... Fri, 07/20/2012 - 13:45

I didn't even think about it until right now, but Cisco has Beta firmware for the RV220W in testing right now.  Call up SBSC and ask for level two support.  They can provide you with the Beta firmware.  I believe the latest one is 1.0.4.15.

Perhaps it contains a fix for your issue?  I highly doubt it, but Netflix streaming is very popular.  You can't be the only person that has encountered this issue.

sharam_55 Tue, 07/24/2012 - 15:53

I called both Trend Micro and SBSC. I opened a case, with the help of an engineer we ran diagnostic test and captured the network traffic. He couldn't help but I was promised that he would escalate the issue and get back to me.

I am still waiting.

doug_counsil@ya... Tue, 07/24/2012 - 16:02

What did Trend Micro have to say?  I'm basically curious about your experience with their tech support.

Thanks for keeping us up-to-date.  The Trend Micro ProtectLink Web functionality is definitely worth the price (~$50/year with a 3 year license) to us.  Unless they fix your issue, half of the functionality (URL Filtering) is worthless to you.  That's not good, but perhaps not a show stopper from you purchasing a license in order to keep the Web Reputation functionality in force.

I probably wouldn't purchase a license until the issue is fixed.  I would keep requesting trial licenses from tech support so you can continue to help them troubleshoot the issue. 

sharam_55 Tue, 07/24/2012 - 16:13

I called the Trend Micro customer support and unknown to me they are outsourcing at least some of their support to GurAid. The tech asked to access my computer after I explained the issue was not on my computer I decided to give him access to my computer. After I explained the problem in detail he put me on hold for about an hour.

He came back with the big news that he can't help me and gave me another number in Trend Micro. But not before trying to sell me on fixing Application errors on my PC because of software conflicts for only $120!

The Trend Micro second tier support referred me to SCSC.

Actions

Login or Register to take actions

This Discussion

Posted July 19, 2012 at 3:43 PM
Stats:
Replies:10 Avg. Rating:
Views:884 Votes:0
Shares:0

Related Content

Discussions Leaderboard

Rank Username Points
1 1,091
2 369
3 181
4 83
5 80
Rank Username Points
5
5