RTMT cant send alerts to exchange server

Answered Question
Jul 20th, 2012

HI,

I have setup alerts in the RTMT and configured it with the exchange. I have tested the connectivity and it does connect to the exchange server IP. I can see the alerts showing up as sent to my email address but still I dont get any.

I have spoken to the exchange guy who said he added all the IP address (for our CUCM 8.5 nodes) to be allowed to send/relay emails. have done searches on the senders IP address (CM Nodes) and the senders email (rtmtadmin@cisco.com) but couldnt locate anything.

By checking some other topics, i came across that we have to configure the DNS on the CUCM CLI. I have checked through the GUI and the DNS is not setup.

can someone please advise

1. Do we need to configure a DHCP before configuring a DNS

2. we can only configure the DNS via the CLI as

set network dns {primary | secondary} ip-address

3. will this cause any network disconnection.

4. or do we have to reboot the cluster/ any services.

and the main question is even if we configure the DNS on the CUCM will it then be able to send the alerts from the RTMT to the exchange server.

Much appretaited for any help.

A

I have this problem too.
0 votes
Correct Answer by jpringle@hhca.com about 1 year 7 months ago

I believe the problem may be that if you have not set the domain name on the server, RTMT sends the email with RTMT_Admin (without the @domain.com) as the sender, which is not a propperly formatted email address.  With one of the versions of Exchange, Microsoft enhanced SMTP security to block emails without a proppery formatted email addresses.  Checkout this test by telneting dirctly to the SMTP Relay (Exchange 2010):

{Note: SMTP Server name and domain changed for security}

C:\>telnet 25  {Telnet to SMTP Relay on Port 25}

220 MailServer.MyCompanyDomain.com Microsoft ESMTP MAIL Service ready at Sat, 25 Aug 2012 14:58:59 -0400
helo               {Send a helo}
250 MailServer.MyCompanyDomain.com Hello [10.XXX.XXX.XXX]
Mail From: RTMT_Admin               {Specify the from email address without the @domain.com like RTMT does}
501 5.1.7 Invalid address               {As you can see, this is rejected}
Mail From: RTMT_Admin@domain.com               {Specify a propperly formatted From address}
250 2.1.0 Sender OK
Rcpt To: MyName@MyCompanyDomain.com          {Specify my email as the recipient}
250 2.1.5 Recipient OK
Data
354 Start mail input; end with .
Subject: Test Email
This is a test email message!
.
250 2.6.0 <4b59fefb-fb8b-4879-98eb-6bfc31e8bf5f@MailServer.MyCompanyDomain.com> [InternalId=58932767] Queued mail for delivery
quit
221 2.0.0 Service closing transmission channel


I received this email in my inbox (altough sometimes it gets dropped in my Junk Mail folder).

I have an old Exchange 2000 server that I am currently relaying my RTMT email alerts to and it relays the message with the sender of RTMT_Admin.

I believe when I add the domain name to my server (on my list of things to do but need to research the impact first) I will be able to relay to my Exchange 2010 server because the Mail From address will be RTMT_Admin@CompanyDomain.com.

I also want to point out that my CallManager is 7.1.5 which uses RTMT 8.1.  My Unity Connection Cluster is 8.0 and it uses RTMT 8.5.  In the email server settings in RTMT 8.1 the only settings are  "Mail Server" and "Port".  In the Mail Server setting in RTMT 8.5, you get the Mail Server, Port and "Sender User Id" which allows you to specify the From email address.  Since I can spcify any fully qualified email address, I can relay these to my Exchange 2010 server.

I hope this info is useful.  I found this link because I was searching for a way to specify the From address in CUCM 7.1.5 / RTMT 8.1 because I am being told by my security team that I have to decomission my Exchange 2000 server because it is running on Windows 2000 and there are no more security updates for it!

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 4 (2 ratings)
nickpalmermorewood Tue, 07/24/2012 - 04:27

1 - I don't believe you do, server IPs are most likely statically configured

2 - Don't forget set network domain

3 - I was trying to find this answer as well, but I believe the answer is yes....it says Change but doesn't make it clear if setting it for the first time, also implies changing it.

Note If you change the IP address for the primary DNS server, you must also restart the Cisco Tomcat service. For more information, see the utils service command.

Caution If you continue, this command causes a temporary loss of network connectivity. If you change the IP address of the DNS server, you must restart Cisco Tomcat and Cluster Manager. For more information, see utils service.

_____________________

Once you've done that, you need to then go to RTMT>Systems>Tools>Alert>Config Email Server

Enter the DNS name of your Exchange Server. You can also test it out without the DNS changes but entering the IP address of the Exchange Server and then triggering some test alerts.

HTH, Nick

abbaswalikhan Wed, 07/25/2012 - 02:58

Thanks Nick for the feedback.

just to confirm,

1. so we dont require any DHCP as we already have static IPs for the nodes.

2. after setting the IP address via the CLI for the primary and secondary DNS we have to set the network Domain as well.

3. I prepare for the outages and restart these services.

and with all this, we would be able to get those alerts.

In the RTMT>Systems>Tools>Alert>Config Email Server, you get to see the Main server name port and senders ID.

without the DNS changes (current situation), when I have used the IP address for the exchange server - I can positively test the connection to the server but as said, still unable to receive any emails!!

I will try to come up with a plan for the above changes and see how it goes

Regards

abbaswalikhan Wed, 07/25/2012 - 03:31

one more thing to add,

we have 6 nodes in our CUCM i.e. one pub and 4 subs with a single TFTP.

do we need to configure the above on all the nodes separatly!!

Thanks

nickpalmermorewood Thu, 07/26/2012 - 01:15

1) DHCP and DNS aren't related in reference to this config

2) After setting primary/secondary the system warns you that it will not be active until the domain name is set and then brings up the following warning:

***   W A R N I N G   ***
Adding/deleting or changing domain name on this server will break database replication. Once you have completed domain modification on all systems that you intend to modify, please reboot all the servers in the cluster. This will ensure that replication keeps working correctly. After the servers have rebooted, please confirm that there are no issues reported on the Cisco Unified Reporting report for Database Replication.

Security Warning : This operation will regenerate all CUCM Certificates including any third party signed Certificates that have been uploaded.

3) I feel you need to get email alerts working first before going through the above hassle using DNS name for your mail server. It should work if you enter the mail server IP, and if it isn't then something else isn't set up right.

System>Tools>Alert>Config Alert Action

Select Default (edit) and confirm that the recipient address is valid and enabled.

As to your last question not sure if DNS parameters need to be set on all servers, but I would tend to do so espcially given the replication warning and that you have to reboot all servers in the cluster to sync up again.

I had exactly the same issue and have been digging around to collate the right info.....so it's very much a works in progress for us as well. We however have managed to get Alerts working using IP rather than DNS name, I haven't yet completed the DNS work.

Nick

abbaswalikhan Thu, 07/26/2012 - 03:57

Nick,

I think you are right , we have to repeat it for all the nodes. By checking different nodes, all of them has Domain name with retries and timers set but we recently moved our Sub1 and didnt configure the Domain name on it. So it appears that these features are setup independently on each node.

The System>Tools>Alerts>Configure Mail Server, is currently setup with the IP address of the exchange. and when I go to

Analysis Manager>Preferences>Mail Server and do a test connectivily, it comes back with success. Does this implies your point that with this test successful, we dont really need the DNS to be setup! 

I could see alerts being generated and sent to the right addresses. but stil nothing comes here to our emails.

The exchange guys says, that we have entered the IP address of all your CM nodes so whenever they receive any email from them they will be relayed to our email address. Still nothing

Its not about setting the thresholds for each alerts right?

Thanks

A

nickpalmermorewood Tue, 07/31/2012 - 23:39

Hi Abbas,

Sorry for the delay in replying, I have been on sick leave. Did you manage to resolve this yet?

System>Alert Central

And from there you should be able to see the Last Alert Raised. If it's in Red it hasn't been cleared (Acknowledged). Choose an alert that you can simulate, like 'AuthenticationFailed' > Right Click and Set Alert Properties, Enable Alert>Next>Set a low threshold like 1 every 3>Next>Trigger on Every Poll>Next>Enable Email>Check Trigger Alert Action>Save

Then try and log in to the CUCM Publisher with the wrong Credentials a few times.

abbaswalikhan Wed, 08/01/2012 - 03:57

Nick,

hope you are better now.

its still not resolved, unfortunatly.

the system is generating these red alerts and below in the alert history i can see they are being sent to our configured email addresses (i have also included my gmail address).

I checked the thresholds, the enables, triggers on every poll are there

what  I dont understand is that why we still dont get emails to any of our addresses. what exactly is blocking them.

as said previously, if I can ping successfully the exchange box just using IP address in the

Analysis Manager>Preference> Mail server

so we dont really require the DNS settting do we.

Cheers,

A

nickpalmermorewood Wed, 08/01/2012 - 06:34

A,

I'm inclined to say then no you don't need DNS, because that is how I am working at the moment. But perhaps someone else can chime in with some advice, as like I said for me this is all a works in progress.

Strangely what works for you doesn't work for me....I am getting mails on alerts to my mailbox, using IP not DNS, BUT when I try the Analysis Manager, Mail Server Test I get failed, node not reachable!!

Perhaps one of the Cisco guys here can lend a hand to solving the issue.

Nick

abbaswalikhan Wed, 08/01/2012 - 06:52

Must be something on the mailserver then Nick!!

server guys says, give me the IP address(es) from where you expect the mails coming from, so that they can allow them.

I have given all the CM nodes.

would it be my PC where the RTMT is installed.

regards,

A

1425a1425 Tue, 08/07/2012 - 13:02

Did you ever figure this problem out?    

We have decided that it is our spam filter blocking it.  The reason is that the alert emails are sent without a sender/from feild populated.  I am looking now to see how to change that but have not had any luck so far.  If you have any info that might help I would greatly appreatied.

Thanks

Ken

charliemak Sat, 08/18/2012 - 15:57


Can you get any server log from the exchange guy ?

I can successfully get e-mail alert from RTMT after configuring DNS and domain in CUCM.
If I do not configure DNS and domain in CUCM, I get below error 553 in mail server. 

"Domain name required for sender address RTMT_Admin"

Correct Answer
jpringle@hhca.com Sat, 08/25/2012 - 12:40

I believe the problem may be that if you have not set the domain name on the server, RTMT sends the email with RTMT_Admin (without the @domain.com) as the sender, which is not a propperly formatted email address.  With one of the versions of Exchange, Microsoft enhanced SMTP security to block emails without a proppery formatted email addresses.  Checkout this test by telneting dirctly to the SMTP Relay (Exchange 2010):

{Note: SMTP Server name and domain changed for security}

C:\>telnet 25  {Telnet to SMTP Relay on Port 25}

220 MailServer.MyCompanyDomain.com Microsoft ESMTP MAIL Service ready at Sat, 25 Aug 2012 14:58:59 -0400
helo               {Send a helo}
250 MailServer.MyCompanyDomain.com Hello [10.XXX.XXX.XXX]
Mail From: RTMT_Admin               {Specify the from email address without the @domain.com like RTMT does}
501 5.1.7 Invalid address               {As you can see, this is rejected}
Mail From: RTMT_Admin@domain.com               {Specify a propperly formatted From address}
250 2.1.0 Sender OK
Rcpt To: MyName@MyCompanyDomain.com          {Specify my email as the recipient}
250 2.1.5 Recipient OK
Data
354 Start mail input; end with .
Subject: Test Email
This is a test email message!
.
250 2.6.0 <4b59fefb-fb8b-4879-98eb-6bfc31e8bf5f@MailServer.MyCompanyDomain.com> [InternalId=58932767] Queued mail for delivery
quit
221 2.0.0 Service closing transmission channel


I received this email in my inbox (altough sometimes it gets dropped in my Junk Mail folder).

I have an old Exchange 2000 server that I am currently relaying my RTMT email alerts to and it relays the message with the sender of RTMT_Admin.

I believe when I add the domain name to my server (on my list of things to do but need to research the impact first) I will be able to relay to my Exchange 2010 server because the Mail From address will be RTMT_Admin@CompanyDomain.com.

I also want to point out that my CallManager is 7.1.5 which uses RTMT 8.1.  My Unity Connection Cluster is 8.0 and it uses RTMT 8.5.  In the email server settings in RTMT 8.1 the only settings are  "Mail Server" and "Port".  In the Mail Server setting in RTMT 8.5, you get the Mail Server, Port and "Sender User Id" which allows you to specify the From email address.  Since I can spcify any fully qualified email address, I can relay these to my Exchange 2010 server.

I hope this info is useful.  I found this link because I was searching for a way to specify the From address in CUCM 7.1.5 / RTMT 8.1 because I am being told by my security team that I have to decomission my Exchange 2000 server because it is running on Windows 2000 and there are no more security updates for it!

abbaswalikhan Tue, 08/28/2012 - 04:47

Thanks JPringle,

I almost lost hope on this one and thats why checked your reply after sometime.

With what you said, means I can just add the domain name to my RTMT_admin to make it a fully qualified one.

all our nodes has the Domain name configured.

just to let you know that we are using CUCM 8.5 and RTMT 8.7

what i have done now

System>Tools>Alert>configure email server and changed the user id to RTMT_Admin@domainname.com.

I believe this will change the user id for all of the alerts.

also, if i go to Analysis Manager> Perfernces>Mailserver

the sender user id is still set to rtmtadmin@cicso.com whcih we can't edit.

so lets wait and see what happens

Thanks

Abbas

abbaswalikhan Tue, 08/28/2012 - 05:01

Brillient JPringle,

as soon as i have added the fully qualified name I have started to get the alerts.

Many Many thanks.

Abbas

abbaswalikhan Tue, 08/28/2012 - 06:03

Just to add to that,

Now as I am getting these alert. I want to setup a PRI channel out of service alert (as we had some issues recently where the channel got out of service and we didnt know about it until users started crying)

now in the below field, I can see all my channels

the rtmt gives me value over or under and not an exact value.

as

0= undetermind

1=out of service

2=idle

3=active call

4=reserved for D signalling

I suspect if we put value below 2 as 0 and 1 both are suspecious values!!!

also do we have to do it for all the channels one by one of is there a better way of doing it.

Many thanks

Abbas

jpringle@hhca.com Tue, 08/28/2012 - 09:27

Are you wanting to monitor just the D-Channel or the B-Channels too?

One of the built in CallManager Alerts (at least in RTMT v8.1) is "MgcpDChannelOutOfService".  It is a annoying though that the email alert does not show the gateway/interface, you have to right click on the alert and select "Alert Properties".

There are other alerts that can monitor the number of spans  in service per gateway and per CallManager.

To monitor the individual B-Channels, you will need to do it like you show above, which would be a pain if you have alot of PRIs. 

Good luck with it.

abbaswalikhan Tue, 08/28/2012 - 09:50

Yes JP you are right, the Dchannel alert is there but sometimes the D channel is working fine, like last time, we had the first B channel of the first gateway out of service and the rest had connected calls. so every new call was hiting that first channel and was gettting engaged tone.

the gateway cli doesnt really tell you about which channel out and in when  you run

ncc-r_hq-mgcp01#show isdn service

PRI Channel Statistics:

%Q.931 is backhauled to CCM MANAGER 0x0003 on DSL 0. Layer 3 output may not apply

ISDN Se0/0/0:15, Channel [1-31]

  Configured Isdn Interface (dsl) 0

   Channel State (0=Idle 1=Proposed 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)

    Channel :  1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1

    State   :  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 3 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

   Service State (0=Inservice 1=Maint 2=Outofservice 8=MaintPend 9=OOSPend)

    Channel :  1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1

    State   :  0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 2 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

but the RTMT showed that that one was out

so which means that i have to setup these alerts for our 90 channels

also i am runing a test later to take out one of the Q931 and see how the alerts which are setup for that particular channel comes out.

Thanks

Actions

Login or Register to take actions

This Discussion

Posted July 20, 2012 at 7:41 AM
Stats:
Replies:18 Avg. Rating:4
Views:2081 Votes:0
Shares:0

Related Content

Discussions Leaderboard