×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Extension Mobility - "Login failed due to a configuration..."

Unanswered Question
Jul 23rd, 2012
User Badges:

Hi guys,


I've been trying to configure a single phone to use extension mobility over the last few weeks and I have ended with the same result each time.


Below is a list of the changes I made on CM/UCCX for EM:


- Configured the extension mobility service and added it to the "host" phone

- Created a device profile for the number I'd like to use with EM

- Enabled EM on the "host" phone

- Created the Agent in UCCX and CM

- Associated the EM device profile with the user

- Associated the "host" phone with the RMCM application user


Using the service on the physical "host" phone will engage EM and the phone will reconfigure with the correct number (can receive and make calls). However, the Cisco Agent Desktop software does not see that the phone is registered and produces the following error:



"Login failed due to a configuration error with your phone and JTAPI or Unified CM. Contact your administrator."


I was under the impression that this would be related to the RMCM user but the "host" phone has been added to the control list.



Any suggestion?




Thanks in advance,


Rock

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
anchoudh Mon, 07/23/2012 - 04:51
User Badges:
  • Red, 2250 points or more

Hi Rock,


Is this host phone is associated as controlled device for this Agent? IS the UCX extension selected in the End user page of CUCM for this Agent.


Also please associate the MAC ID of the other phone (where this Agent is trying to login with his EM profile) to the RmCm application user in CUCM.


Hope this helps.

Anand


Please rate helpful posts by clicking on the stars below the right answers !!

RockCrayfish Mon, 07/23/2012 - 05:09
User Badges:

My apologies, I forgot to add that to my above list.


The host phone is associated with the agent user in CUCM. The primary and IPCC extension drop-down menus have been set to the appropriate extension. The device profile is associated with the agent user as a controlled profile and "Allow Control of Device from CTI" is selected.


The MAC of the host phone is associated with the RmCm application user in CUCM.



Thanks for the reply. Any other suggestions?

anchoudh Mon, 07/23/2012 - 07:32
User Badges:
  • Red, 2250 points or more

Hi Rock,


Could you please tell us the UCCX version being used here?


Unsupported Configurations for Agent Phones:


The following configurations are not supported for agent phones:

•Two lines on an agent’s phone that have the same extension but exist in different partitions.

•A Unified CCX extension assigned to multiple devices.

•Configuring  the same Unified CCX extension in more than one device profile, or  configuring the same Unified CCX extension in any combination of device  profiles and devices. (Configuring an Unified CCX extension in a single  device profile is supported.)

•In the Unified CM Administration  Directory Number Configuration web page for each Unified CCX line,  setting Maximum Number of Calls to a value other than 2.

•In the  Unified CM Administration Directory Number Configuration web page for  each Unified CCX line, setting Busy Trigger to a value other than 1.

•Configuring a Cisco Unified IP Phone with Secure Real-Time Protocol (SRTP) for use in silent monitoring and recording.

•No Cisco Unified Communications Manager device can be forwarded to the Unified CCX extension of an agent.

•The Unified CCX extension of an agent cannot be configured to forward to a Cisco Unified CCX route point.

•Use of characters other than the numerals 0–9 in the Unified CCX extension of an agent.

•Configuring the Unified CM intercom feature.

•Configuring the hold reversion feature.


Reference:

http://www.cisco.com/en/US/docs/voice_ip_comm/cust_contact/contact_center/crs/express_8_5/release/guide/uccx851rn.pdf



Thanks,

Anand

RockCrayfish Mon, 07/23/2012 - 07:50
User Badges:

UCCX 8.5 and CUCM 8.6.


- The directory number is associated with the EM device profile only, no other devices/profiles.

- Maximum Number of Calls and Busy trigger are configured to 2 and 1, respectively.

- No forwarding of any kind.

- Unified CM intercom feature is not enabled.

- Hold reversion feature is not enabled.


- Not sure if SRTP applies as it's a device profile configuration.

brian1mcc Tue, 07/24/2012 - 02:18
User Badges:
  • Silver, 250 points or more

Are you on the latest SU for CUCM 8.6? We ran in to that issue (amoung others) in 8.6.2a and it was resolved after we upgraded to an engineering special (8.6.2.22034).


Sounds very like this bug: CSCtq37975


Brian

RockCrayfish Tue, 07/24/2012 - 04:37
User Badges:

Here is the current system version: 8.6.2.20000-2. It's rather annoying considering the same agent can log in if I set them up with a physical phone or even a softphone but not a device profile (yes, I removed all other associations when I created the device profile for the agent).


Thanks for the help guys!

brian1mcc Tue, 07/24/2012 - 05:03
User Badges:
  • Silver, 250 points or more

So you're on 8.6.2(a). I think upgrading to SU1 will resolve this for you. Your best bet is probably to open a TAC case to confirm the bug, and to recommend a version to upgrade to.


BTW, when I was running in to this issue, I could log the agent in fine when using a physical device ... but once the DN was assigned to a device profile instead, it wouldn't work.


Brian

Please rate helpful posts!

Paul McGurn Tue, 07/24/2012 - 12:16
User Badges:
  • Bronze, 100 points or more

We typically get this error if the Device Profile (not just the phone) is not added to the list of controller profiles for the UCCX RM JTAPI user configured in CUCM, or, if non-EM, when the phone isn't added to the list of controlled devices.

RockCrayfish Wed, 08/29/2012 - 11:23
User Badges:

The device profile has been added  to "CTI Controlled Device Profiles" under the application user. The  physical phone that I will be logging into the device profile with is  also added as a controlled device under the application user.


Not  sure where else to turn. I've tried deleting and creating the device  and user profiles but nothing seems to resolve this issue.


I  have only seen the same error message when an agent with a physical  phone that hasn't been added to the application user attempts to login  to CAD.

Paul McGurn Wed, 08/29/2012 - 11:30
User Badges:
  • Bronze, 100 points or more

This is everything I do in order to get an EM user to be able to work in UCCX.


1. Provision their physical phone and soft phone with a "fake" extension (UCCX won't allowed shared lines, and EM vs. non-EM use of a DN counts as a shared line)

2. Configure a device profile for the user, and that will use their main extension/DN as line 1.

3. Add the device profile as a CTI-controlled profile in End Users

4. Set Primary Extension and IPCC Extension to their main DN (what the device profile is using)

5. Log their phone in to Extension Mobility

6. Add the device profile as a CTI-controlled profile in the UCCX application user

7. Confirm they can log in to CAD


I typically see the error you're seeing if #4 or #6 are missed/incomplete.  I don't think you need to add the devices to the RMCM user, as the device profile being added to it should suffice.

Ahmed Khalefa Thu, 09/13/2012 - 02:41
User Badges:

Hi Rock,

in the End User menu in the CUCM , associate BOTH the Physical Phone and the Device Profile.

and in the UCCX Extension , choose the Line with the PROFILE , not the one of the Device .

Now login to the IP Phone with your Mobility Credentials , then open the CAD application and try again to login .


Thanks A lot ,

Ahmed Salah

Paul McGurn Fri, 02/08/2013 - 06:08
User Badges:
  • Bronze, 100 points or more

another potential cause for this error -


if the user is on Cisco IP Communicator, and logged in with EM, go to Preferences > Audio > Network, and make sure it's bound to the correct network adapter.  we had a user with a laptop that was connecting via VPN, and the CIPC was bound to the laptop's bluetooth adapter instead of the VPN virtual NIC.  once we fixed that, and restarted CIPC, they could log in to CAD.

Actions

This Discussion

Related Content