Assistance configuring a 2620xm with pppoe

Unanswered Question
Jul 23rd, 2012

Here is what I have currently on my home network:

Sagemcom modem (windstream)

Cisco 2620XM router (1 AUX 1 Fast Ethernet)

Cisco 1900 Catalyst 24 port switch

Cisco 1200 Aeronet Wireless

HP Proliant DL380 G4

HP Netserver LC3

8 PC's

I am trying to use the Aux port on the router for the modem and the FE for my switch. I have followed several tutorials I have found (mostly on the Cisco site) but keep coming up with Unknown Network errors. Here is my current configuration:

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no network-clock-participate slot 1

no network-clock-participate wic 0

no aaa new-model

ip subnet-zero

ip cef

!

!

!

vpdn enable

!

vpdn-group ppoe

request-dialin

protocol pppoe

!

vpdn-group pppoe

!

no ftp-server write-enable

!

!

!

controller T1 1/0

framing sf

linecode ami

!

controller T1 1/1

framing sf

linecode ami

!

!

interface FastEthernet0/0

ip address 192.168.254.2 255.255.255.0

ip nat inside

ip tcp adjust-mss 1452

duplex auto

speed auto

!

interface Serial0/0

no ip address

shutdown

no fair-queue

!

interface Serial0/1

no ip address

shutdown

!

interface Dialer1

mtu 1492

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 1

!

ip nat inside source list 1 interface Dialer1 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

interface Dialer1

mtu 1492

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 1

!

ip nat inside source list 1 interface Dialer1 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

ip http server

!

access-list 1 permit 192.168.254.2

!

line con 0

line aux 0

line vty 0 4

!

!

!

end

Please let me know what needs to be changed so that I may get this working properly as at the end of next month I want to add VOIP to my home network.

Thanks!!!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
Peter Paluch Mon, 07/23/2012 - 06:43

Hi Jimmy,

I do not entirely understand what is the problem you are trying to solve. You have given us the list of your hardware, the current configuration, but you did not explain clearly what you are trying to achieve and what are the symptoms of your problem. Please be so kind to explain these in detail.

Best regards,

Peter

jimmy-barnett Mon, 07/23/2012 - 07:52

Peter,

What I am trying to accomplish is this. I want the modem to act like the modem, the router to handle the routing. The server is already handling the DHCP and the Cisco 1200 is handling the wireless. I want to be able to add VOIP to this in the near future as well.

Thanks!

Thanks Alessio! I will look over that document as well.

Peter Paluch Mon, 07/23/2012 - 08:13

Jimmy,

What is your exact Internet connection type? The AUX port is not supposed to provide network connectivity. You use the AUX to remotely access the router via a modem and configure it, but it is not intended to provide routed network connectivity.

The Sagemcom modem - what is it exactly? Is it a DSL? Analog dialup? Cable?

Best regards,

Peter

alessio@cisco Mon, 07/23/2012 - 08:14

Jimmy,

with this design care to bridge the modem if you want your router to manage routing and PPPOE. your server provider will give you the entire set of settings for the modem you are using and for the username /pwd you need.

Alessio

jimmy-barnett Mon, 07/23/2012 - 08:36

Peter,

It is an ADSL connection. I have looked at several different modules for the 2620 XM but there is not a Wic1 ADSL module. If I need to change to a different router please let me know what is recommended.

alessio@cisco Mon, 07/23/2012 - 08:41

Jimmy,

the fact that the wic-1adsl is EoS and EoL does not mean you can't get one working for your 2620xm. check for it on ebay and you will find tonns of them. I have installed personally wic-1adsl on the 2600 series and they work fine.

https://supportforums.cisco.com/thread/2126803

In the very first link of leo you should find all the info you need

enjoy

Alessio

jimmy-barnett Mon, 07/23/2012 - 09:15

Hi Alessio,

I just ordered one from ebay. should be here Friday of this week. Thank you for your assistantance thus far!

Thanks!

Jimmy

jimmy-barnett Fri, 07/27/2012 - 08:30

Hi Alessio,

Ok I have the Wic1-ADSL card installed. Anything i need to know before I get started?

Peter Paluch Wed, 08/01/2012 - 15:19

Hello Jimmy,

Were you able to get your ADSL card up and running?

Best regards,

Peter

jimmy-barnett Thu, 08/02/2012 - 06:02

Hi Peter,

I have been able to install the card but have not had any time to sit and configure. I have looked at numerous examples in the forums regarding the configuration but still not exactly sure of how to set this up.

Thanks!

Jimmy

jimmy-barnett Fri, 08/03/2012 - 06:02

Hi Peter,

I have read the article and I do believe that will work however last night I had to completely wipe the router and lost all the configurations (and my examples when the wife cleaned off the desk!) Is there a good tutorial (besides yours for the adsl card) that I can use with the proper commands for reconfiguring the router the way it needs to be? After I get this completed I am buying 2 or 3 more for a lab setup to begin the study for the CCNA and CCNP.

Thanks!

Jimmy

Peter Paluch Sat, 08/04/2012 - 05:08

Hello Jimmy,

Honestly, I am not sure about such a tutorial. Surely, there are lots of guides out there showing how to configure this or that feature. However, I would not personally expect an all-encompassing tutorial - considering the extensive IOS features, such a tutorial would be huge. Ultimately, it all boils down to what your requirements are. The thread I've directed you to contains a very common example of configuring an PPPoE/DSL access together with NAT which is the basic thing to achieve a working internet connection, and should be workable for you.

So think of what your requirements are, and we will slowly get them implemented.

Best regards,

Peter

Actions

Login or Register to take actions

This Discussion

Posted July 23, 2012 at 6:29 AM
Stats:
Replies:14 Avg. Rating:
Views:733 Votes:0
Shares:0

Related Content

Discussions Leaderboard

Rank Username Points
1 15,007
2 8,155
3 7,745
4 7,088
5 6,747
Rank Username Points
135
83
80
69
38