ISIS Multi-Topolgy Core

Unanswered Question
Jul 23rd, 2012

Hi All,

          With four routers in the core running ISIS Multi-topology for (IPv4 and IPv6) on all interfaces and the loopbacks, i can see all the necessary routes for IPv4 but not IPv6.

Despite enabling address-family for IPv6 and multi-protocol under the ISIS process and "ip router isis" under all the interfaces as needed, i still cannot see any IPv6 route when "show ipv6 route isis" is executed.

Can someone please help me out with what might be the problem?.

The topology can be seen on "CCIE-SP-v3.0-Sample-Lab-Part-1-7.pdf" submitted byVincent somewhere last year, " I am reffering to Routers 2,7,8 and 9 in particular" moreso, i am only running the LAB in pure IOS and not XR.

Thanking all in advance,

O.A

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
Olugbenga.Abiodun Mon, 07/23/2012 - 11:16

Hi Guiseppe,

                   Many thanks for your response as usual. I actually have the "metric-style wide" enabled under the router process as you can see the node's outputs below. Although i am only showing the output of one node but the same can be found on the remaining nodes.

R2#sir

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/8 is variably subnetted, 9 subnets, 2 masks

C       2.2.0.2/32 is directly connected, Loopback0

i L1    2.2.0.7/32 [115/10] via 2.2.27.7, GigabitEthernet3/0

i L1    2.2.0.8/32 [115/20] via 2.2.28.8, GigabitEthernet2/0

i L1    2.2.0.9/32 [115/20] via 2.2.29.9, GigabitEthernet1/0

C       2.2.27.0/24 is directly connected, GigabitEthernet3/0

C       2.2.28.0/24 is directly connected, GigabitEthernet2/0

C       2.2.29.0/24 is directly connected, GigabitEthernet1/0

i L1    2.2.78.0/24 [115/20] via 2.2.28.8, GigabitEthernet2/0

                    [115/20] via 2.2.27.7, GigabitEthernet3/0

i L1    2.2.79.0/24 [115/20] via 2.2.29.9, GigabitEthernet1/0

                    [115/20] via 2.2.27.7, GigabitEthernet3/0

==========================================================================

R2#sh ipv6 route isis

IPv6 Routing Table - Default - 8 entries

Codes: C - Connected, L - Local, S - Static, U - Per-user Static route

       M - MIPv6, R - RIP, I1 - ISIS L1, I2 - ISIS L2

       IA - ISIS interarea, IS - ISIS summary, D - EIGRP, EX - EIGRP external

R2#

==================================================================

R2#sr | sec router isis

ip router isis

ip router isis

ip router isis

ip router isis

router isis

net 47.0002.0000.0000.0002.00

is-type level-1

metric-style wide

!

address-family ipv6

  multi-topology

exit-address-family

R2#

===========================================================

R2#sh isis database

IS-IS Level-1 Link State Database:

LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL

R2.00-00            * 0x0000001F   0xC7C5        466               0/0/0

R7.00-00              0x0000001B   0x2AF8        1196              0/0/0

R7.01-00              0x00000006   0x73BF        1037              0/0/0

R8.00-00              0x00000010   0x6852        623               0/0/0

R8.01-00              0x0000000A   0xD057        630               0/0/0

R8.02-00              0x0000000B   0x63C7        1111              0/0/0

R9.00-00              0x00000011   0x6D44        1167              0/0/0

R9.01-00              0x0000000B   0x6BBE        1004              0/0/0

R9.02-00              0x0000000A   0xCA5A        583               0/0/0

R2#

=========================================================================

Lastly,  i have put "ip router isis" under each interface countless of times, yet when i do "sh run int XX" the result never showed any "ip router isis" under IPv6 address but can be seen under v4, is the  normal behaviour?. Please see below.

R2#sr int gi1/0

Building configuration...

Current configuration : 138 bytes

!

interface GigabitEthernet1/0

ip address 2.2.29.2 255.255.255.0

ip router isis

negotiation auto

ipv6 address 2002:2:2:29::2/64

end

================================================

Looking forward to your swift response as usual,

Regards,

O.A

Ivan Krimmel Mon, 07/23/2012 - 12:41

Hi O.A.,

you just need to add 'ipv6 router isis' under an interface in order to run ISISv6 on it.

This helps.

Olugbenga.Abiodun Mon, 07/23/2012 - 15:12

Ivan,

       Thanks for your contribution but if you have taken your time to read my last post, you will see that i mentioned "

Lastly,  i have put "ip router isis" under each interface countless of  times, yet when i do "sh run int XX" the result never showed any "ip  router isis" under IPv6 address but can be seen under v4, is this the normal  behaviour?

So this can't be the problem. Further help is much awaited from anyone.

Thanks,

=======

O.A

Ivan Krimmel Mon, 07/23/2012 - 22:20

O.V.,

I sure did read the whole thread and spotted the issue. Anyway, please take your time to check the config below:

interface Ethernet1/1

ip address 192.168.34.4 255.255.255.0

ip router isis ch

ipv6 address 2001::1/64

ipv6 router isis ch

Olugbenga.Abiodun Tue, 07/24/2012 - 00:39

Ivan,

       Thanks for your willingness to assist. Unfortunately, i cannot understanding why you wants me to add "ch" to the "ip router isis" under the interfaces because the router process does not contain any NAME/TAG. Below is my original configs.

R2#sr | sec router isis

ip router isis

ip router isis

ip router isis

ip router isis

router isis

net 47.0002.0000.0000.0002.00

is-type level-1

metric-style wide

!

address-family ipv6

  multi-topology

exit-address-family

R2#

I trust someone out there will be able to assist me further,

Huh!!! where did you get O.V from?,......I am O.A

Thanks,

O.A

Actions

Login or Register to take actions

This Discussion

Posted July 23, 2012 at 7:27 AM
Stats:
Replies:6 Avg. Rating:
Views:636 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard