×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

CUBE + SBC dtmf fail

Unanswered Question
Jul 23rd, 2012
User Badges:

Dear All,


I'm trying integration with SBC PSTN with SIP trunk (inband-g711aluw). All calls is always success ring and getting connection or answered, but the problem are when sending dtmf always send double digit and the destination does not receive tone. any idea about this ?


I have trying :


CME - CUBE (SIP trunk - inband G711aluw) - SBC -> DTMF Fail


CUCM - CUBE (SIP trunk - inband G711aluw) - SBC -> DTMF Fail


Regards



RD

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Chris Deren Mon, 07/23/2012 - 14:59
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,
  • Cisco Designated VIP,

    2017 IP Telephony, Contact Center, Unified Communications

Can you post your cube config?


Sent from Cisco Technical Support iPhone App

Rahman Dani Tue, 07/24/2012 - 05:27
User Badges:

Hi Cris,

Below my configuration


CISCO#term le 0

CISCO#sh run

Building configuration...



Current configuration : 6250 bytes

!

! Last configuration change at 09:52:39 UTC Mon Jul 23 2012 by bicisco

! NVRAM config last updated at 09:53:50 UTC Mon Jul 23 2012 by bicisco

! NVRAM config last updated at 09:53:50 UTC Mon Jul 23 2012 by bicisco

version 15.2

service timestamps debug datetime msec localtime

service timestamps log datetime msec localtime

service password-encryption

service sequence-numbers

!

hostname CISCO

!

boot-start-marker

boot system flash:c3900-universalk9-mz.SPA.152-3.T.bin

boot-end-marker

!

!

! card type command needed for slot/vwic-slot 0/1

logging buffered 10000000

no logging console

enable secret 5 $1$mqjI$MtrUawubK5sp8b1P2gpeh1

enable password 7 030752180500

!

aaa new-model

!

!

aaa authentication login h323 local

aaa authorization exec h323 local

!

!

!

!

!

aaa session-id common

no network-clock-participate wic 0

!

no ipv6 cef

!

!

!

!

!

no ip domain lookup

no ip cef

multilink bundle-name authenticated

!

!

!

!

!

!

!

voice-card 0

dspfarm

dsp services dspfarm

!

!

!

voice service voip

address-hiding

mode border-element license capacity 500

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

sip

registrar server

!

voice class codec 1

codec preference 1 g711alaw

codec preference 2 g711ulaw

codec preference 3 g729r8

!

!

!

!

voice translation-rule 1

rule 1 /^0\(.+\)/ /\1/

!

voice translation-rule 2

rule 1 /.+/ /2125525860/

!

!

voice translation-profile TO-TELKOM

translate calling 2

translate called 1

!

!

!

license udi pid C3900-SPE100/K9 sn FOC14176RVM

license accept end user agreement

license boot module c3900 technology-package uck9

hw-module pvdm 0/1

!

hw-module sm 1

!

!

!

username bicisco privilege 15 secret 5 $1$TDcE$SOAyL1syyplCmgtYsC.gF.

!

redundancy

!

!

!

!

!

!

interface Loopback0

no ip address

shutdown

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

description JKT-TIP-01-MGMT-3550-01 Fa0/10

ip address 10.222.1.40 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/2

description METRO-TELKOM Port 3

ip address 10.14.0.6 255.255.255.252

duplex auto

speed auto

no cdp enable

!

interface Serial0/0/0

no ip address

shutdown

clock rate 2016000

!

interface Serial0/0/1

no ip address

shutdown

clock rate 2016000

!

interface Serial0/0/2

no ip address

shutdown

clock rate 2016000

!

interface Serial0/0/3

no ip address

shutdown

clock rate 2016000

!

interface GigabitEthernet1/0

no ip address

shutdown

!

interface GigabitEthernet1/1

description Internal switch interface connected to EtherSwitch Service Module

no ip address

!

interface Vlan1

no ip address

shutdown

!

!

ip default-gateway 10.222.1.1

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 10.222.1.1

!

ip access-list extended INSIDE

permit udp host 10.204.206.252 any

deny   udp any any eq 5060

permit ip any any

ip access-list extended OUTSIDE

permit udp host 10.14.0.5 any

deny   udp any any eq 5060

deny   udp any any eq tftp

deny   tcp any any eq www

deny   tcp any any eq telnet

deny   tcp any any eq ftp

deny   tcp any any eq 22

permit ip any any

!

!

nls resp-timeout 1

cpd cr-id 1

!

snmp-server community %BI-Net&=+ RO

snmp-server ifindex persist

snmp-server enable traps entity-sensor threshold

!

!

!

control-plane

!

call treatment on

call threshold global cpu-avg low 68 high 75

call threshold global total-calls low 200 high 250

call spike 10 steps 6 size 250

!

!

!

!

!

!

mgcp profile default

!

sccp local GigabitEthernet0/0

sccp ccm 10.222.1.40 identifier 1 version 7.0

sccp

!

sccp ccm group 1

bind interface GigabitEthernet0/0

associate ccm 1 priority 1

associate profile 1 register XCODE_CUBE

registration retries 5

!

dspfarm profile 1 transcode

codec pass-through

codec g711alaw

codec g729r8

codec g711ulaw

maximum sessions 28

associate application SCCP

!

dial-peer voice 11 voip

description INBOUND-FROM-CME-CUCM

session protocol sipv2

incoming called-number 0[0-9]T

voice-class codec 1

dtmf-relay rtp-nte

no vad

!

dial-peer voice 12 voip

description INBOUND-FROM-TELKOM

session protocol sipv2

incoming called-number 2552586.

codec g711alaw

no vad

!

dial-peer voice 22 voip

description OUTBOUND-TO-CME

destination-pattern 2552586[0-3]

session protocol sipv2

session target ipv4:10.204.206.252

voice-class codec 1

voice-class sip bind control source-interface GigabitEthernet0/0

voice-class sip bind media source-interface GigabitEthernet0/0

dtmf-relay rtp-nte

no vad

!

dial-peer voice 23 voip

description OUTBOUND-TO-TELKOM

translation-profile outgoing TO-TELKOM

destination-pattern .T

session protocol sipv2

session target ipv4:10.14.0.5

voice-class sip bind control source-interface GigabitEthernet0/2

voice-class sip bind media source-interface GigabitEthernet0/2

codec g711alaw

no vad

!

dial-peer voice 24 voip

description OUTBOUND-TO-CUCM

destination-pattern 2552586[0-3]

session protocol sipv2

session target ipv4:10.204.27.222

voice-class codec 1

voice-class sip bind control source-interface GigabitEthernet0/0

voice-class sip bind media source-interface GigabitEthernet0/0

dtmf-relay rtp-nte

no vad

!

!

!

!

gatekeeper

shutdown

!

!

telephony-service

sdspfarm units 2

sdspfarm transcode sessions 128

sdspfarm tag 1 XCODE_CUBE

sdspfarm tag 2 MTP_CUBE

max-ephones 1

max-dn 2

ip source-address 10.222.1.40 port 2000

max-conferences 8 gain -6

transfer-system full-consult

transfer-pattern .T

create cnf-files version-stamp 7960 Jul 16 2012 07:57:41

!

!

!

line con 0

logging synchronous

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line 67

no activation-character

no exec

transport preferred none

transport input all

transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

flowcontrol software

line vty 0 4

logging synchronous

transport input all

!

scheduler allocate 20000 1000

ntp source GigabitEthernet0/0

ntp server 10.240.255.1

!

end


Thanks


Regards,


RD

Ayodeji Okanlawon Mon, 07/23/2012 - 15:04
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

Can you also send along with your cube config, a "debug voip rtp session named-event "


Please rate all useful posts


"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Nick Lichatz Mon, 07/23/2012 - 17:52
User Badges:

you are most likley trying to use OOB DTMF and your trunk is using inband??


what dtmf are you using on your outbound and and inbound dial-peers on the CUBE?



If your dial-peers and CUCM trunk is configured correctly and you are trying to convert OOB and inband DTMF,  build a MTP on your DSP farm on your CUBE and add it to your MGRL for the trunk. this takes about 2 minutes to config. if this doesnt work, pull some traces and post.

Rahman Dani Tue, 07/24/2012 - 05:31
User Badges:

Hi Nick,

I already configured transcode at cube configuration, any idea do you have ?


Thanks


Regards


RD

Rahman Dani Tue, 07/24/2012 - 05:29
User Badges:


Hi aokanlawon,

Below capture during calling and I trying to send digit dtmf:

CISCO#

044142: Jul 24 06:17:40.447:          s=VoIP d=DSP payload 0x65 ssrc 0x522CEFC sequence 0x122 timestamp 0xB3B721B7

044143: Jul 24 06:17:40.447:  << Pt:101    Evt:0       Pkt:0A 00 A0

044144: Jul 24 06:17:40.447:          s=VoIP d=DSP payload 0x65 ssrc 0x522CEFC sequence 0x122 timestamp 0xB3B721B7

044145: Jul 24 06:17:40.447:  << Pt:101    Evt:0       Pkt:0A 00 A0

044146: Jul 24 06:17:40.467:          s=VoIP d=DSP payload 0x65 ssrc 0x522CEFC sequence 0x124 timestamp 0xB3B721B7

044147: Jul 24 06:17:40.467:  << Pt:101    Evt:0       Pkt:0A 01 40

044148: Jul 24 06:17:40.467:          s=VoIP d=DSP payload 0x65 ssrc 0x522CEFC sequence 0x124 timestamp 0xB3B721B7

044149: Jul 24 06:17:40.467:  << Pt:101    Evt:0       Pkt:0A 01 40

044150: Jul 24 06:17:40.479:          s=DSP d=VoIP payload 0x65 ssrc 0x60 sequence 0x123 timestamp 0x12295B97

044151: Jul 24 06:17:40.479:          Pt:101    Evt:0       Pkt:03 00 00  >>

044152: Jul 24 06:17:40.479:          s=DSP d=VoIP payload 0x65 ssrc 0x60 sequence 0x124 timestamp 0x12295B97

044153: Jul 24 06:17:40.479:          Pt:101    Evt:0       Pkt:03 00 00  >>

044154: Jul 24 06:17:40.479:          s=DSP d=VoIP payload 0x65 ssrc 0x3B90128 sequence 0x123 timestamp 0x12295B97

044155: Jul 24 06:17:40.479:          Pt:101    Evt:0       Pkt:03 00 00  >>

044156: Jul 24 06:17:40.479:          s=DSP d=VoIP payload 0x65 ssrc 0x3B90128 sequence 0x124 timestamp 0x12295B97

044157: Jul 24 06:17:40.479:          Pt:101    Evt:0       Pkt:03 00 00  >>

044158: Jul 24 06:17:40.487:          s=VoIP d=DSP payload 0x65 ssrc 0x522CEFC sequence 0x126 timestamp 0xB3B721B7

044159: Jul 24 06:17:40.487:  << Pt:101    Evt:0       Pkt:0A 01 E0

044160: Jul 24 06:17:40.487:          s=VoIP d=DSP payload 0x65 ssrc 0x522CEFC sequence 0x126 timestamp 0xB3B721B7

044161: Jul 24 06:17:40.487:  << Pt:101    Evt:0       Pkt:0A 01 E0

044162: Jul 24 06:17:40.499:          s=DSP d=VoIP payload 0x65 ssrc 0x60 sequence 0x125 timestamp 0x12295B97

044163: Jul 24 06:17:40.499:          Pt:101    Evt:0       Pkt:03 00 00  >>

044164: Jul 24 06:17:40.499:          s=DSP d=VoIP payload 0x65 ssrc 0x3B90128 sequence 0x125 timestamp 0x12295B97

044165: Jul 24 06:17:40.499:          Pt:101    Evt:0       Pkt:03 00 00  >>

044166: Jul 24 06:17:40.507:          s=VoIP d=DSP payload 0x65 ssrc 0x522CEFC sequence 0x128 timestamp 0xB3B721B7

044167: Jul 24 06:17:40.507:  << Pt:101    Evt:0       Pkt:0A 02 80

044168: Jul 24 06:17:40.507:          s=VoIP d=DSP payload 0x65 ssrc 0x522CEFC sequence 0x128 timestamp 0xB3B721B7

044169: Jul 24 06:17:40.507:  << Pt:101    Evt:0       Pkt:0A 02 80

044170: Jul 24 06:17:40.519:          s=DSP d=VoIP payload 0x65 ssrc 0x60 sequence 0x126 timestamp 0x12295B97

044171: Jul 24 06:17:40.519:          Pt:101    Evt:0       Pkt:03 01 90  >>

044172: Jul 24 06:17:40.519:          s=DSP d=VoIP payload 0x65 ssrc 0x3B90128 sequence 0x126 timestamp 0x12295B97

044173: Jul 24 06:17:40.519:          Pt:101    Evt:0       Pkt:03 01 90  >>

044174: Jul 24 06:17:40.527:          s=VoIP d=DSP payload 0x65 ssrc 0x522CEFC sequence 0x12A timestamp 0xB3B721B7

044175: Jul 24 06:17:40.527:  << Pt:101    Evt:0       Pkt:0A 03 20

044176: Jul 24 06:17:40.527:          s=VoIP d=DSP payload 0x65 ssrc 0x522CEFC sequence 0x12A timestamp 0xB3B721B7

044177: Jul 24 06:17:40.527:  << Pt:101    Evt:0       Pkt:0A 03 20

044178: Jul 24 06:17:40.547:          s=VoIP d=DSP payload 0x65 ssrc 0x522CEFC sequence 0x12C timestamp 0xB3B721B7

044179: Jul 24 06:17:40.547:  << Pt:101    Evt:0       Pkt:0A 03 C0

044180: Jul 24 06:17:40.547:          s=VoIP d=DSP payload 0x65 ssrc 0x522CEFC sequence 0x12C timestamp 0xB3B721B7



Thanks


Regards,

RD

Ayodeji Okanlawon Tue, 07/24/2012 - 05:39
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

Can you do a test call and send the ff: "debug ccsip messages"


I can see you are using and sending pt 101. We need to see if your provider is doing the same



Please rate all useful posts


"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Ayodeji Okanlawon Tue, 07/24/2012 - 05:42
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

I can also see that you have not enabled dtmf relay on your outbound and inbound dial-peer to your sip provider...


dial-peer voice 12 voip


dial-peer voice 23 voip

description OUTBOUND-TO-TELKOM

translation-profile outgoing TO-TELKOM

destination-pattern .T


Can you add dtmf-relay rtp-nte to this dial-peers.


Please rate all useful posts


"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Rahman Dani Tue, 07/24/2012 - 05:48
User Badges:

Hi aokanlawon,

yes, I'm not user dtmf-relay at dial-peer configuration becouse the connection used inband-SIP not out-of-band for rtp-nte.


Thanks


Regards,

RD

Ayodeji Okanlawon Tue, 07/24/2012 - 05:53
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

Rahman,


rtp-nte is not out of band. In trp-nte dtmf tones are carried inband. You need to specify the tyoe of dtmf to use. None is configured thats why its is not working. If you send me your debug ccsip messages, I will know what your provider is using. Most of then use rtp-nte



Please rate all useful posts


"'Nature is too thin a screen, the glory of the omnipresent God bursts through it everywhere"-Ralph Waldo Emerson

Actions

This Discussion

Related Content