×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

problem after migrate 6506 to N7K

Unanswered Question
Jul 26th, 2012
User Badges:
  • Silver, 250 points or more

we just replace 6500 with N7K, after migration there're some device (server,pc,printer) change its ip address configuration (subnet and gateway) by it self. can N7K did it?


---

Posted by WebUser Hafif Hery Husen from Cisco Support Community App

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
darren.g Tue, 07/31/2012 - 17:30
User Badges:
  • Silver, 250 points or more

Web User wrote:


we just replace 6500 with N7K, after migration there're some device (server,pc,printer) change its ip address configuration (subnet and gateway) by it self. can N7K did it?


---

Posted by WebUser Hafif Hery Husen from Cisco Support Community App


What did the device change its IP address from? And to?


Is the device obtaining its IP address via DHCP? If so, did you have a DHCP server running on your 6500? Or were you running the "IP Helper" command to forward DHCP elsewhere?


The N7K with NXOS doesn't run a DHCP server like other IOS devices can, so it can't have allocated the IP address to your device. There must be some other underlying cause. Do you have DHCP snooping configured on the N7K?


Cheers.

fb_webuser Wed, 08/15/2012 - 18:46
User Badges:
  • Silver, 250 points or more

hi Darren thank you for ur response

before the migration one of sun server have IP 172.30.83.16/24 and after it changed to 172.30.83.16/16

but its not just changed subnet mask, it also changed gateway other device


yes, before on 6500 we running "IP helper" command to forward dhcp and now on N7K we running "ip dhcp relay"


dhcp snooping disable on N7K


---

Posted by WebUser Hafif Hery Husen from Cisco Support Community App

darren.g Wed, 08/15/2012 - 21:38
User Badges:
  • Silver, 250 points or more

Web User wrote:


hi Darren thank you for ur response

before the migration one of sun server have IP 172.30.83.16/24 and after it changed to 172.30.83.16/16

but its not just changed subnet mask, it also changed gateway other device


yes, before on 6500 we running "IP helper" command to forward dhcp and now on N7K we running "ip dhcp relay"


dhcp snooping disable on N7K


---

Posted by WebUser Hafif Hery Husen from Cisco Support Community App


Do you have the layer 3 level on the N7k configured corrcetly?


Part of the DHCP forward/request is to identify the subnet the request is coming from - so the DHCP server knows which pool to allocate from - if you have mis-configured the layer 3 interface on the N7K with the wrong mask (it looks like you've got the correct subnet, at least), then the DHCP server may have been massively confused, and the Sun device may have gotten itself the wrong subnet mask.


Check the layer 3 configuration on your N7K for the VLAN concerned, and make sure it's correct.


Cheers

hery hafif setiadi Fri, 09/07/2012 - 23:39
User Badges:

hi Darren im the "Web User" above           

yes i believed the L3 config on N7K was correct but i need to make sure it .. that's why i posted this question


version 6.0(1)


interface Vlan83

  description ** Link to Server Room 3 **

  no shutdown

  ip flow monitor Netflow-Monitor-AABHO-CS input 

  ip flow monitor Netflow-Monitor-AABHO-CS output 

  no ip redirects

  ip address 172.16.83.248/24

  ip router eigrp 8888

  ip arp 172.16.83.25 03BF.AC10.5319 


version 6.0(1)


interface Vlan88

  ip flow monitor Netflow-Monitor-AABHO-CS input 

  ip flow monitor Netflow-Monitor-AABHO-CS output 

  ip address 172.16.88.201/24

  ip router eigrp 8888

  ip dhcp relay address 172.16.83.30

  description ** Link to 8fl **

  no shutdown


version 6.0(1)


interface Vlan81

  ip flow monitor Netflow-Monitor-AABHO-CS input 

  ip flow monitor Netflow-Monitor-AABHO-CS output 

  ip address 172.16.81.201/24

  ip router eigrp 8888

  ip dhcp relay address 172.16.83.30

  description ** Link to 1fl **

  no shutdown


any other config that i should post ?

darren.g Wed, 09/12/2012 - 19:18
User Badges:
  • Silver, 250 points or more

I can't see anything wrong with that - sorry.


Just out of interest - you *do* have the "feature dhcp" command set on the N7K, don't you? Grasping at straws - I can't see anything in the config (or know of anything in NXOS) which would change the DHCP reply like that.


Are you 100% sure of your DHCP server configuration?

hery hafif setiadi Thu, 09/13/2012 - 04:05
User Badges:

its ok Darren, thank you for your attention i really appreciate it

the problem doesnt appear anymore now, its only occurred shortly after the migration

and for DHCP server ... im 99% sure


btw i've another problem with N7K ... i'll create new discussion for it

Actions

This Discussion