Play a prompt to a MeetMe conference

Unanswered Question
Jul 27th, 2012

Hi everyone:

I'm trying to develop a "frontend" for meetme conferences. The caller can insert the meetme number, a configured password, and record his name. This should be played to the conference to announce the new user.

Everything is working OK except  playing the prompt to the meetme conference. It works when calling an IP phone instead of the meetme conference, so I supposed the "Place Call" step is well configured.

Do you know what could be the problem, or if there's some limitation about that? (So people should buy a Meeting Place )

I'm using UCCX 8.5 with CUCM 8.6, and this is the script:

sshot-314.png

Thanks!!!!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 4.5 (2 ratings)
Chris Deren Fri, 07/27/2012 - 07:15

What do you see when you do reactive debug? Have you tried longer delay?

Chris

cfernandezg Mon, 07/30/2012 - 00:46

Hi Chris:

Reactive debug shows that the "Place Call" step tries to connect (it sounds one beep in the meetme conference) but it fails (after 3 seconds it sounds 2 beeps meaning the participant has disconnected). It doesn't go inside Succesful or any other branch. After these 3 seconds it goes directly to the next step, "Call Redirect".

Thanks for your help!

Carlos F.

Chris Deren Mon, 07/30/2012 - 07:22

Is the meetMe DN in the same PT as the other phone DN you tried in your script?

What codec are you using for the UCCX deployment and for your conference bridge? Are the cti ports in the same region via DP as the conference bridge, if not are they configured to use the same codec?  What type of conference bridge are you using, software or hardware?

Chris

cfernandezg Mon, 07/30/2012 - 08:02

Hi Chris:

Is the meetMe DN in the same PT as the other phone DN you tried in your script?

Yes

What codec are you using for the UCCX deployment and for your conference bridge?

We are using only G.711, because we don't have DSPs

Are the cti ports in the same region via DP as the conference bridge, if not are they configured to use the same codec?

Same DP for both

What type of conference bridge are you using, software or hardware?

Software at the CUCM servers (IP Voice Media Streaming Application)

Thanks!!

Carlos F.

Graham Old Tue, 07/31/2012 - 12:48

I had an issue that would not play prompts on a place call step. In my case this was playing to a phone.

My problem was that the "Default IVR Language Configuration" was wrong in System/Languages 

I am in the UK and it was set to [en] instead of [en_GB]

What was strange was all the inbound scripts were picking up prompts from [en_GB] it was only the play prompt on the contact from the place call step that was looking in the [en] prompt directory.

Just another point to watch out for. The first call into a meetme has to come from a Cisco phone, go off hook, select the meetme softkey and dial the meetme number. The second call onwards can just dial the number. So your script will fail if this is the first call into the meetme conference.

Graham

cfernandezg Wed, 08/01/2012 - 02:16

Hi Graham, thanks for your answer:

I've checked the language configured, and it's [es_ES]

About the first call to a meetme number, when the script tries to place the call the meetme conference has been already created from a Cisco IP phone (meetme softkey).

Thanks again!

Carlos F.

bcorbet2004 Thu, 08/09/2012 - 13:18

I am attempting to do the same thing with MeetMe and UCCX.  I am having the same problem calling into the MeetMe bridge that is already activated.  I get 1 beep when the call is placed, and a few seconds later the 2 beeps when the call drops out of meetme.  I then redirect the caller to the meetme bridge and it works fine.

Seems like a RTP/Codec issue to me as well.

Did you find a resolution to yours?

Thanks,

Brian Corbet

cfernandezg Fri, 08/10/2012 - 02:32

Hi Brian:

Thanks for sharing your own experience. I haven't found a solution for this, so I'm not presenting the caller name to the conference. With this, a nice (and cheap) conference service could be implemented. Hope to find a solution...

Regards!

Carlos F.

Graham Old Fri, 08/10/2012 - 13:41

I ran a test on my lab system and it works as expected.

This is on UCM 8.6.1.20000-1 and CCX 8.5(1) SU3

I have posted my test script and prompts below.

This is what you need to do to install it.

Create a prompt directory: MeetMe

Load the prompts, MeetMe.zip in to the directory MeetMe

Create an application using the MeetMe.aef

Set the PortGroup to your “Call Control Group” “Group ID” if it’s not zero

Set the MeetMe to the Directory Number of the Meet Me

Add your trigger

This will wait for the first local person to start the Meet Me conference

If this fails then you have a setup problem.

Please rate helpful posts.

Graham

Attachment: 
cfernandezg Mon, 08/13/2012 - 04:11

Hi Graham:

Thank you very much for your answer. It's good to know it should work, and it's a problem of my "system". I've tried your script and prompts, and everything worked but "Place Call" step. It did the same: calls to the meetme conference (1 bip), wait for 2 or 3 seconds, and then it disconnects (2 bip). The first call to the meetme ("Redirect Call") worked fine.

Using a phone extension instead of the meetme number, the "Place Call" step worked fine.

I debugged the call in CUCM and in UCCX, and I found the next in UCCX log:

18142542: Aug 13 10:46:00.476 CEST %MIVR-SS_TEL-7-UNK:CallID:7446 MediaId:65619/2 Task:31000019056 did not get destination CONN_FAILED event

18142543: Aug 13 10:46:00.476 CEST %MIVR-SS_TEL-3-MAKE_CALL_FAILED:Outbound call failed : All Call ids=CallID:7446 MediaId:65619/2 Task:31000019056,CTI Port=19491,Exception=com.cisco.jtapi.PlatformExceptionImpl: Could not meet post conditions of connect(),Failure reason==0x64::

I don't know what's the cause. Maybe CTI Port configuration, but it's working OK with an IP Phone. What differences could exist between a connection to and IP phone or a Conference Bridge?

My system:

CUCM version: 8.6.2.21900-5 (8.6(2)SU1)

UCCX version: 8.5.1.11003-32 (8.5(1)SU3)

Thanks again!!!

Carlos F.

Graham Old Mon, 08/13/2012 - 11:27

Hi Carlos

Can you just check the codec you are using for the meetme.

Dial the meetme from a 79xx type phone and press the ? twice and see what codec the phone is using to talk to the meetme. Also check packet size is 20ms

Graham

cfernandezg Tue, 08/14/2012 - 00:30

Hi Graham:

Calling from a 7961 to the meetme conference, the codec used is G.711u, and 20ms packet size. This phone belongs to the same Device Pool as the Conference Bridges (IP Voice Media Streaming App.). All calls are using G.711 (we don't have hardware DSPs yet), and both G.711 codecs (a and u) are enabled for all devices.

Thanks for your answer!

Carlos F.

Graham Old Tue, 08/14/2012 - 02:16

Hi Carlos

The error message you are seeing suggests a partition, calling search space problem. But if I force that situation on my lab I don't get the beep when the CTI dials and the double beep when the CTI call drops.

So it does suggest it can dial the meetme but not establish the audio stream.

What does your system look like, how many UCM do you have, is your CCX HA.

Could this be a routing problem, can your CCX ping all your UCM servers, is the IP routing OK, are there any firewalls?

Graham

cfernandezg Tue, 08/14/2012 - 05:11

Hi Graham:

Yes, if it was related with permissions, the UCCX couldn't get this first bip when attempting to connect to the meetme conference. I agree it looks like a problem with establishing the audio connection.

We have 1 PUB and 1 SUB, both with CCM and IP Voice Media Streaming Application services enabled.

We have only one UCCX server, so no HA.

IP Connectivity between UCCX and UCM is working, because it's a production system, and we are running several applications in UCCX. All these servers are in the same LAN, so no firewall between them.

Thanks for your suggestions, Graham!

Carlos F.

Graham Old Wed, 08/15/2012 - 01:51

Hi Carlos

I am running out of ideas here.

Go to Trace in Unified CCX Serviceability, Select "Cisco Unfied CM Telephony Client" in the drop down and turn on all the logging for jtapi. See if that shows any more information on why the call is failing.

Try and do a test when the CC is not working so you only see your call in the logs.

You could also try from the UCM side by looking at the CTI logs.

Graham

cfernandezg Thu, 08/16/2012 - 01:51

Hi Graham:

Thanks for your support. I tried the call with JTAPI debug, and I got this message:

487: Aug 16 09:54:07.374 CEST %JTAPI-JTAPI-7-UNK:[[19490:INTERNA:1/(P1-JtapiUser_1) GCID=(2,67656)->ACTIVE]->ESTABLISHED]PlatformExceptionImpl caught: Internal error returned from call control

488: Aug 16 09:54:07.378 CEST %JTAPI-JTAPI-7-UNK:(P1-JtapiUser_1) [BRIDG_19490] CiscoMediaOpenLogicalChannelEv [#98] Cause:100 CallCtlCause:0 CiscoCause:0 FeatReason:12

Apart from that, I didn't see any other error or failure message.

Which CUCM debugs could I get to see this "Call Control error" referred from the UCCX log? Yo said CTI logs, but which one do you mean?

Thanks again!!

Carlos F.

Graham Old Thu, 08/16/2012 - 04:02

Hi Carlos

This just confims its a media problem. The call establishes but it can't start the RTP streams.

Go to the CCX trace and enable LIB_MEDIA : DEBUGGING and XDEBUGGING1 traces

Repeat the test and collect the "Unified CCX Engine" and "DriverManager" traces.

If you can have the CTI port dial a phone and play any message to the phone. While the message is playing hit the ? mark twice and look at the call statistics, confirm the codec and packet size.

Graham

cfernandezg Thu, 08/16/2012 - 07:03

Hi Graham:

Tried what you said, but modifyng the script so it only calls to the meetme conference to play the recorded name, and then it terminates. I analized the traces (only UCCX Engine, I didn't find "DriverManager" traces), and found this:

20261008: Aug 16 15:40:31.778 CEST %MIVR-SS_TEL-7-UNK:CallID:8178 MediaId:68151/2 Task:31000021074 makeCall(19493,19347,10000)

20261017: Aug 16 15:40:31.784 CEST %MIVR-SS_TEL-7-UNK:CallID:8178 MediaId:68151/2 Task:31000021074 Got CallActiveEv, ConnCreatedEv, ConnConnectedEv, CallCtlConnInitiatedEv, TermConnCreatedEv BRIDG_19493, TermConnActiveEv BRIDG_19493, CallCtlTermConnTalkingEv BRIDG_19493,  events on the AddressCallObserver.

20261018: Aug 16 15:40:31.784 CEST %MIVR-SS_TEL-7-UNK:CallID:8178 MediaId:68151/2 Task:31000021074 Got CallCtlConnDialingEv,  events on the AddressCallObserver.

20261019: Aug 16 15:40:31.784 CEST %MIVR-SS_TEL-7-UNK:CallID:8178 MediaId:68151/2 Task:31000021074, TerminalConnection to Terminal: BRIDG_19493 is ACTIVE

20261020: Aug 16 15:40:31.787 CEST %MIVR-SS_TEL-7-UNK:CallID:8178 MediaId:68151/2 Task:31000021074 com.cisco.jtapi.CiscoMediaOpenLogicalChannelEvImpl received

20261021: Aug 16 15:40:31.788 CEST %MIVR-SS_TEL-7-UNK:CallID:8178 MediaId:68151/2 Task:31000021074, Local CallCtlConnEstablishedEv [19493:INTERNA:1/(P1-JtapiUser_1) GCID=(2,68151)->ACTIVE]->ESTABLISHED

20261022: Aug 16 15:40:31.788 CEST %MIVR-SS_TEL-7-UNK:CallID:8178 MediaId:68151/2 Task:31000021074 Got CallCtlConnEstablishedEv,  events on the AddressCallObserver.

20261023: Aug 16 15:40:31.788 CEST %MIVR-SS_TEL-7-UNK:CallID:8178 MediaId:68151/2 Task:31000021074 com.cisco.jtapi.CiscoRTPOutputStartedEvImpl received

20261027: Aug 16 15:40:31.790 CEST %MIVR-SS_TEL-7-UNK:CallID:8178 MediaId:68151/2 Task:31000021074 com.cisco.jtapi.CiscoRTPInputStartedEvImpl received

20261030: Aug 16 15:40:31.790 CEST %MIVR-LIB_MEDIA-7-UNK:PrPl: appId=2, confId=3894, parId=0, channelId=145, channelImplId=145, contactId=8178, contactImplId=68151/2 -> setTxDestination: payloadType=4

20261074: Aug 16 15:40:36.789 CEST %MIVR-SS_TEL-7-UNK:CallID:8178 MediaId:68151/2 Task:31000021074 did not get destination CONN_FAILED event

20261075: Aug 16 15:40:36.789 CEST %MIVR-SS_TEL-3-MAKE_CALL_FAILED:Outbound call failed : All Call ids=CallID:8178 MediaId:68151/2 Task:31000021074,CTI Port=19493,Exception=com.cisco.jtapi.PlatformExceptionImpl: Could not meet post conditions of connect(),Failure reason==0x64::

20261099: Aug 16 15:40:36.790 CEST %MIVR-SS_TEL-7-UNK:Call.rejecting(UNKNOWN) JTAPICallContact[id=8178,implId=68151/2,state=STATE_INITIATED_IDX,inbound=false,App name=AUDIO_BRIDGE,task=31000021074,session=31000010460,seq num=0,cn=Unknown,dn=null,cgn=19493,ani=null,dnis=null,clid=null,atype=OUTBOUND,lrd=null,ocn=Unknown,route=RP[num=0000],OrigProtocolCallRef=null,DestProtocolCallRef=0000000000010A37028E7DD700000000,TP=19493]

I also made the script to call to a phone instead of a meetme conference, and checked the codec while playing the prompt --> G.711u 20ms

With this information I can't guess what's the problem... maybe somebody can...

Thanks Graham!!

Kind Regards

Carlos F.

guilhem.perez Tue, 05/14/2013 - 03:03

Hi,

Did you solve your issue? I'm interested in your script function.

Thank you

cfernandezg Thu, 05/16/2013 - 03:03

Hi Guilhem:

No, I didn't solve this issue. I gave up the script, not using a prompt with the name of the new attendee. Just a prompt saying someone is connecting.

Kind Regards!

Carlos F.

Actions

Login or Register to take actions

This Discussion

Posted July 27, 2012 at 1:57 AM
Stats:
Replies:20 Avg. Rating:4.5
Views:1976 Votes:0
Shares:0

Related Content

Discussions Leaderboard