Replacing routing function with a switch

Answered Question
Jul 28th, 2012

Hello,

I have the task of replicating the router config on a 3825 router on a 3750 switch. Reason is we are taking out the router and replacing it with the switch to make use of the router for other functions.

Below is main part of the router config:

!

ip source-route

ip cef

!

!

multilink bundle-name authenticated

!

license udi pid CISCO3825 sn FCZxxxxxxx

!

vlan internal allocation policy ascending

!

interface GigabitEthernet0/0

ip address 10.19.28.5 255.255.255.0

duplex auto

speed 100

media-type rj45

no mop enabled

!        

interface GigabitEthernet0/1

ip address 10.19.127.16 255.255.255.0

duplex auto

speed auto

media-type rj45

!

interface FastEthernet1/0

description "m2_s17"

switchport access vlan 2

speed 100

no cdp enable

!

interface FastEthernet1/1

description "m2_s19"

switchport access vlan 3

speed 100

no cdp enable

!

interface FastEthernet1/2

description "m2_s21"

switchport access vlan 4

speed 100

no cdp enable

!

interface FastEthernet1/3

description "m2_s23"

switchport access vlan 5

speed 100

no cdp enable

!

interface FastEthernet1/4-14

shutdown

!

interface FastEthernet1/15

no switchport

ip address 10.19.128.16 255.255.255.0

!

interface Vlan1

no ip address

shutdown

!

interface Vlan2

ip address 192.168.61.1 255.255.255.252

ip load-sharing per-packet

ip ospf priority 10

!

interface Vlan3

ip address 192.168.61.5 255.255.255.252

ip load-sharing per-packet

ip ospf priority 10

!

interface Vlan4

ip address 192.168.61.9 255.255.255.252

ip load-sharing per-packet

ip ospf priority 10

!

interface Vlan5

ip address 192.168.61.13 255.255.255.252

ip load-sharing per-packet

ip ospf priority 10

!

router ospf 100

log-adjacency-changes

area 0.0.0.4 stub

network 192.168.61.0 0.0.0.3 area 0.0.0.4

network 192.168.61.4 0.0.0.3 area 0.0.0.4

network 192.168.61.8 0.0.0.3 area 0.0.0.4

network 192.168.61.12 0.0.0.3 area 0.0.0.4

!

ip default-gateway 10.19.28.254

ip forward-protocol nd

!

!

no ip http server

ip route 0.0.0.0 0.0.0.0 10.19.28.254

!

scheduler allocate 20000 1000

end

The 3750 switch I have runs C3750E-UNIVERSALK9-M, Version 12.2(55)SE3 on a LAN BASE license.

The first thing I have done is to order for a license upgrade to IP BASE which would give the support for OSPF routing.

I do not see much of an issue with the Interface configs, however, I am not too sure about replicating the routing config on the switch.

My question is can I run the commands as shown for the OSPF routing on the switch? If not, can I get suggestions on how best to set this up on the switch?

Regards,

Femi

I have this problem too.
0 votes
Correct Answer by realdreams about 1 year 8 months ago

The IP Base image supports OSPF for routed access to enable customers to extend Layer 3 routing capabilities to the access or wiring closet. The IP services image is required if you need multiple OSPFv2 and OSPFv3 instances without route restrictions. (Catalyst 3750 and 3560).

source: http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.2_55_se/release/notes/OL23054.html

I didn't know there was a LAN base licence for 3750. I don't see it in software download.

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
Reza Sharifi Sat, 07/28/2012 - 15:44

Hi

If you are planning to deploy OSPF I suggest you use IP Service license instead of IP Base as there are limitation with IP base

Other than that you can deploy OSPF on your switch just like the router

Also be aware that the switch does not run NAT, IPSec, if you need them

HTH

Sent from Cisco Technical Support iPhone App

femi.agboade Sat, 07/28/2012 - 15:52

Hello Reza,

Thanks for the response.

The IP Service license is actually quite pricey compared to the IP Base, more so that we arent doing any complex type of routing, not different from what is displayed in the router config I stated above.

I had also checked the Cisco configuration tool and noticed that both IP Base and IP Services license had pretty much the same feature set as regards OSPF functions.

So do you think I can run the setup below on the IP Base license:

interface Vlan4

ip address 192.168.61.9 255.255.255.252

ip load-sharing per-packet

ip ospf priority 10

!

router ospf 100

log-adjacency-changes

area 0.0.0.4 stub

network 192.168.61.0 0.0.0.3 area 0.0.0.4

network 192.168.61.4 0.0.0.3 area 0.0.0.4

network 192.168.61.8 0.0.0.3 area 0.0.0.4

network 192.168.61.12 0.0.0.3 area 0.0.0.4

Regards,

Femi

Correct Answer
realdreams Sun, 07/29/2012 - 12:15

The IP Base image supports OSPF for routed access to enable customers to extend Layer 3 routing capabilities to the access or wiring closet. The IP services image is required if you need multiple OSPFv2 and OSPFv3 instances without route restrictions. (Catalyst 3750 and 3560).

source: http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.2_55_se/release/notes/OL23054.html

I didn't know there was a LAN base licence for 3750. I don't see it in software download.

femi.agboade Sun, 07/29/2012 - 14:26

Hello,

Thank you for your comments and the reference link.

We purchased the 3750 switches with the LAN base license which I think is the default license that comes with the switch when it is purchased.

Regards,

Femi

Actions

Login or Register to take actions

This Discussion

Posted July 28, 2012 at 3:20 PM
Stats:
Replies:4 Avg. Rating:5
Views:321 Votes:0
Shares:0
Categories: Switches
+

Related Content

Discussions Leaderboard

Rank Username Points
1 15,012
2 8,155
3 7,745
4 7,088
5 6,752
Rank Username Points
115
88
85
74
38