Aironet 1130AG, home use WPA2, help

Answered Question
Jul 31st, 2012

Greetings,

I have a Cisco Aironet 1130AG.  I am trying to set this up for very basic home use.  I want to use WPA2.  I could of swore I'd done this before, but I can't for the life of me get it to work.  Keep getting errors about requires of Open Authentication, EAP with WPA2, etc.

Either way, I'm frustrated with the GUI.

Does anyone have an example of a very basic config for an 1130 using WPA2? 

On consumer wireless, it's WPA2 Personal (considering I'm not authentication against a server).

Thanks for any help.

I have this problem too.
0 votes
Correct Answer by marcgon2 about 1 year 8 months ago

Hello Scott,

In order to configure WPA2 on your autonomous access point using the GUI and only one SSID (no VLANs), you have to follow the following steps:

- Go to Security > Encryption Manager > Select Cipher > AES CCMP from the drop down menu > Apply

- Go to Security > SSID Manager > Select (or create) the SSID > Link the SSID to the radio that you want

- Open authentication should be selected

- Key Management should be set to Mandatory

- "Enable WPA" needs to be checked

- Enter the Pre-Shared Key on the "WPA                                        Pre-shared Key" field.

- Scroll down and click on the first apply (not the bottom one).

After this if you want to broadcast the SSID then you should select the SSID from the "Set Single Guest Mode SSID" drop down menu found at the bottom of the case.

When everything is configured, you have to turn on the radios on Network Interfaces > Radio0 802.11G or Radio1 802.11A > Settings > Enable > Apply.

The issue that you may be having is that is that the access point will not let you enable WPA until you configure the encryption first so please make sure that the encryption is cofigured before enablind WPA.

Here is link that explains this very well:

http://www.cisco.com/en/US/tech/tk722/tk809/technologies_configuration_example09186a008054339e.shtml#config_ap

Since you want to configure a pre-shared key you just have to go to the "Configure in Personal Mode" on the previous document.

I hope this helps you

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
Scott Fella Tue, 07/31/2012 - 14:08

Take a look at the other post here Optimizing Aironet 1142

Sent from Cisco Technical Support iPhone App

Correct Answer
marcgon2 Tue, 07/31/2012 - 14:15

Hello Scott,

In order to configure WPA2 on your autonomous access point using the GUI and only one SSID (no VLANs), you have to follow the following steps:

- Go to Security > Encryption Manager > Select Cipher > AES CCMP from the drop down menu > Apply

- Go to Security > SSID Manager > Select (or create) the SSID > Link the SSID to the radio that you want

- Open authentication should be selected

- Key Management should be set to Mandatory

- "Enable WPA" needs to be checked

- Enter the Pre-Shared Key on the "WPA                                        Pre-shared Key" field.

- Scroll down and click on the first apply (not the bottom one).

After this if you want to broadcast the SSID then you should select the SSID from the "Set Single Guest Mode SSID" drop down menu found at the bottom of the case.

When everything is configured, you have to turn on the radios on Network Interfaces > Radio0 802.11G or Radio1 802.11A > Settings > Enable > Apply.

The issue that you may be having is that is that the access point will not let you enable WPA until you configure the encryption first so please make sure that the encryption is cofigured before enablind WPA.

Here is link that explains this very well:

http://www.cisco.com/en/US/tech/tk722/tk809/technologies_configuration_example09186a008054339e.shtml#config_ap

Since you want to configure a pre-shared key you just have to go to the "Configure in Personal Mode" on the previous document.

I hope this helps you

scott.bridges Tue, 07/31/2012 - 15:02

I appreciate the replies.

Scott Fella,

I started manually inputing the SSID settings into my 1130AG, and a few of the commands are not valid.  Such as the "ssid Name" and "encryption mode ciphers aes-ccm".  I assume it's because of the different models.

Marco,

Unfortunately, I do not even have a "Select Cipher" option on the first step, so I can't even begin.

What should I be running?

Here is my Show Version:

#sh ver

Cisco IOS Software, C1130 Software (C1130-K9W7-M), Version 12.4(10b)JA, RELEASE SOFTWARE (fc2)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2007 by Cisco Systems, Inc.

Compiled Wed 24-Oct-07 15:17 by prod_rel_team

ROM: Bootstrap program is C1130 boot loader

BOOTLDR: C1130 Boot Loader (C1130-BOOT-M) Version 12.3(8)JEA, RELEASE SOFTWARE (fc2)

ap.godlike uptime is 37 minutes

System returned to ROM by power-on

System image file is "flash:/c1130-k9w7-mx.124-10b.JA/c1130-k9w7-mx.124-10b.JA"

marcgon2 Sun, 08/05/2012 - 07:56

If you get to the web interface of the access point, you should have a "Security" tab on the left side, if you select it, more options will apear below it, one of them is "Encryption Manager". Here on the Encryptoin Manager page you should see three otions: None, WEP Encryption and Cipher. If you want WPA to work, you have to select this and from the drop down menu, you select TKIP for WPA and AES CCMP for WPA 2.

If you have more questions please let me know.

scott.bridges Sun, 08/05/2012 - 09:20

Finally got it working.

Turns out that I had an old IOS on the AP that didn't have many of the options explained.

Once I upgraded to the latest possible IOS, I had the options and was able to get it working rather quickly.

Thanks again

Actions

Login or Register to take actions

This Discussion

Posted July 31, 2012 at 1:57 PM
Stats:
Replies:6 Avg. Rating:5
Views:4584 Votes:0
Shares:0

Related Content

Discussions Leaderboard