CME inbound SIP call forwarded or diverted has no audio in either direction

Unanswered Question
Aug 2nd, 2012

Inbound and outbound calls are working fine.

Inbound calls answered by agents then transfered to external numbers working fine.

But Inbound calls were forwarded or diverted directly (Call forward) by CME to external numbers have no audio.

Signalling works fine. (External number can answer can hand up. But NO AUDIO)

Did some research on web and found this post.

https://supportforums.cisco.com/thread/2105408

But No NAT and FIREWALL are involved in this case. also check configuration

These two command has already been added by CCA.

no supplementary-service sip moved-temporarily

no supplementary-service sip refer

voice service voip

ip address trusted list

ipv4 0.0.0.0 0.0.0.0

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

no supplementary-service h450.2

no supplementary-service h450.3

supplementary-service h450.12

no supplementary-service sip moved-temporarily

no supplementary-service sip refer

fax protocol none

no fax-relay sg3-to-g3

sip

registrar server expires max 3600 min 3600

no update-callerid

sip-profiles 1000voice service voip
ip address trusted list
ipv4 0.0.0.0 0.0.0.0
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service h450.2
no supplementary-service h450.3
supplementary-service h450.12
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
fax protocol none
no fax-relay sg3-to-g3
sip
registrar server expires max 3600 min 3600
no update-callerid
sip-profiles 1000

Anyone can help?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
David Trad Sun, 08/05/2012 - 19:31

Hi Kevin,

Do you have transcoding turned on? You may require this but in most cases is not essential.

Is the diverted call going back out over SIP or through a form of PSTN/PRI connection?

Cheers,


David Trad.

sometime911 Tue, 08/07/2012 - 15:24

Hi David

Yes. Transcoding is turned on. Required for CUE at here.

Diverted call going back out over same SIP trunk.

But when I checked SIP trace.

Inbound call was using G711alaw. But outbound is using G729

Outbound dial-peers are configured with a codec class. (g711alaw. g711ulaw and g729)

Not sure how to correct this.

Kevin

Paolo Bevilacqua Mon, 08/06/2012 - 06:27

Bind SIP to interface is configured where?

Which device is performing NAT?

Also seeing the trace would help.

sandunbaduge Tue, 01/08/2013 - 18:00

Kevin,

This is like a codec issue, you can configure voice class codec under voice service voip.

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729r8

video codec h264

Actions

Login or Register to take actions

This Discussion

Posted August 2, 2012 at 8:21 PM
Stats:
Replies:4 Avg. Rating:
Views:2121 Votes:0
Shares:0

Related Content

Discussions Leaderboard