voice-gw sip error

Unanswered Question
Aug 7th, 2012

                   Hi at all, I've a voice gw  with the following configuration

boot-start-marker
boot system flash0 c2900-universalk9-mz.SPA.151-3.T.bin
boot-end-marker
!
!
card type e1 0 0
card type e1 0 1
logging buffered 200000

!
no aaa new-model
clock timezone Prague 1 0
clock summer-time Prague recurring last Sun Mar 2:00 last Sun Oct 3:00
network-clock-participate wic 0
network-clock-participate wic 1
network-clock-select 1 E1 0/0/0
network-clock-select 2 E1 0/1/0
!
no ipv6 cef
ip source-route
ip cef
!
!
!
!
!
ip domain name dominio.local
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-net5
!
!
trunk group ALL_PRI
hunt-scheme longest-idle
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-21098022
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-21098022
revocation-check none
!
!
crypto pki certificate chain TP-self-signed-21098022
certificate self-signed 01
  30820227 30820190 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  2F312D30 2B060355 04031324 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32313039 38303232 301E170D 31323038 30373138 33303436
  5A170D32 30303130 31303030 3030305A 302F312D 302B0603 55040313 24494F53
  2D53656C 662D5369 676E6564 2D436572 74696669 63617465 2D323130 39383032
  3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281 8100BE25
  2CFD3094 9D8D3CED 93720195 EC853DD8 B8396951 C59B8CE1 132349A3 2294EE11
  E9F480F6 F263408E C437D44B 2D47973B B191AA03 E89F6803 76D2C331 B5921106
  8739632F 24230525 E2E02EEF 89464FE5 91B9036B F1EAB37E 81598BBE 476134CF
  566EDF95 CF932E35 716B1865 C70A1466 74B63941 2B997F8C C85A88D0 A90F0203
  010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603 551D2304
  18301680 14FBB7BC 31371601 AC4ACE63 ADAE6BE4 4FFA5B61 7E301D06 03551D0E
  04160414 FBB7BC31 371601AC 4ACE63AD AE6BE44F FA5B617E 300D0609 2A864886
  F70D0101 04050003 8181008B 92983B26 838EE882 F0FE957A D97A715B A8807639
  4D5F3406 EB2F4B36 3F3EF5DD 30787890 0576202A F8A0CE38 38EDB775 946AEE50
  E74E22EC 9D5F5F92 6AFFB08E C659C877 D7682B27 5A589B40 97E68686 FE55BE7A
  B0164B95 8C74465A E4E85082 F0B25C93 36A42808 6273BD0E 58334805 580BB4EE
  528F6062 145E1844 4B2248
   quit
voice-card 0
!
!
!
voice service voip
ip address trusted list
  ipv4 172.16.50.240
  ipv4 172.16.50.242
address-hiding
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
sip
  registrar server expires max 1200 min 300
  no update-callerid
  pass-thru content sdp
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 g729r8
codec preference 4 g729br8
video codec h264
!
voice class sip-profiles 1
request INVITE sip-header Contact modify "@" ";tgrp=1;trunk-context=cisco1@"
!
voice class sip-profiles 2
request INVITE sip-header Contact modify "@" ";tgrp=2;trunk-context=cisco1@"
!
!
!
!
voice translation-rule 1
rule 1 /^238607319/ /7701/
rule 2 /^238607346/ /7713/
rule 3 /^238607348/ /7710/
rule 4 /^238607351/ /7711/
rule 5 /^238607352/ /7712/
!
voice translation-rule 25
rule 1 /^999./ //
!
voice translation-rule 26
rule 1 /^/ /9991/
!
voice translation-rule 27
rule 1 /^/ /9992/
!
voice translation-rule 348
rule 1 /^238607348/ /7710/
!
voice translation-rule 351
rule 1 /^238607348/ /7711/
!
voice translation-rule 352
rule 1 /^238607348/ /7712/
!
!
voice translation-profile AddInboundPrefix1
translate called 26
!
voice translation-profile AddInboundPrefix2
translate called 27
!
voice translation-profile RemoveInboundPrefix
translate called 25
!
voice translation-profile contatta-in
translate called 1
!
voice translation-profile out-calling
translate calling 1
!
voice translation-profile to-348
translate called 348
!
voice translation-profile to-351
translate called 351
!
voice translation-profile to-352
translate called 352
!
!
license udi pid CISCO2911/K9 sn FCZ1445708D
hw-module pvdm 0/0
!
hw-module pvdm 0/1
!
!
!
username qualisystem privilege 15 password 7 08005C4F0A110041464A
username ucmadmin password 7 01000202490E115E
!
redundancy
!
!
controller E1 0/0/0
pri-group timeslots 1-30
description Welcome
!
controller E1 0/1/0
pri-group timeslots 1-30
description Welcome
!
!
!
!
!
interface GigabitEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
ip address 172.16.81.251 255.255.255.0
no ip proxy-arp
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:15
description Welcome
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn overlap-receiving T302 2000
isdn incoming-voice voice
trunk-group ALL_PRI
no cdp enable
!
interface Serial0/1/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn overlap-receiving T302 2000
isdn incoming-voice voice
trunk-group ALL_PRI
no cdp enable
!
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip route 0.0.0.0 0.0.0.0 172.16.81.254
!
!
!
!
control-plane
!
!
voice-port 0/0/0:15
translation-profile incoming AddInboundPrefix1
description Welcome
!
voice-port 0/1/0:15
translation-profile incoming AddInboundPrefix2
!
!
!
mgcp profile default
!
!
dial-peer voice 1 voip
description dummy_DialPeer_For_Primary_CUCM
session target ipv4:172.16.50.240
dtmf-relay h245-alphanumeric
!
dial-peer voice 2 pots
trunkgroup ALL_PRI
description Chiamata in uscita
translation-profile outgoing out-calling
destination-pattern 0T
no sip-register
!
dial-peer voice 3 pots
description Chiamata in ingresso
incoming called-number .%
direct-inward-dial
!
dial-peer voice 4 voip
description Chiamata in ingresso
destination-pattern 238607T
session target ipv4:172.16.50.240
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 5 pots
trunkgroup ALL_PRI
description Chiamata in uscita
translation-profile outgoing out-calling
destination-pattern 8T
no sip-register
!
dial-peer voice 103 voip
destination-pattern 100248401
session protocol sipv2
session target ipv4:172.16.50.240
playout-delay maximum 300
codec g711alaw
no vad
!
dial-peer voice 10 voip
description Chiamate a CTI Route Point di Contatta
destination-pattern 77..
session target ipv4:172.16.50.240
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 11 pots
description Ricezione chiamata sul numero 0238607319
translation-profile incoming contatta-in
incoming called-number 238607319
direct-inward-dial
!
dial-peer voice 348 pots
description Ricezione chiamata sul numero 0238607348
translation-profile incoming to-348
incoming called-number 238607348
direct-inward-dial
!
dial-peer voice 352 pots
description Ricezione chiamata sul numero 0238607352
translation-profile incoming to-352
incoming called-number 238607352
direct-inward-dial
!
dial-peer voice 351 pots
description Ricezione chiamata sul numero 0238607351
translation-profile incoming to-351
incoming called-number 238607351
direct-inward-dial
!
dial-peer voice 105 voip
destination-pattern 24507T
session target ipv4:172.16.50.240
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 106 voip
destination-pattern 24507T
session target ipv4:172.16.50.242
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 44 voip
description Chiamata in ingresso
shutdown
destination-pattern 999[1-9]238T
session target ipv4:172.16.50.240
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
dial-peer voice 5007 voip
description **Inbound trunk1 master**
translation-profile outgoing RemoveInboundPrefix
preference 1
destination-pattern 999123860741.
session protocol sipv2
session target ipv4:172.16.50.217:5122
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
voice-class sip profiles 1
no vad
!
dial-peer voice 5008 voip
description **Inbound trunk1 master**
translation-profile outgoing RemoveInboundPrefix
preference 2
destination-pattern 999223860741.
session protocol sipv2
session target ipv4:172.16.50.218:5122
voice-class codec 1 
voice-class sip dtmf-relay force rtp-nte
voice-class sip profiles 2
no vad
!
!
sip-ua
credentials username 100248401 password 7 055F272E15551F000D0242 realm sip.openvoip.it
keepalive target ipv4:172.16.50.218:5122
keepalive trigger 5
authentication username 100248401 password 7 06522E0078575810111047
retry keepalive 5
timers keepalive active 20
registrar ipv4:84.233.228.137:5060 expires 3600
sip-server ipv4:84.233.228.137:5060
!
the sip call to 172.16.50.218 / 217 doesn't work

with the command  "debug ccsip call I've the following output  Eachone can  help me?

.Aug  7 20:27:15.496: //206/1C747DAE8021/SIP/Call/sipSPICallInfo:
The Call Setup Information is:
Call Control Block (CCB) : 0x3164D710
State of The Call        : STATE_DEAD
TCP Sockets Used         : NO
Calling Number           : 3400971266
Called Number            : 238607413
Source IP Address (Sig  ): 172.16.81.251
Destn SIP Req Addr:Port  : 172.16.50.218:5122
Destn SIP Resp Addr:Port : 172.16.50.218:5122
Destination Name         : 172.16.50.218

.Aug  7 20:27:15.496: //206/1C747DAE8021/SIP/Call/sipSPIMediaCallIn
Number of Media Streams: 1
Media Stream             : 1
Negotiated Codec         : No Codec
Negotiated Codec Bytes   : 0
Nego. Codec payload      : 255 (tx), 255 (rx)
Negotiated Dtmf-relay    : 0
Dtmf-relay Payload       : 0 (tx), 0 (rx)
Source IP Address (Media): 172.16.81.251
Source IP Port    (Media): 27112
Destn  IP Address (Media):  -
Destn  IP Port    (Media): 0
Orig Destn IP Address:Port (Media): [ - ]:0

.Aug  7 20:27:15.496: //206/1C747DAE8021/SIP/Call/sipSPICallInfo:
Disconnect Cause (CC)    : 63
Disconnect Cause (SIP)   : 503

thanks in advance

giancarlo

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
leonardotadeu Tue, 08/07/2012 - 13:54

Sorry but what is your problem?

Coul you be more specific?

Regards

Leonardo Santana

gevangelista Tue, 08/07/2012 - 16:25

the call from pstn arrive to voice-gw and will be' redirected to 172.16.50.217 and/or 172.16.50.218 (is an external IVR ) but doesn't work

Actions

Login or Register to take actions

This Discussion

Posted August 7, 2012 at 1:42 PM
Stats:
Replies:3 Avg. Rating:
Views:403 Votes:0
Shares:0
Tags: sip, error
+

Related Content

Discussions Leaderboard

Rank Username Points
1 21,031
2 15,047
3 10,325
4 8,014
5 4,856
Rank Username Points
126
105
98
57
56