Gig trunk only running at 100mb

Answered Question
Aug 8th, 2012
User Badges:

Hello,


I have a trunk from a Cisco 3750 100mb switch to a Cisco 2960G switch.  The 3750 has a 1GB SFP module installed, so I should be getting 1GB throughput, but I'm only getting 100mb.


2960


interface GigabitEthernet0/23

description Trunk to 3750 2/0/48

switchport mode trunk



2960G#sh interface GigabitEthernet0/24

GigabitEthernet0/24 is up, line protocol is up (connected)

  Hardware is Gigabit Ethernet, address is a8b1.d4f9.c898 (bia a8b1.d4f9.c898)

  Description: Trunk to 3750-1 gig 1/0/1

  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive not set

  Full-duplex, 100Mb/s, link type is auto, media type is 10/100/1000BaseTX



3750


interface GigabitEthernet1/0/1

description Trunk to 2960G 0/24

switchport trunk encapsulation dot1q

switchport mode trunk



3750#sh int gig 1/0/1

GigabitEthernet1/0/1 is up, line protocol is up (connected)

  Hardware is Gigabit Ethernet, address is 001e.f632.0d01 (bia 001e.f632.0d01)

  Description: Trunk to 2960G 0/24

  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive not set

  Full-duplex, 100Mb/s, link type is auto, media type is 10/100/1000BaseTX SFP


I have replaced the cable which didn't help, and I also forced the speed ont he 3750 to be "speed 1000" and then the trunk went down.


Any ideas?


Correct Answer by Leo Laohoo about 4 years 9 months ago
 Pair D         0    +/- 2  meters N/A              Open


Ok, a few things.


Firstly, I don't know what IOS version you are using.  I am stating this now because for a 2960G you should be able to see the distance to the fault compared to the length of your cable.


Next, you see the result of Pair "D"?  Did you see it's marked as "OPEN" instead of Normal?  This means there's an OPEN circuit.  Unfortunately for you, Pair "D" controls GigabitEthernet.  This is the reason why your interface will only connect to 100 Mbps.


From the looks of your output, the cable directly connected to the 2960G is faulty.


Read more of TDR here

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Leo Laohoo Wed, 08/08/2012 - 03:25
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Ok, from the 2960G, please run the following commands:


1.  Command:  test cable tdr interface Gig0/24;

2.  Wait for approximately 5 to 7 seconds;

3.  Command:  sh cable tdr interface Gig0/24; and

4.  Please post the output to #3.

Andy White Wed, 08/08/2012 - 04:26
User Badges:

Wow I didn't know these commands existed!


sh cable tdr int gig 0/24

TDR test last run on: March 20 21:28:06



Interface Speed      Local pair   Pair length          Remote pair Pair status

---------     -----          ----------      ------------------       -----------        --------------------

Gi0/24    100M       Pair A         N/A                    N/A             Normal

                            Pair B         N/A                    N/A             Normal

                            Pair C         N/A                    N/A             Normal

                            Pair D         0    +/- 2  meters N/A              Open

Correct Answer
Leo Laohoo Wed, 08/08/2012 - 04:34
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

 Pair D         0    +/- 2  meters N/A              Open


Ok, a few things.


Firstly, I don't know what IOS version you are using.  I am stating this now because for a 2960G you should be able to see the distance to the fault compared to the length of your cable.


Next, you see the result of Pair "D"?  Did you see it's marked as "OPEN" instead of Normal?  This means there's an OPEN circuit.  Unfortunately for you, Pair "D" controls GigabitEthernet.  This is the reason why your interface will only connect to 100 Mbps.


From the looks of your output, the cable directly connected to the 2960G is faulty.


Read more of TDR here

Andy White Wed, 08/08/2012 - 04:39
User Badges:

Hi,


Version:


WS-C2960G-24TC-L   15.0(1)SE3            C2960-LANBASEK9-M


I've already replaced the cable though, I've tried CAT 5 and CAT6.


Regards

Leo Laohoo Wed, 08/08/2012 - 04:41
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

I've got 2960S running this IOS version and I've come up with good readings.



I've already replaced the cable though, I've tried CAT 5 and CAT6.

What kind of cables are we talking about here?  Are these the "molded" ones or the ones that are "hand-made"?

Andy White Wed, 08/08/2012 - 05:08
User Badges:

It was the cable! thanks, I replaced it for a 3rd time with a new cable:




Interface Speed    Local pair   Pair length        Remote pair Pair status

--------- ----- ---------- ------------------ ----------- --------------------

Gi0/24    1000M   Pair A          4    +/- 10 meters Pair B      Normal

                          Pair B          4    +/- 10 meters Pair A      Normal

                          Pair C          4    +/- 10 meters Pair D      Normal

                          Pair D          4    +/- 10 meters Pair C      Normal



Thanks

Leo Laohoo Wed, 08/08/2012 - 05:14
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Good to hear it's finally working.

Andy White Wed, 08/08/2012 - 06:07
User Badges:

Out of interest what does turning off DTP achieve (switchport nonegotiate)?

Leo Laohoo Wed, 08/08/2012 - 17:11
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Not much.  It will determine if the remote end port is an access port or a dot1q trunk.  I normally disable this feature.

Alessio Andreoli Wed, 08/08/2012 - 04:15
User Badges:
  • Silver, 250 points or more

Hi Andy,

when you hardcode the speed you need to hardcode the duplx settings and to disable DTP therefore i would tell that :



interface GigabitEthernet1/0/1

description Trunk to 2960G 0/24

switchport trunk encapsulation dot1q

switchport mode trunk

switchport none

speed 1000

duplex full


and


interface GigabitEthernet0/23

description Trunk to 3750 2/0/48

switchport trunk encapsulation dot1q

switchport mode trunk

switchport none

speed 1000

duplex full

this should work. After this implementation check if the CRC are increasing and if that is the case it could be cable or the SFP interface.



HTH


Alessio

Andy White Wed, 08/08/2012 - 04:28
User Badges:

Let me try this, why do we need to disbale the Dynamic trunking Protocol?


Thanks

Actions

This Discussion