×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

ASA5505 Version upgrade

Answered Question
Aug 11th, 2012
User Badges:

I'm currently having the following version on my ASA5505.


ASA 8.3.1 


ASDM 6,.4.5


I'm seeing the following new versions on support site and i would like to upgrade to the latest version


ASA 8.3.1  ---> 8.4.4.1.ED


ASDM 6,.4.5 --> 6.4.9.103



My question is


1. Can i go straight from 8.3.1 -> 8.4.4.1 or ASDM 6.4.5 -> 6.4.9 or do i need to install previous version?

2. What is the order i need to install is ADDM or ASA?  As per document i beleive its ASDM first?   Can somebody confirm this?



Thanks

Correct Answer by Karsten Iwen about 5 years 1 week ago

1) From 8.3 you can go directly to 8.4.4.1.

2) If you use an older ASDM with a newer ASA-version some features might not be available. But I had never problems with that. But the other way round, the newest ASDM normally supports not only the newest ASA-version but also many odver versions. So you are safe to first upgrade the ASDM and then the ASA.



-- 
Don't stop after you've improved your network! Improve the world by lending money to the working poor:
http://www.kiva.org/invitedby/karsteni

Correct Answer by Marvin Rhoads about 5 years 1 week ago

You can go sraight from each of those versions you are running to the latest.


There is no requirement regarding ASA software first or ASDM first. New features introduced in the later ASA software may not be configurable via the ASDM GUI until you have the matching current ASDM image loaded; but other than that the device will work just fine.


Upgrading ASDM is very simple in that one only needs relaunch ASDM for it to take effect immediately.


ASA upgrade is also simple but you will need to reboot the device for the new image to load. In both cases remember to clean up your disk0: (after validating your upgrade) by deleting the old images.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
Marvin Rhoads Sat, 08/11/2012 - 11:55
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,
  • Cisco Designated VIP,

    2017 Firewalling, Network Management, VPN

You can go sraight from each of those versions you are running to the latest.


There is no requirement regarding ASA software first or ASDM first. New features introduced in the later ASA software may not be configurable via the ASDM GUI until you have the matching current ASDM image loaded; but other than that the device will work just fine.


Upgrading ASDM is very simple in that one only needs relaunch ASDM for it to take effect immediately.


ASA upgrade is also simple but you will need to reboot the device for the new image to load. In both cases remember to clean up your disk0: (after validating your upgrade) by deleting the old images.

Correct Answer
Karsten Iwen Sat, 08/11/2012 - 11:56
User Badges:
  • Purple, 4500 points or more
  • Cisco Designated VIP,

    2017 Firewalling, VPN

1) From 8.3 you can go directly to 8.4.4.1.

2) If you use an older ASDM with a newer ASA-version some features might not be available. But I had never problems with that. But the other way round, the newest ASDM normally supports not only the newest ASA-version but also many odver versions. So you are safe to first upgrade the ASDM and then the ASA.



-- 
Don't stop after you've improved your network! Improve the world by lending money to the working poor:
http://www.kiva.org/invitedby/karsteni

mmuthiah72 Sat, 08/11/2012 - 12:05
User Badges:

Thank you both.  Upgrade completed sucessfully.  I can perform the upgrade in any order.  I'm seeing the latest version of ASA is 8.4.4.3 on my ASDM upgrade wizard, but only 8.4.4.1 is available for download!?  Is 8.4.4.3 a  beta version?

Actions

This Discussion

Related Content