×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

H323 gateway outbound dialing

Unanswered Question
Aug 13th, 2012
User Badges:

I am trying to set up a 2911 as an h.323 gateway connected to call manager.  I have the 5 digit dialing working and inbound is working.  My problem is outboud dialing.  I receive a fast busy on the outbound call.  I'm only using one pots line at the moment.   I can see the call reaching the gateway and going out but still receive the fast busy.  Could someone please check over my config and possibly see what I'm missing?  Thanks.


version 15.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname BN-USHUM01-RTR01

!

boot-start-marker

boot-end-marker

!

!

!

no aaa new-model

!

no ipv6 cef

ip source-route

ip cef

!

!        

!

!

ip dhcp pool Data

network 10.32.118.0 255.255.255.0

default-router 10.32.118.1

domain-name abs.com

dns-server 172.27.10.31 172.27.10.32

!

ip dhcp pool Voice

network 10.32.119.0 255.255.255.0

domain-name ABS

default-router 10.32.119.1

option 150 ip 10.5.1.15

!

!

no ip domain lookup

multilink bundle-name authenticated

!

!

!

!

!

!

trunk group outbound

!

crypto pki token default removal timeout 0

!

!

voice-card 0

dspfarm

dsp services dspfarm

!

!

!

voice service voip

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

h323

  no call service stop

!

voice class h323 1

  h225 timeout tcp establish 3

!

!

!

!

!

license udi pid CISCO2901/K9 sn FTX162980WB

hw-module pvdm 0/0

!

hw-module pvdm 0/1

!

!

!

username comms privilege 15 secret 4 LJjRhLQE9EeK0wxjud/EkEzZuTvRmpkVQAmfVmqtvcQ

!

redundancy

!

!

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/0.1

encapsulation dot1Q 1 native

ip address 10.32.118.1 255.255.255.0

!

interface GigabitEthernet0/0.2

description Voice

encapsulation dot1Q 2

ip address 10.32.119.1 255.255.255.0

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.32.119.1

!

interface GigabitEthernet0/1

ip address 172.27.2.10 255.255.255.0

duplex auto

speed auto

!

ip forward-protocol nd

!

ip http server

ip http authentication local

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 172.27.2.222

!

access-list 100 permit ip host 10.32.119.4 any

access-list 100 permit ip any host 10.32.119.4

!

!

!

control-plane

!

!

voice-port 0/0/0

trunk-group outbound

connection plar 25425

!

voice-port 0/0/1

connection plar 25425

shutdown

!

voice-port 0/0/2

connection plar 25425

shutdown

!

voice-port 0/0/3

shutdown

!

!

!        

mgcp profile default

!

!

dial-peer voice 2 voip

description Inbound 5 digit DN send to CUCM

preference 1

destination-pattern 25425

session target ipv4:10.5.1.15

voice-class h323 1

dtmf-relay h245-alphanumeric

no vad

!

dial-peer voice 5 pots

description Long Distance

destination-pattern 91[2-9].........

port 0/0/0

forward-digits 11

!

dial-peer voice 6 pots

description Local

destination-pattern 9[2-9].........

port 0/0/0

forward-digits 10

!        

dial-peer voice 7 pots

description International

destination-pattern 9011T

port 0/0/0

prefix 011

!

dial-peer voice 1 pots

incoming called-number .

direct-inward-dial

port 0/0/0

!

!

gateway

timer receive-rtp 1200

!

!

!

gatekeeper

no shutdown

!

!

!

line con 0

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

login local

transport input all

!

scheduler allocate 20000 1000

end

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
brmeade Mon, 08/13/2012 - 08:07
User Badges:
  • Silver, 250 points or more

Since he's using FXO, he will need to use debug voice ccapi inout.

Chris Deren Mon, 08/13/2012 - 08:16
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,
  • Cisco Designated VIP,

    2017 IP Telephony, Contact Center, Unified Communications

Also, provide "debug vpm signal", are you sure you have loop start POTS lines and not ground start? Try changing to ground start and reverse polarity if still having issues.


Chris

markedavis Mon, 08/13/2012 - 08:49
User Badges:

Debug vpm comes back with nothing.  Looks like I"m not reaching the port.  I did find that the toll fraud app was stopping it at first.  Now I get a recording saying the call cannot be completed as dialed. 


BN-USHUM01-RTR01#

Aug 13 15:47:11.486: //-1/xxxxxxxxxxxx/CCAPI/ccAppShutdownMode:

   ccAppShutdownMode: remove it from the queue

Aug 13 15:47:14.270: //-1/0001E1421700/CCAPI/cc_api_display_ie_subfields:

   cc_api_call_setup_ind_common:

   cisco-username=Houma Main Line

   ----- ccCallInfo IE subfields -----

   cisco-ani=25425

   cisco-anitype=2

   cisco-aniplan=1

   cisco-anipi=0

   cisco-anisi=1

   dest=12813867708

   cisco-desttype=0

   cisco-destplan=0

   cisco-rdie=FFFFFFFF

   cisco-rdn=

   cisco-rdntype=-1

   cisco-rdnplan=-1

   cisco-rdnpi=-1

   cisco-rdnsi=-1

   cisco-redirectreason=-1   fwd_final_type =0

   final_redirectNumber =

   hunt_group_timeout =0


Aug 13 15:47:14.270: //-1/0001E1421700/CCAPI/cc_api_call_setup_ind_common:

   Interface=0x30B3AE2C, Call Info(

   Calling Number=25425,(Calling Name=)(TON=National, NPI=ISDN, Screening=User, Passed, Presentation=Allowed),

   Called Number=12813867708(TON=Unknown, NPI=Unknown),

   Calling Translated=FALSE, Subscriber Type Str=Unknown, FinalDestinationFlag=TRUE,

   Incoming Dial-peer=2, Progress Indication=NULL(0), Calling IE Present=TRUE,

   Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=42

Aug 13 15:47:14.270: //-1/0001E1421700/CCAPI/ccCheckClipClir:

   In: Calling Number=25425(TON=National, NPI=ISDN, Screening=User, Passed, Presentation=Allowed)

Aug 13 15:47:14.270: //-1/0001E1421700/CCAPI/ccCheckClipClir:

   Out: Calling Number=25425(TON=National, NPI=ISDN, Screening=User, Passed, Presentation=Allowed)

Aug 13 15:47:14.270: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:


Aug 13 15:47:14.270: :cc_get_feature_vsa malloc success

Aug 13 15:47:14.270: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:


Aug 13 15:47:14.270:  cc_get_feature_vsa count is 1

Aug 13 15:47:14.270: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:


Aug 13 15:47:14.270: :FEATURE_VSA attributes are: feature_name:0,feature_time:809807304,feature_id:42

Aug 13 15:47:14.270: //42/0001E1421700/CCAPI/cc_api_call_setup_ind_common:

   Set Up Event Sent;

   Call Info(Calling Number=25425(TON=National, NPI=ISDN, Screening=User, Passed, Presentation=Allowed),

   Called Number=12813867708(TON=Unknown, NPI=Unknown))

Aug 13 15:47:14.270: //42/0001E1421700/CCAPI/cc_process_call_setup_ind:

   Event=0xC0DF7060

Aug 13 15:47:14.270: //-1/xxxxxxxxxxxx/CCAPI/cc_setupind_match_search:

   Try with the demoted called number 12813867708

Aug 13 15:47:14.270: //42/0001E1421700/CCAPI/ccCallSetContext:

   Context=0x410A09B4

Aug 13 15:47:14.270: //42/0001E1421700/CCAPI/cc_process_call_setup_ind:

   >>>>CCAPI handed cid 42 with tag 2 to app "_ManagedAppProcess_Default"

Aug 13 15:47:14.270: //42/0001E1421700/CCAPI/ccCallProceeding:

   Progress Indication=NULL(0)

Aug 13 15:47:14.274: //42/0001E1421700/CCAPI/ccCallDisconnect:

   Cause Value=1, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)

Aug 13 15:47:14.274: //42/0001E1421700/CCAPI/ccCallDisconnect:

   Cause Value=1, Call Entry(Responsed=TRUE, Cause Value=1)

Aug 13 15:47:14.274: //42/0001E1421700/CCAPI/cc_api_get_transfer_info:

   Transfer Number Is Null

Aug 13 15:47:14.274: //42/0001E1421700/CCAPI/cc_api_call_disconnect_done:

   Disposition=0, Interface=0x30B3AE2C, Tag=0x0, Call Id=42,

   Call Entry(Disconnect Cause=1, Voice Class Cause Code=0, Retry Count=0)

Aug 13 15:47:14.274: //42/0001E1421700/CCAPI/cc_api_call_disconnect_done:

   Call Disconnect Event Sent

Aug 13 15:47:14.274: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:


Aug 13 15:47:14.274: :cc_free_feature_vsa freeing 3044ADC0

Aug 13 15:47:14.274: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:


Aug 13 15:47:14.274:  vsacount in free is 0

BN-USHUM01-RTR01#

brmeade Mon, 08/13/2012 - 08:52
User Badges:
  • Silver, 250 points or more

Your outbound dial-peers are not matching as you are not sending the prefixed 9.  Either send the 9 from CUCM or remove the 9 prefix from each of your outbound dial-peers.

Arturo Alejandr... Mon, 08/13/2012 - 09:05
User Badges:

Could you put a "show dial-peer voice summary"


try to remove the trunk-gproup


!

voice-port 0/0/0

trunk-group outbound

connection plar 25425

!


and  add


dial-peer voice 6 pots

description Local

destination-pattern 9[2-9].........

port 0/0/0

forward-digits 10

no register e164

!   




and put this command to verify if the local numer is routed to correct dial-peer


sh dialplan number 95554554455


regards

markedavis Mon, 08/13/2012 - 09:14
User Badges:

Thanks, the dialpeer is what was getting me.  Chaned the predot in the call manager to none and all is working.

Actions

This Discussion

Related Content