Inconsistant Calling

Unanswered Question
Aug 14th, 2012
User Badges:

Hey there,


Setting: 2 phones (7962's) connected to POE switch (3750) which has a link to 2911 running SIP CME 9.0...


State: Both phones register perfectly with newest SIP code.


Condition: 1 out of every 3 call's from either phone to the other fails... no ring on the destination phone... So one call works... call completes, 2 way talk path, then hang up and redial, and no ringy... Is this potentually a DTMF relay issue? I have dtmf-relay sip-notify enabled on all pools...


Ideas?




See config below:


version 15.1

service timestamps debug datetime msec

service timestamps log datetime

service password-encryption

!

hostname TEST

!

boot-start-marker

boot-end-marker

!

!

logging buffered 20000

enable secret XXXXX

!

no aaa new-model

!

!

no ipv6 cef

ip source-route

ip cef

!

!

!

ip multicast-routing

ip dhcp excluded-address 192.168.222.0 192.168.222.10

!

ip dhcp pool phones

network 192.168.222.0 255.255.255.0

domain-name Test123.com

default-router 192.168.222.1

option 150 ip 192.168.100.1

!

!

no ip domain lookup

ip domain name Test123.com

!

multilink bundle-name authenticated

!

!

!

!

!

!

template 1

!

!

voice-card 0

!

!

!

voice service voip

allow-connections sip to sip

no supplementary-service sip handle-replaces

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

sip

  bind control source-interface Loopback0

  bind media source-interface Loopback0

  registrar server

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729r8

!

!

voice register global

mode cme

source-address 192.168.100.1 port 5060

timeouts interdigit 3

max-dn 100

max-pool 50

load 7962 SIP42.9-3-1-1S

authenticate register

authenticate realm all

timezone 6

tftp-path flash:

create profile sync 0006074543342742

ntp-server 192.168.100.1 mode directedbroadcast

!

voice register dn  1

number 1111

name IP Phone1 1111

label IP Phone1 1111

!

voice register dn  2

number 1112

name IP Phone2 1112

label IP Phone2 1112

!

voice register dn  3

number 1113

name IP Phone3 1113

label IP Phone3 1113

!

voice register dn  4

number 1114

name IP Phone4 1114

label IP Phone4 1114

!

voice register dn  5

number 1115

name IP Phone5 1115

label IP Phone5 1115

!

voice register dn  6

number 1116

name IP Phone6 1116

label IP Phone6 1116

!

voice register template  1

button-layout 1-3 line

button-layout 4-6 speed-dial

network-locale 1

user-locale 1

!

voice register pool  1

fastdial 2 1112

fastdial 6 1116

id mac A418.7529.4925

type 7962

number 1 dn 1

template 1

dtmf-relay sip-notify

voice-class codec 1

username test password test

description Phone One

no vad

!

voice register pool  2

id mac A418.7528.5775

type 7962

number 1 dn 2

template 1

dtmf-relay sip-notify

voice-class codec 1

username test2 password test

description Phone Two

no vad

!

voice register pool  3

id mac A418.7529.34DE

type 7962

number 1 dn 3

template 1

dtmf-relay sip-notify

voice-class codec 1

username test3 password test

description Phone Three

no vad

!

voice register pool  4

id mac A418.7528.F2F4

type 7962

number 1 dn 4

template 1

dtmf-relay sip-notify

voice-class codec 1

username test4 password test

description Phone Four

no vad

!

voice register pool  5

id mac A418.7528.F451

type 7962

number 1 dn 5

template 1

dtmf-relay sip-notify

voice-class codec 1

username test5 password test

description Phone Five

no vad

!

voice register pool  6

id mac F4EA.6749.6C1A

type 7962

number 1 dn 6

template 1

dtmf-relay sip-notify

voice-class codec 1

username test6 password test

description Phone Six

no vad

!

!

!

!

license udi pid CISCO2911/K9 sn xxxxx

license accept end user agreement

!

!

username test privilege 15 password 7 XXXXX

!

redundancy

!

!

ip tftp source-interface Loopback0

!

!

interface Loopback0

ip address 192.168.100.1 255.255.255.255

ip ospf 1 area 0

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/2.100

description To_3750

ip address 192.168.222.1 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/0/0

no ip address

!

interface GigabitEthernet0/0/1

no ip address

!

interface GigabitEthernet0/0/2

no ip address

!

interface GigabitEthernet0/0/3

no ip address

!

!

router ospf 1

network 192.168.100.0 0.0.0.255 area 0

!

ip forward-protocol nd

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

!

!

!

!

!

tftp-server flash0:/Cisco7962/apps42.9-3-1TH2-5.sbn alias apps42.9-3-1TH2-5.sbn

tftp-server flash0:/Cisco7962/cnu42.9-3-1TH2-5.sbn alias cnu42.9-3-1TH2-5.sbn

tftp-server flash0:/Cisco7962/cvm42sip.9-3-1TH2-5.sbn alias cvm42sip.9-3-1TH2-5.

sbn

tftp-server flash0:/Cisco7962/dsp42.9-3-1TH2-5.sbn alias dsp42.9-3-1TH2-5.sbn

tftp-server flash0:/Cisco7962/jar42sip.9-3-1TH2-5.sbn alias jar42sip.9-3-1TH2-5.

sbn

tftp-server flash0:/Cisco7962/SIP42.9-3-1-1S.loads alias SIP42.9-3-1-1S.loads

tftp-server flash0:/Cisco7962/term62.default.loads alias term62.default.loads

!

control-plane

!

!

!

!

mgcp profile default

!

!

!

!

!

gatekeeper

shutdown

!

!

!

line con 0

login local

line aux 0

line vty 0 4

privilege level 15

login local

transport input ssh

line vty 5 15

privilege level 15

login local

transport input ssh

!

scheduler allocate 20000 1000

ntp source Loopback0

ntp master 1

end

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
paolo bevilacqua Tue, 08/14/2012 - 22:36
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

For best results, use phones with SCCP firmware, not SIP.

You will have more features, and less bugs.

sterdnotshaken Wed, 08/15/2012 - 08:44
User Badges:

I appreciate your response Paolo. I really would like to get this up and running in SIP CME per the potential of running video phones (9971, etc...) which only run SIP code...


Any good debugging commands that may shed some light on this situation? Here are some that I have tried:


debug ccsip message

debug voip dialpeer all


and multiple others... with the ccsip debug command when the phone doesn't ring, there is no SIP debug dialog logged...


Thanks!

Actions

This Discussion