×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

etherchannel and user traffic

Unanswered Question
Aug 16th, 2012
User Badges:
  • Bronze, 100 points or more

Hi everybody.


Here I am again with another silly scenario.


If one of the link in etherchannel goes down, then Pagp or LCAP simply shifts the load from failed link to other active links in etherchannel.

The question is  should we expect the same behavior if etherchannel is configured statically using  channel-protoco 1 mode on ?


Below is my lab set up:


host 2------SW1 f1/1---------------f1/1 SW2-----host4

                       f1/2---------------f1/2


f1/1 and f1/2 on both switches are bundled in etherchannel which is acting as a trunk.


hos2 ip 199.199.199.2

host4  ip  199.199.199.4


Sw1 has default load balance method i.e src-dst -ip  for etherchannel


etherchannel is configured statically with :

channel -protocol mode on on both switches.


Sw1 and Sw2 assign port index as:


port index 0    f1/1

port index 1    f1/2


Let say host2  sends a ping packet to host4 ( 199.199.199.4).

Focusing only on the path this packet will take, following will occur:


Sw1 receives the packet and Perform XOR operation on the right most bits of src ip( 199.199.199.2) and destination ip ( 199.199.199.4)

.

the last octet of 199.199.199.2 is:

.2 -->   0 0 0 0 0 010


The last octet of 199.199.199.4 is:

.4---> 0 0 0 0 0100.


Performing XOR operation on the right most bit will yield


0 XOR 0= 0


So sw1 will use link f1/1 because port index assigned to it in etherchannel is 0 to forward ping packets.


Now what would happen  link f1/1 for some reason goes down, Will sw1 drop ping packet sourced from 199.199.199.2 and destined to 199.199.199.4 ?

Will sw1 simply use the other link i.e  f1/2 to foward  them?



I simulated the above scenario by shutting down f1/1 on sw1. First let me show you the output before I  disabled the portf1/1 on sw1.

( I am using router for host below)


host2#ping 199.199.199.4


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 199.199.199.4, timeout is 2 seconds:

!!!!!


SW1 output:



SW1#show etherchannel port

                Channel-group listing:

                -----------------------


Group: 1

----------

                Ports in the group:

                -------------------

Port: Fa1/1

------------


Port state    = Up Mstr In-Bndl

Channel group = 1           Mode = On/FEC     Gcchange = 0

Port-channel  = Po1         GC   = 0x00010001    Pseudo port-channel = Po1

Port index    = 0

Age of the port in the current state: 00d:00h:01m:51s

Port: Fa1/2

------------


Port state    = Up Mstr In-Bndl

Channel group = 1           Mode = On/FEC     Gcchange = 0

Port-channel  = Po1         GC   = 0x00010001    Pseudo port-channel = Po1

Port index    = 1

Age of the port in the current state: 00d:00h:05m:50s




====================================================================


Everything is working normal thus far.




Now lets disables the port f1/1 on sw1.

SW1(config)#int f1/1

SW1(config-if)#shutdown



*Mar  1 00:22:23.991: %LINK-5-CHANGED: Interface FastEthernet1/1, changed state to administratively down

Sw1#show etherchannel summary

Flags:  D - down        P - in port-channel

        I - stand-alone s - suspended

        R - Layer3      S - Layer2

        U - in use

Group Port-channel  Ports

-----+------------+-----------------------------------------------------------

1     Po1(SU)     Fa1/1(D)   Fa1/2(P)



The port f1/1 is down


Next , we have h2 send ping packet and let see what happens.



host2#ping 199.199.199.4


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 199.199.199.4, timeout is 2 seconds:

.!.!.

Success rate is 40 percent (2/5), round-trip min/avg/max = 1572/1744/1916 ms


===============================================================

1)Based on the above result, it appears to me sw1 does shift the load from failed link to other active links in etherchannel. Is it true or Is it some bug in IOS? ( keep in mind the etherchannel in our case is staticallly configured using channel-group 1  mode on)


2) If you look at the output below


.!.!.




First packet no response

second packet response

third packet no response

fouth packet response

fifth packet no response



I do not understand why we are getting response for some pings packets and no response for others?


thanks and have a great day.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
sarahr202 Fri, 08/17/2012 - 07:34
User Badges:
  • Bronze, 100 points or more

Well I got the answer for first question thanks to Peter.


1)  Etherchannel will simply shifts the load from failed link to another active link in etherchannel.


2) As for question 2, I still do not understand why  weare not getting response for some ping packets.

  Strangely enough, when i issued the ping command at host2, sw1 drops ping alternatively for e.g


Ist time when ping 199.199.199.2 issued at h2, I find :

first ping no response

second ping response

third ping no response

fourth ping response

fifth ping no response.


The 2nd time when issued the ping 199.199.199.2 at host2, i find :

firstping response

second ping no response

third ping response

fourth ping no response

fifth ping response.


sw2 at the other side has both ports active in etherchannel and it is alternatively using ports f1/1 and f1/2 in etherchannel to forward ping replies from host4.


Your input will ge greatly appreciated.

nkarthikeyan Sat, 08/18/2012 - 02:34
User Badges:
  • Gold, 750 points or more

Hi Sara,


I guess here IOS and the device model plays the major roles in the etherchannels. Because when i looked at your post i have simulated in a cisco packet tracer as well as in my lab setup where i have 4560 Sup 2+ and 3750-12G switch.


When i tried with the packet tracer..... i found the dfficulties as such whatever you have observed. actually more than that.


But in my LAB when i did the same thing with 4506 and 3750 i couldn't find any issues. when we have the 1 link goes down there is a drop for a moment and after that everything looks well.



Please do rate if the given information helps.


By


Karthik

Actions

This Discussion