ASA software update questions

Unanswered Question
Aug 21st, 2012
User Badges:

Hello,



I'd like to update our current ASA appliances software version 8.2(2) and ASADM version 6.2(5) to the latest ones but we've heard that there is possible an issue between our current version with the latest one which would wipe out our current ACL when it upgraded. Can anyone please confirm this?



Thanks.

.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
varrao Tue, 08/21/2012 - 07:01
User Badges:
  • Red, 2250 points or more

Hi,


It would not wipe out but convert your NAT and ACL's to a new syntax, because post 8.3 version, there are changes in the nat and acl syntax on ASA. My recommendation would be to understand these changes first before upgrading, you would find lots of threads and documents on this forum for it. You can also google for the release notes for the latest software version to understand the changes. Let me know if you need any help with it.



Thanks,
Varun Rao
Security Team,
Cisco TAC

Ramraj Sivagnan... Tue, 08/21/2012 - 07:01
User Badges:
  • Silver, 250 points or more

Hi Bro

Yes, you can upgrade your Cisco ASA from 8.2.X to 8.4.X but you need to ensure you've adequate memory for this. For steps in upgrading to version 8.4. along with some helpful do's and dont's, you could refer to http://www.cisco.com/en/US/docs/security/asa/asa84/release/notes/asarn84.html#wp495651


There won't be any change in most parts of your configuration including your ACLs, unless of course your ACLs are using object-groups currently. Furthermore, the NAT commands are totally different in version 8.4. I must say, it's rather confusing, especially for someone like me who's been dealing with Cisco Firewalls since version 6.X days.


If you were to ask me, if everything is running fine now, don't upgrade. Yes, I agree in version 8.4, it supports much more newer features and resolves a lot of the oustanding known issues/bugs but I wouldn't recommend upgrading.

Actions

This Discussion

Related Content