problem to configure 2x ISR cisco 886 in ISDN

Endorsed Question
Aug 29th, 2012

Hi,

I'm trying to configure 2 routers (cisco 886) to create a link between them via ISDN link (in france) but it doesn't work

I think I put a base conf but nothing work :

LAN 1 (192.168.220.0/24) => BRI0 (172.23.240.1) Cisco 886 <= ISDN =>  BRI0 (172.23.240.2) Cisco 886 => LAN 2 (192.168.255.0/24)

both conf are about the same (not IP and phone number) :

...

interface BRI0

ip address 172.23.240.1 255.255.255.0

encapsulation ppp

dialer idle-timeout 600

dialer string xxxxxxxxxxxxx

dialer-group 1

isdn switch-type vn3

isdn termination multidrop

isdn point-to-point-setup

ppp authentication chap

!

interface Vlan1

ip address 192.168.220.254 255.255.255.0

!

ip route 0.0.0.0 0.0.0.0 172.23.240.2

!

dialer-list 1 protocol ip permit

!

...

I will add more later an authentication.

Si if you have an idea, that would be great.

Thanks

Regards

Nicolas

I have this problem too.
0 votes
Endorsed by Peter Paluch
Giuseppe Larosa about 1 year 7 months ago

Hello Nicolas,

I would try after removing the lines

interface bri0

no isdn point-to-point-setup

no isdn termination multidrop

These are not needed in a minimal configuration.

To see what happens you can use

show isdn status

This show is very handy as it shows ISDN Layer1, Layer2, Layer3

debug isdn q921

debug isdn q931

debug ppp negotiation

debug ppp authentication

debug dialer

you need to trigger a call pinging a remote destination

see the following documents

http://www.cisco.com/en/US/docs/internetworking/troubleshooting/guide/tr1917.html

http://www.cisco.com/en/US/tech/tk801/tk379/technologies_tech_note09186a0080094bb8.shtml

Hope to help

Giuseppe

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (2 ratings)
Giuseppe Larosa Wed, 08/29/2012 - 07:52

Hello Nicolas,

I would try after removing the lines

interface bri0

no isdn point-to-point-setup

no isdn termination multidrop

These are not needed in a minimal configuration.

To see what happens you can use

show isdn status

This show is very handy as it shows ISDN Layer1, Layer2, Layer3

debug isdn q921

debug isdn q931

debug ppp negotiation

debug ppp authentication

debug dialer

you need to trigger a call pinging a remote destination

see the following documents

http://www.cisco.com/en/US/docs/internetworking/troubleshooting/guide/tr1917.html

http://www.cisco.com/en/US/tech/tk801/tk379/technologies_tech_note09186a0080094bb8.shtml

Hope to help

Giuseppe

Peter Paluch Wed, 08/29/2012 - 11:41

Hi Nicolas,

Can you post your current working configuration so we can compare the changes? Thanks!

Best regards,

Peter

nvanhaute Wed, 08/29/2012 - 23:14

Hi Peter,

sure, see interesting lines below :

...

isdn switch-type vn3

...

!

interface BRI0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type vn3

isdn termination multidrop

isdn point-to-point-setup

ppp authentication chap pap callin

!

...

!

interface Vlan1

ip address 192.168.220.254 255.255.255.0

!

interface Dialer1

description vers CLG

ip address 172.23.240.1 255.255.255.0

encapsulation ppp

dialer pool 1

dialer remote-name CLG285-RN01

dialer idle-timeout 180

dialer string xxxxxxxxxx

dialer-group 1

ppp authentication chap callin

!

...

!

ip route 0.0.0.0 0.0.0.0 Dialer1

!

dialer-list 1 protocol ip permit

!

...

Nicolas

Peter Paluch Thu, 08/30/2012 - 00:01

Hi Nicolas,

Wonderful, thanks! So you basically moved away from configuring the physical BRI interface (a so-called "Legacy DDR" approach) and instead you moved to Dialer profiles. Very good.

Best regards,

Peter

Actions

Login or Register to take actions

This Discussion

Posted August 29, 2012 at 4:47 AM
Stats:
Replies:5 Avg. Rating:5
Views:519 Votes:0
Shares:0
Tags: configure, isdn, isr, 886
+

Related Content

Discussions Leaderboard