ROMMON lseek out of bounds and getdirent: lseek error

Unanswered Question
Aug 29th, 2012

Hello,

I have a 2600 router i indend to use as an access server. I doesnt have an IOS so i downloaded via tftp. I should see the file at dir flash:, but all i get are these error

--------------------------------------------------------------------------------------------------------

System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)

Copyright (c) 1999 by cisco Systems, Inc.

TAC:Home:SW:IOS:Specials for info

PC = 0xfff0a530, Vector = 0x500, SP = 0x680127b0

C2600 platform with 65536 Kbytes of main memory

----------------------------------------------------------------------------------------------------------

rommon 1 > dir flash:

         File size           Checksum   File name

lseek out of bounds

getdirent: lseek error

rommon 2 >

And if i tried to download again the file, its failing because it seems that there aren't any space available in my flash. Heres the meminfo.

rommon 2 > meminfo

Main memory size: 64 MB.

Available main memory starts at 0x10000, size 65472KB

IO (packet) memory size: 0 percent of main memory.

NVRAM size: 32KB

rommon 3 >

Here's the download

rommon 14 > tftpdnld

          IP_ADDRESS: 172.16.15.223

      IP_SUBNET_MASK: 255.255.255.0

     DEFAULT_GATEWAY: 172.16.15.231

         TFTP_SERVER: 172.16.15.205

           TFTP_FILE: c2600-c-mz.123-23.bin

Invoke this command for disaster recovery only.

WARNING: all existing data in all partitions on flash will be lost!

Do you wish to continue? y/n:  [n]:  y

Performing tftpdnld over Fast Enet.

Interface is operating at: 10Mbps/FULL DUPLEX

Initializing interface.

Interface link state down.

Interface link state up.

ARPing for 172.16.15.205

ARPing for 172.16.15.205..

ARPing for 172.16.15.205

ARPing for 172.16.15.205..

ARPing for 172.16.15.205

ARPing for 172.16.15.205..

ARPing for 172.16.15.205

ARPing for 172.16.15.205..

ARPing for 172.16.15.205

ARPing for 172.16.15.205..

ARPing for 172.16.15.205

ARP reply for 172.16.15.205 received.  MAC address 48:5b:39:ee:dd:ff

Receiving c2600-c-mz.123-23.bin from 172.16.15.205 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

File reception completed.

TFTP flash copy: Error, image size (18522732) larger than flash (8388608).

rommon 15 >

Even if im not seeing some file/s on my dir flash: command i executed boot nevertheless.

rommon 15 > boot

lseek out of bounds

getdirent: lseek error

boot: cannot determine first file name on device "flash:"

So tried a network boot

rommon 16 > boot c2600-c-mz.123-23.bin 172.16.15.205

lseek out of bounds

getdirent: lseek error

an alternate boot helper program is not specified

(monitor variable "BOOTLDR" is not set)

and unable to determine first file in bootflash

loadprog: error - on file open

boot: cannot load "c2600-c-mz.123-23.bin 172.16.15.205"

rommon 17 >

Here's what i think. The first file dowload could be corrupted and it eats up the space on my flash.

My question is how can I reformat the flash so that I can redownload the IOS? And if in case that fails also, any other way i can recover this machine

Thanks,

Jon

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
Sandeep Choudhary Wed, 08/29/2012 - 22:18

Hi Jonjon,

Use the xmodem procedure to download it to the router

Regards

Please rate if it helps.

jonjon.mata Wed, 08/29/2012 - 22:24

Hi,

Thats what im trying right now, already in progress. Hope it'll work (crossing fingers)

thanks,

Jon

jonjon.mata Sun, 09/02/2012 - 20:56

Hi Sandee,

After several attmepts, the same errors

rommon 2 > xmodem c2600-bin-mz.123-18.bin

Do not start the sending program yet...

         File size           Checksum   File name

lseek out of bounds

getdirent: lseek error

WARNING: All existing data in bootflash will be lost!

Invoke this application only for disaster recovery.

Do you wish to continue? y/n  [n]:  y

Ready to receive file c2600-bin-mz.123-18.bin ...

Erasing flash at 0x607c0000

program flash location 0x60800000program flash: address 0x60800000 not valid - aborting

rommon 3 >

I've tried the ios and the same proceedure on another router and even on the gns3, it works fine. Im thinking of reformatting the flash, but couldn't find the right procedure on a cisco 2620 router.

Actions

Login or Register to take actions

This Discussion

Posted August 29, 2012 at 9:04 PM
Stats:
Replies:4 Avg. Rating:
Views:1075 Votes:0
Shares:0
Tags: rommon, error, out
+

Related Content

Discussions Leaderboard

Rank Username Points
1 2,069
2 1,732
3 1,675
4 1,624
5 1,529