×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

VLAN membership lost after reboot (SG300-20)

Unanswered Question
Sep 1st, 2012
User Badges:

I have a problem that is really bugging me. I have two Cisco SG300-20 switches. Both of them are configured in L3 mode. They have several VLAN's configured.


When I reboot my switches some VLAN membership settings are lost! I have already saved the settings over and over before rebooting, and even tried to save it to the backup memory and so on. Say for example I have changed port 9 to 14 from VLAN 101 to VLAN 105. I save the configuration, reboot the switch. And then the changes are lost. This is a big problem, because servers and my iSCSI network loose connectivity. They already have the latest firmware. This issue was there three firmwares before.


This issue pop-ups when I have a power loss, or I need to reboot/shutdown them manually. It may be off-topic but I also have the feeling that the performance of the switches goes down during uptime. A reboot solves the performance issue. I don't have a performance benchmark, but I can notice it on the performance transfer rate between clients and servers.


Any suggestions?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Tom Watts Sat, 09/01/2012 - 09:01
User Badges:
  • Green, 3000 points or more

Hi Boudewijn, I think what you're experiencing is "auto smart port". These macros will negotiate the links on your network based off CDP and LLDP advertisements.


I think if you disable the smart port roles globally and per port your issue may go away


config t

macro auto disable

interface range gi1-20

no macro auto smartport


Keep in mind, removing these features also removes the auto voice vlan functionality.



-Tom
Please rate helpful posts

Boudewijn Plomp Tue, 09/04/2012 - 10:24
User Badges:

Thomas, I think you are pointing me into the right track! Although I am a bit familiar with smarport. I have checked the settings and can't find anything that might cause it. Of course worth to try.


Because I was having problems I reset the switch to factory defaults and reconfigured it. Right now, I don't have a problem anymore. I haven't reset my other swtich but I did disable smartport. I just haven't found a moment yet to reboot it. Once I have done that I will let you know. Thanks!    

Tom Watts Tue, 09/04/2012 - 10:29
User Badges:
  • Green, 3000 points or more

Boudewijn, please make sure to save the running config to start up config


copy run start


-Tom
Please rate helpful posts

Petty Talamayan Fri, 01/08/2016 - 09:34
User Badges:

SF302-08P - updating to the recent firmware of 1.3.17.18 including boot, reset to factory default.  use hyper terminal to reconfigure switch, to disable smartports per Tom's commands above, reconfigure VLANS on all ports, save mem and reboot.  I tested the reboot, even did several power cycle and the fix solved the issue that I have been trying to figure out myself.


After the successful test, copied the running config of the reconfigured switch, downloaded it to another sf302-08p (make sure to edit the management IP of the running config file), did reboot, powercycle, success.....


Thanks Tom for the solution.

Boudewijn Plomp Sat, 09/08/2012 - 12:51
User Badges:

Here is an update. As mentioned one switch is factory reset and is working properly. Now, on the other switch I have fully disabled auto smartpot. Today I have rebooted that switch. And again... VLAN membership gone for 6 ports. I am not going to investigate this any further. With a week I will factory reset the switch.

Actions

This Discussion

Related Content